Introduction

Help >

Spitronics ECU with Hyperspace Software

This Spitronics ECU hardware is continuously developed to meet requirements for today's market as technology on engines improve. The current models discussed in this manual are Mercury2, Pluto2 sand Saturn. The latest tuning software is Hyperspace ECU version 3.5 which is developed for these models. This manual covers software and hardware explanations. Wiring diagrams are kept in separate manuals for simplicity.

Read the subfolders on how to use this manual.

Copyright © 2013. All rights reserved.


About the Manual

Help > Introduction >

About this Manual

The Spitronics Hyperspace ECU Manual is a comprehensive informative database which includes all the relevant ECU products. Explanations on software and hardware operations are covered in this manual. Due to the type of product and functionality there is a lot of information, so please read the instructions below on how to promptly navigate to the section you require. Note: Only explanation drawings are placed in this manual, complete wiring diagram drawings are kept in separate manuals due to the vast amount of different drawings. (See the part on Selecting Wiring Diagrams in this folder.)

Always start with the Terms & Conditions of this product displayed in this folder. You need to know how this product is presented to the public should you have any queries later. It is also by Law that theses T&C's must be visible and read by you and your valued customer. Failure to comply with this legislation may lead to legal action and/or undesirable complications.

Work through the Product Selection and understand the differences between the products and how to select the best one for your application. (See the selection charts.) If you still have difficulty please feel free to email us under support found on www.spitronics.com and we'll be glad to assist you.

Note: It is detrimental that you start with the Safety Precautions for your product before you begin installation. This will prevent unnecessary costs, mistakes and negligence and prevent time from being wasted. The FAQ came about from common mistakes that customers have made in the past. Remember these are electronic products and they can be damaged if not installed correctly and/or used in the prescribed manner.

How to use the manual

Contents

This is the main contents list. All the information is categorized and speaks for itself.

Note: The software explanations are in the same menu manner displayed as found on the software itself.

For example: The ECU setup has been categorized, as it is found in the setup menu tab, as in the software.

Search

To find a subject, click on the Search tab and type the word, click on List Topics. Then click on the Items displayed and it will guide you to the specific document.

The Back key (or Alt+Left Arrow) will take you back to the previous view.

You may print parts of this document with the Print button.

These buttons will take you in and out of sub folders in the menu.

Quick Links

The last topic in the manual is Quick links. This may be the handiest page to find quick items. The list is in alphabetical order. It has relevant Software or Hardware topics. When you click on a link it will open the manual on the relevant page. If you click on the [image] button then it will show you where it is in the list and you can view data from there.

Below some of the pages you will find related links to guide you to information that may also relevant at that stage or for that specific application. Use the Back key to go to the previous page. (See above links as example of the related links as explained.)


Abreviations

Help > Introduction >

Abbreviations

AC Alternating Current
AFR Air to Fuel Ratio
ATDC After Top Dead Centre
BDC Bottom Dead Centre
BTDC Before Top Dead Centre
CAS Crank Angle sensor
COP Coil On Plug
DC Direct Current
DP Differential Pressure
Drv Driver
ECU Engine Control Unit
EFI Electronic Fuel Injection
EGR Exhaust Gas Recirculation
EGT Exhaust Gas Temperature
F/S Full Sequential
GS Galaxy Software
GP General Purpose
HOME Pulse on a camshaft sensor that comes once every second revolution
HS Hyperspace Software
HT High Tension (spark plug leads)
HV High Voltage
IAC Idle Air Control
IAT Intake Air Temperature
Imp Impedance
Int Internal
MAP Mean Absolute Pressure
NOS Nitrous Oxide System
OEM Original Engine Management
PWM Pulse Width Modulation
RPM Revolutions Per Minute
Seq Sequential
TCU Transmission Control Unit
TDC Top Dead Centre or Pulse on a crank that comes once every revolution
TOT Transmission Oil Temperature
TPS Throttle Position Sensor
TSS Transmission Speed Sensor
TxW Throttle by Wire
V Volt
VE Volumetric Efficiency
VSS Vehicle Speed Sensor
VVT Variable Valve Timing
VVT-I Variable Valve Timing with Intelligence
VVTL-I Variable Valve Timing with Lift and Intelligence

WOT Wide Open Throttle

W/S Wasted Spark


Version Changes

Help > Introduction >

Version Changes

The sub folder will explain what changed from the previous version to the discussed one. If you skipped versions take time out to read all the versions in between.


Version Changes in Ver 3.5A

Help > Introduction > Version Changes >

Version Changes in Ver 3.5A

Each version change will have changes in the software or firmware. This document will explain the changes from Galaxy Ver 3.5 to Hyperspace Ver 3.5A. Note that Ver 3.5A will open in Galaxy but some of the settings cannot be adjusted in Galaxy. Rather use Ver 3.5. Version 3.5A must be used in Hyperspace. This was done as to commission Hyperspace and let users play with both versions while the software was commissioned. A few new development features had to come during this process and that's the reason Ver 3.5A was born.

Software

Galaxy is a comprehensive package that has to be installed on a Laptop. It includes handling of all versions in different packages like ECU or ECU. The latest firmware version that Galaxy can handle, is ECU Ver 3.5. This Software will be discontinued for new versions of firmware.

Hyperspace is the new software that will take over from Galaxy. This software will cover Ver 3.5 onwards. It cannot run older versions of the ECU firmware. It is a standalone package and can be run quickly without hassles with anti-virus programs and internet connections. It is very fast to open and tune. The manual is embedded in the software. Note that each version will have its own software release which will be saved on the website. If you use the wrong version, the software will indicate which version is the right one to use for your firmware.

The Major changes are listed below:

Hyperspace Firmware Ver 3.5A

MAP Names has changed between Galaxy and Hyperspace with different extension names. Them MAP's are the same otherwise. Galaxy used a filename.galaxy for all maps. In Hyperspace we decided to split them to make it more identifiable for the software to only show relevant maps. Examples will be filename.spiecu for ECU maps, filename.spiticu for TCU maps and so forth. The spi part indicate Spitronics and then the last part what type of map it is. You may change the extensions from .galaxy to Hyperspace extensions to use the map on the newer software.

The MAP Lock Password was moved in memory with the critical setup values. This is to do the Clone feature without the need for a programmer. One symptom is when you load the Ver 3.5A firmware, the device will be locked by a password because it was not cleared before. The remedy is to save your maps before you upgrade the firmware and then load map 1 in after upgrade, with the Clone function. Then put the ECU in map 2 and load map 2 in. See the MAP Lock feature.

The crank and cam sensor is renamed to make it more acceptable. Crank(TDC) is used instead of Trigger and Cam(Home) is used instead of TDC. Home Teeth is incorporated to make provision for different Cam pulses on different engines for the same crank pulse. This will greatly reduce the number of firmware programs to cater for the different car manufacturers.

The Retard and Launch functions share the same input. With 3.5A we made the selection here to make it less confusing.

The Fuel Calculation selection is the master setting for fuel and timing tuning. It will adjust the Timing Calculation setting to be the same as this setting. A refresh will happen to reset the timing calculation setting. Both fuel and time must be on the same algorithm due to altitude sensor that changes the MAP signal.

Altitude Compensation was changed in different tuning algorithms. Some will affect the fuelling method when you upgrade to ver 3.5A. Make sure about your AFR afterwards.

When Matrix TPS is selected, the Lambda Target Volts graph changes from Map compensation to TPS compensation. This will let the Lambda control feature be used with this fuel calculation method without the need of a map sensor. Altitude compensation did not work on this TPS matrix before. It is now correctly implemented.

This method had a different way of working with altitude compensation which pose some accuracy problems with turbo engines. It is now corrected and can be used successfully. See the Tuning section.

Graph names were changed to make more sense. First part of the name is describing what is will change. The second part describes the real-time signal acting on the graph.

Ex. Lambda Target Volts - Manifold Pressure Compensation (Bar)

Matrix adjustable values are restricted by the Maximum Timing and Maximum Fuel values. At start-up values exceeding the limits will be lowered to maximum value and at save it will be written to the ECU.


Version Changes in Ver 3.5B

Help > Introduction > Version Changes >

Version Changes in Ver 3.5B

This document will explain the changes from Hyperspace Ver 3.5A to Hyperspace Ver 3.5B. Note that Ver 3.5B will open in Galaxy but the settings cannot be adjusted. Please not that most of these features require the Ultimate class for your device hardware. Also refer to the Excel spreadsheets for correct driver placement on the devices. Also note that not all the features discussed in this document will operate in all the version 3.5B firmware. Some files require more drivers than are available in the devices. These files will be named for each engine combination like this 4 Cylinder example:

Mercury2 4Cyl Ver3.5B GP Output Priority Layout.xlsx

Launch Limiter with Delayed Release

This feature will allows for a slow increase in Launch limiter RPM when it is released. It will help with traction because then engine power is slowly returned to normal. This setting is a prototype feature and use the Auxiliary 1 register which will be visible.

This value set can be adjusted in 100 milliseconds resolution. 30 will result in 3 seconds delay to rise 2000 rpm. Ex. If launch rpm is 4000 and you release the clutch then the limiter will increase over 3 seconds to 6000 rpm. Another example if the value is 23 then it will take 2.3 seconds to raise the limiter from 4000 to 6000 RPM. It can be used during shifts to higher gears by touching the launch button. The time at this stage will be the same for all the gears.

For this feature to operate Tuning POT must be set to Launch and Launch Activation must be set to Clutch so that a launch button can be used.

Launch, Anti-lag and Retard Timing

The timing for these 3 functions can be adjusted down to 30 degrees after TDC when the feature is activated. This will help spin a turbo more smoothly without the engine going over the launch RPM value.

Injector Trimming

The Injector trim works in full sequential mode. See the manuals for more description on the different engines. Always tune the engine with 100% values and then do fine adjustments. Note that you will require EGT sensors or individual Lambda sensor to perform this task properly.

Cam sensor sink timing

The new version of home sink is implemented in this program. Below is an abstract from the latest manual.

Cam (Home)

The cam angle sensor will always be situated on a cam shaft. It could be a lone sensor in the valve cover or in a distributor. This signal only came with later models when full sequential injection was introduced. Some distributors like Nissan and Toyota had both sensors in the distributor. The cam signal will give a unique pattern over two revolutions, allowing the ECU to detect which revolution is the firing stroke. This signal could be one pulse or a number of pulses. The ECU can compare it with the crank signal pattern and determine firing stroke.

This feature is incorporated in the new version 3.5B firmware to determine a home pulse position from different cam signals. Each manufacture uses a different cam pattern. One of the cam sensors must be connected to the ECU and selected. During setup, start with teeth 1 and crank the engine. It should show missing home pulses on the error codes. Increase the value and press C for clear after each adjustment. If the error stops appearing, at for example 4, then continue increasing till you see the error again. If the value is 10, for example, then set the teeth setting in the average of 7 teeth. Now the ECU knows the difference in stroke 1 and stroke 3 of the engine. One will have a pulse within 7 teeth after the slot and 3 will have no pulses.

Full Sequential Spark

This feature can do full sequential spark on the gear type triggers. Note that there is a driver for each coil. Should you select wasted spark COP then the coils is still wired one per driver and not externally paired like the Ver 3.5A firmware. With this firmware two pairs of drivers will be pulsed together. To sink the coils with the two revolutions require a setting of the gear teeth. This will determine if it fires on compression or exhaust stroke. This is universal firmware and for some engines it may be on rev one and other ones it may be on rev two after the cam pulse was read. It depends on where and how the cam teeth is designed.

Example:

If you use the 36-1 gear and your timing mark is on 14 then it could also be on 14+36=50. A simple way to test will be to select COP wasted spark.

Now crank and start the engine. You may need to advance the timing if it wants to backfire through the intake. Use gear teeth settings from 1 to 36. If it starts and idle, then calibrate timing with a timing light then save the map. Now select full sequential mode and save again.

Now start the engine. If it starts, then you have the sink pulse right. If not add 36 to your current gear teeth value and save. Crank again and it should start now.

Note that this program needs to find the home signal first before it will start the engine. This will prevent backfire through the intake.

Cam Control Selection

This feature will reduce the number of firmware files required for different engines. Previous version was split in a normal engine or specific VVTI engines. VVTI consists of 2 cam control settings for inlet or exhaust cams. Control is still open loop so for V engines the 2 Cam solenoids are connected on the same driver. It requires only 1 x 3Amp diode to be installed. No input Cam sensors are required in open loop control. Also note that cam control will be 25% duty cycle when Off and 75% duty cycle when On. If your engine requires different control parameters, then you need to load the engine specific firmware.

First you need to select 1 or 2 cam outputs. Note that the software will refresh the setup data as these drivers are shared with GP output drivers. If you don't use cam outputs, then un select them to free up the GP drivers.

Then the cam control block will become visible also indicating which drivers are used for which coil. If no drivers are visible, then the cam selections are not selected.

Take note that Cam1 is used Cyl1 in V engines or Intake Cam. Cam2 is used for the opposite cam than Cam1 or the Exhaust Cam.

Should the engine have an intake Flap then use the V-Tech feature on GP2 for it as it has a TPS limit as well.

Dedicated firmware like the Lexus VVTI will use the Intake block in the VVTI settings block.


Getting Started

Help > Introduction >

Getting Started with Spitronics Devices

About the product.

The Spitronics products are developed primarily for the DIY market, this makes it a more cost effective product as the company's overheads are held to a minimum. Spitronics rather makes use of the extensive infrastructure of dealers that specialize in this type of business. Products are mostly sold through dealers inside South Africa and handy customers and dealers abroad. The Spitronics devices are not plug & play devices but must be customized by the dealer for specific applications. These products are very versatile and can be adapted to most engines and transmissions. The dealer is responsible for after sale service and is a third party company that Spitronics do not have control over. Make sure of the dealer's service capabilities before you buy from them. Spitronics is not responsible for poor service from such outlets and is not affiliated to these entities. Please read our terms and conditions found on our website. All the information, software and manuals are freeware on our website www.spitronics.com

Block Diagram of Product interfacing

How does Spitronics Products Work

Each Spitronics product is Micro based which requires a firmware program to initialize the hardware, and tuning Maps that adjust parameters and graphs for the engine or transmission. The Maps require tuning software so that the tuner can adjust fuel and timing for that application. The product also needs to be activated before it will operate.

1. The firmware will initialize the hardware to work on a specific engine or transmission. This firmware is fixed code and is pre-loaded into the product with the USB Debug Adapter. It is optional for an end user because they will use it only once. The dealer has the option to customize standard hardware for all different applications with this programmer. The firmware files are freeware on our website and has the extension of .HEX. This process is illustrated in step 1 in the diagram above.

2. Spitronics developed an internet activation system to allow dealers abroad to carry stock at a reduced price. Then when the dealer sells to a customer he will activate the unit in a specific hardware class according to the firmware and application of the customer. He will then do a payment for the rest of the amount. He will load the correct firmware and startup Map for the customer and guide him to the correct drawings and settings. He will test the unit on a simulator and verify that everything is in order as to assist the customer. This feature makes the product 'counter ready' without the delay of ordering the product on demand. This process is illustrated in step 2 in the diagram above.

3. The tuning software will allow the tuner to adjust his engine or transmission to his requirement. This could be performance, economy, automatic or tiptronic etc. This tuning data is saved in the product and also in a file called a data Map with the extension .SPIECU or .SPITCU etc. This process is illustrated in step 3 in the diagram above.

What you need to get started:

1. The product hardware and accessories for the specific application. This will be the ECU / TCU, control modules such as idle control and Coil Igniters, harnesses, MAP sensors etc. for that specific application. The product is sold in different classes and are priced according to features and outputs used. There is a chart on the website indicating the different classes. Information on what you need can be found under products and there are selection charts available. However, you may ask a dealer in your area or send a mail to info@spitronics.com

2. The USB / UART communication cable to connect the device on to a laptop for tuning purposes. This cable is sold separately as you'd only need one for tuning all our products. The electronics are installed into the cable which means the product becomes cheaper as each ECU does not require those components. This product has drivers that needs to be installed before it will operate. These drivers can be found on the web under Downloads and USB Drivers.

3. The tuning software to interface with the products. The software is Windows based only and works on all versions. You need a Laptop or Tablet for this.

4. A Startup map which helps with the setup of the specific engine. As each engine differs with minor changes, these MAP's requires a bit of refining. It is a data file that is saved on the hard disk and differs for each type of engine. If you don't get a specific map for your engine you may adapt any map to suit your engine.

5. The manuals for explaining wiring and tuning. These manuals became bulky with all the information but once you browse through them you will get to your info quickly. They are available on the web and is updated from time to time.

Optional requirements.

1. The firmware programmer. This USB Debug Adapter lets you customize the product yourself for any engine or transmission or custom task, if that firmware was developed for it. Firmware is free and placed on the website. You can browse to check if your application is covered. The programmer is also used to download the latest updates available for your application. New features may be added for your convenience. We always recommend buying a programmer to distant customers. Test firmware is also available to help in fault finding.

2. The simulator helps dealers to find faults on customer's units. It is recommended for the dealer that likes to carry stock and help customers over the counter. The latest Simulator2 works on all our products with the exception of different connecting harnesses.

See Installing software and drivers for further explanation.


Installing software and drivers

Help > Introduction >

Installing software and drivers

The Hyperspace software comes with 2 files in a Zip folder. It is standalone meaning it is not installed like most programs. Rather and EXE file that is run from a folder. See the sub folder for more details on this.

The USB/UART tuning cable requires drivers for Windows to operate correctly. There are 2 versions for 32-bit and 64-bit computer cores. See the sub folder for more details on this.

The USB Debug Adapter or Firmware programmer has its own software from the factory. This has to be installed on the laptop to operate. There are a few critical rules around using it. Please do this first to ensure you are not wiping the memory of your device completely. See the sub folder for more details on this.

Classification Software are required to activate units for the first time and also after upgrades are done later. It is a customer user program to do remote activations or upgrades. See the sub folder for more details on this.

Device Tester Software are there to assist in trouble shooting a product and also adding test 2 for dealers. It is a standalone program which is used by dealers. See the sub folder for more details on this.

The software is compressed in WinRar format. It is freeware and could be found at the link below. Follow the instruction from that product manuals.

http://www.7-zip.org/download.html


Hyperspace Tuning software

Help > Introduction > Installing software and drivers >

Hyperspace Tuning software

The tuning software will be compressed in a RAR document. This software can be found on www.spitronics.com under the following path. You may click on the bottom link to download the software.

Hyperspace Tuning Software

After it is de-compressed to a folder on the laptop there will be 2 files as below. Names and dates in the compilations may change but there will be an EXE and Config file

Run the EXE file called Hyperspace ECU 3.5 Beta.exe

Now there will be a couple of folders created as below. AutoSaves and DeviceSaves will hold the files created by the software for later reference. Logs will only be created later should the software encounter errors during operations.

Now copy the EXE file and paste a shortcut somewhere on the desktop for your convenience.

Your Hyperspace software is now ready to start tuning.


USB Tuning Cable

Help > Introduction > Installing software and drivers >

USB Tuning Cable

The USB cable requires drivers for setting it up as a comport in Windows. These drivers can be found on www.spitronics.com under the following path. You may click on the bottom link to download the drivers.

USB Drivers

http://www.spitronics.com/downloads/USB Drivers/Spitronics_USB_Drivers.rar

USB Drivers

The browser should download the drivers in the downloads folder. The drivers file is compressed with WinRAR which is freeware software. Un-compress the file. After uncompressing there should be a folder created as below.

Go into the folder and you should see the following.

If you have a 64bit computer then run the file called

For 32bit computer run the file called

After you installed the driver plug the USB /UART cable into the computer and the cable will be activated. In the device manager you should see the block below in com ports. This means the drivers are installed correctly.

· Your USB cable should now connect the Hyperspace Tuning Software and device for communication.


Firmware Programmer

Help > Introduction > Installing software and drivers >

Firmware Programmer

The USB Debug Adapter or Firmware Programmer as we call it in the manual, are used to download updated firmware or other firmware into the ECU. This unit requires software to be installed and can be downloaded from www.spitronics.com under the following path. You may click on the bottom link to download the software.

Firmware Programmer Software

http://www.spitronics.com/downloads/Firmware Programmer/mcu_ide.exe

This manual can be found under the sub folders. One rule is NEVER press a button called "Erase All Code Space". This will wipe the unit completely and it will have to be returned to the factory. Read through the precautions part before attempting to program your device.


Introduction

Each product has a selection of firmware programs. These programs are the heart of the microprocessor that initialize the product to operate in a specific way. Each engine has different sensors and electrical accessories and requires different programs. The firmware programmer allows the users to change the Firmware program in the ECU for different engines or applications. The programmer is also used for upgrading to the latest version of the manufacturers firmware. The programmer is bought optional and not a requirement. It is very useful if the agent is far from the manufacturer. The firmware software is freeware after development. Read the Precautions first to prevent damage.

See the other folders for further explanation.


Precautions

1. Do NOT program the incorrect product firmware in your product. This could lock the microprocessor for operations and destroy the hardware. Each products firmware starts with the product name to minimize mistakes. Most of the firmware do have hardware lockout protection but the Test Programs and the older products do not have this protection feature. So do take care on this action.

2. Do NOT press the [image] button at any time in the Programmer Software. This will erase the product ID Code rendering it useless. This product will then have to be reprogrammed by the manufacturer resulting in courier charges and time loss.

3. Disconnect all the output harnesses from the product. The programmer will switch the outputs to the high state which means that coils and injectors will be switched on. This may damage the coil drivers or coils and fill the engine with fuel.

4. Follow the Startup Procedure to make sure that the right firmware and settings is loaded into your product to prevent damage. Some agents may neglect or misunderstand you on your application. It is your responsibility to check for mistakes.

5. After programming check the information screen to see if the right firmware is loaded. Note the program number and description.


Installation

After downloading the Firmware Programmer software run the file mcu_ide.exe to install the software program. Follow the onscreen instructions till you are asked for the following.

Click on Custom and uncheck Examples and Utilities.

You will not need these and they will only take up unnecessary disk space. No harm if you install the complete programmer.

Connect the USB programmer to the PC only and start the program at the start button, activate Silicone Laboratories and click on Silicone Laboratories IDE.

Now click on Options, Connect Options and select USB Debug Adapter and also C2 interface.

Click OK and you are all set to use the Programmer.


Operation

To program your Product, first connect the Programmer to the Product's Com Port. Connect only the P1 12-Way connector and earth the Product. Switch the ignition on. Click on the [image] button to connect.

The download [image] button will become active, click on it.

Now use the Browse button to select the correct HEX file on the hard disk or CD. Do not at any stage press the Erase all code space button.

Select the Files of Type to be Intel Hex (*.hex) then go to Look in: to search for the correct file.

Click Open when it is selected.

Click Download to program the Product.

Click the disconnect [image] button when it is finished and switch the ignition off. Disconnect the programmer and connect the USB/UART Converter cable. Do not connect the output cables before you run through the startup procedure. This will ensure that load the right firmware and not to damage the product.


Error Messages

Help > Introduction > Installing software and drivers > Firmware Programmer >

Error Messages

The Silicon Laboratories IDE Software display different messages when it cannot connect to the device or the Debug Adapter. Fast way to verify if the equipment is correct is to see if you can get connection to another device if you have one. Below is a description of the messages.

This message appears when the debug adapter Connection Options settings is incorrect. See the example below.

This message appears when the Silicon Laboratories IDE Software and the debug adapter are not the same version. If you press Ok it will be updated and never ask this question again until you load newer version Silicon Laboratories IDE software on the laptop.

This message appears if the debug adapter is not connected to the laptop. If it connects the Run and power LED's will light up on the debug adapter. It may also be a faulty debug adapter.

This message appears when the debug adapter is not connected to a Spitronics device. It may be a broken wire between the debug adapter and device. It may also be a faulty device. Usually when the Micro Processor of the device is blown. It may also be a damaged USB debug adapter. On some products the programmer inputs have duel tasks. It is then selected via jumpers. Make sure the jumpers are set for program mode.

This message appears when the debug adapter makes only partial connection to the device. Usually a damaged Micro Processor of the device.


Selecting Wiring Diagrams

Help > Introduction >

Selecting Wiring Diagrams

Manuals can be downloaded from the website. Go to www.spitronics.com then to Downloads tab, then Manuals tab. Due to the amount of different combinations of wiring and different harnesses, it is difficult to add it to the software manual without creating confusion. The names of the new manuals are structured according to the harness name. Each harness has a part number at the ECU connector side. To understand the harness levels, see the Harness Level description in this manual.

If you have the Level 1 harnesses, then you need to download this manual.

http://www.spitronics.com/downloads/Manuals/Drawings Pluto2 Mercury2 Neptune2 14_06_2017.rar

If you have the easy install harness Level 2 then download the file with that specific harness number. Due to the changing date in the number we cannot post a link till the final work is done.

Mercury2 MEX01 Installation Manual 29_09_2017


Terms & Conditions

Help > Introduction >

Click on the link below:

Terms & Conditions


Product Selection

Help >

Product Selection

Spitronics continuously develop products in the automotive industry. They have been in the market for more than a decade and as their expertise grow they develop new models that improve on hardware and software as engine and electronic technology improves. Their latest models are Mercury2, Saturn and Pluto2. See the Sub folders for features & specifications. Then view the How to Choose section to determine which unit would best suit you.

The Mercury2 Engine Control Unit (ECU) or Transmission Control Unit (TCU) is the flagship of our range. It is epoxy filled for ruggedness and reliability. It has the latest technology in short circuit protected drivers to prevent damage during faulty installations. It has many inputs and outputs to control from small to complex engines or transmissions. Simply change the firmware to choose between ECU or TCU.

Pluto2 is our low cost Engine Control Unit (ECU) which is made very small to use on motorcycles etc. where space is a problem. It has coil and injector drivers on board to simplify wiring and reduce costs. It has lots of features for such a miniature ECU and also replace our trusty old Venus ECU. It has more robust drivers than the first generation Pluto with improved spark. It is suitable for small to medium engine features.

Saturn is our low cost Engine Control Unit (ECU) which is made more robust with high voltage coil drivers that are very well cooled. This ideal for racing engines with high performance coils. It has coil and injector drivers on board to simplify wiring and reduce costs. It has 2 more GP outputs than Pluto2 and is backwards compatible with the Pluto harness. It is suitable for small to medium engine features.

The Mercury Coil Driver is a quality high performance spark generator. It comes in 2x2, 4x4 and 6x6 configuration. It is very compact and epoxy filled. The drivers are over-current and over temperature protected in short circuit circumstances. It has a primary cut-off voltage of 360V which will generate around 36kV breakthrough voltage. It can be used with other ECU systems.

The Coil Driver / Relay Combo is a combination of the Single Coil Driver & Electronic Relay in the same enclosure. This will reduce cost for distributor applications. The relay can handle 45 Amp and is epoxy sealed. The driver is over-current and over temperature protected in short circuit circumstances. The Coil driver is over-current and over temperature protected in short circuit circumstances. It has a primary cut-off voltage of 360V which will generate around 36kV breakthrough voltage. It can be used with other ECU systems.

The Single Coil Driver is a quality high performance spark generator for distributor applications. It is very compact and epoxy filled. The driver is over-current and over temperature protected in short circuit circumstances. It has a primary cut-off voltage of 360V which will generate around 36kV breakthrough voltage. It can be used with other ECU systems.

The Electronic Relay is the high quality solid state relay. It has no contacts that can burn or foul up. The relay can handle 45 Amp and is epoxy sealed. The driver is over-current and over temperature protected in short circuit circumstances. This relay can be used for many applications as 12V will switch it on and open circuit will switch it off. It is also used for the fuel pump duty cycle driver.

The Type 1 Stepper Idle Control is a high quality controller for 4 Pole stepper motors. It can be used on the Mercury2 and Pluto ECU's.

The Type 2 Stepper Idle Control is a high quality controller for Bi-Polar stepper motors. It can be used on the Mercury2 and Pluto ECU's.

The 1.1 Bar Map Sensor is a reliable low cost sensor that is mounted in the engine bay. It is used as an altitude sensor or manifold pressure sensor for normal aspirated engines.

The 2.5 Bar Map Sensor is a reliable low cost sensor that is mounted in the engine bay. It is used as manifold pressure sensor for normal aspirated and turbo engines with boost up to 1.5 Bar above sea level pressure.

The Aluminum Map Sensor is a durable high quality version of the pressure sensors. It comes in 1.1 Bar, 2.5 Bar, 3.0 Bar and 4.0 Bar pressure range. The 4 Bar sensor could also be used as fuel pressure sensor for normal aspirated engines.

The USB 6Pin Cable is the new standard communication interface to computers and tuning software. This cable has electronics in the enclosure on the cable to convert UART micro protocol to USB Computer protocol. It has optic isolation to shield sensitive laptops from the harsh signal environment found in automotive industry. These electronics is only used during tuning of the units. Therefore, Spitronics decided to keep it separate from their products to reduce production cost. This style cable is used on Pluto, Mercury2 and Neptune2. The older units will require a converter cable with different connecter setups.

The Firmware Programmer is used to change the firmware in all the Spitronics products. The connecter may differ from product to product. You may require a different connecter cable for older products. See the sub folders for explanation on connectors.


Frequently Asked Questions

Help > Product Selection >

Frequently Asked Questions

1. Is this unit a replacement for my car's standard computer? No the Spitronics products are unique with its own connecters and operation. Some of the signals can be interfaced with the standard units to maintain other functions like instruments etc.

2. Which product will suit my application? It is easy to determine by the How to Choose and Comparison Chart topic further in this chapter. Read through all the points and narrow down which unit is suitable for your application.

3. What do I get with the kit? Once you made a selection please look at the Kit Packing Lists to see what is included in the kit and what else you need to buy separate. All kits come with harnesses, level 1 or level 2, to connect onto existing engine plugs. It does not include the engine connecters as there are too many variations. You simply solder the harness onto your existing connecters. We do stock some of the connecters but will only quote them on enquiry. Then the ECU kits come with a 2.5 Bar Map sensor which may be changed on request to a different type.

4. What do I need to buy extra? Any sensors not included in the kit like Air & Water temperature sensor, Oxygen sensor etc. that is not on the engine or has to be replaced due to failure or service date expire. The USB communications cable is sold separately because you only need one as a tuning tool. It is a must have component for the setup and tuning of the products. The Programmer is optional to change the firmware or install upgrades on the products afterwards. It is recommended for customers abroad were you are far from support. If you buy Level 1 harness you may need a fuse box and automotive wiring and some dress-up components like lugs etc.

5. Is the unit Plug & Play No it is more like Wire & Play. Meaning that there is a certain amount of installation time soldering and wiring to be done before the unit can be switched on. Then you may need to tune it to your engines parameters due to minor variation differences between engines.

6. Can I install and tune this unit successfully? These products were developed for the DIY market. But you do need a fair bit of knowledge and hand skills to complete this project. Most auto electrical people should be able to assist if you have difficulties. If you study the manual properly you should be able the get your engine reasonably drivable with fair consumption and performance.

7. Does the unit need to be Dyno-Tuned after install? Some tuners found a way to tune it on the road quite successfully especially if there are no Dyno's available. If you do have a facility and a recommended tuner it is advisable to have it tuned properly. Some units that is engine-specific may come with a tuned MAP on it for that engine. Then minor tuning is required and not necessary for a Dyno Tune. High performance racing and turbo engines is recommended for a dyno tune as they can brake easily under heavy load. Road tune also become problem some due to handling the power.

8. Is the unit pre tuned? No but we do put a startup MAP on the unit. These units are universal for different engines and it cannot cater for all variations in sensor and driver setup like injector sizes, fuel pressure etc. in some units that is engine-specific we will load a tuned MAP on it for that type of engine. It should start and be drivable around 90%. But some fine setup will make it more efficient.

9. Can this unit work for diesel engines? No Spitronics is busy to develop a Diesel version but it will only be finished in the near future.

10. Can this unit work for direct injectors? No but it is under development with the Diesel development which will be finished in the near future.

11. Can this unit work for Throttle by Wire systems? Throttle by wire is in the testing phase and is near end to production. Units are available as proto test units.

12. Is this a piggy back system? No this is a standalone computer and does not require any other electronic units apart from its own units and the sensors on the engine. But with clever connections and sharing of the OEM signals it can be used with the OEM ECU to add fuel or do some different tasks.

13. Can this unit control my VVTI cams? It can control cams in open loop at this stage. Loop control is under development which will be finished in the near future.

14. Does this unit do Knock sensing? No knock sensing may be developed in the near future.

15. Does this unit do self-tuning? No the units do have loop control with the oxygen sensor and idle valve, but all tuning is done in open loop and these systems will fine adjust in real time to optimize fuel mixtures. It is on development in the near future

16. Can this unit be used for racing fuels? Yes, it does have two selection MAP's to tune the engine for different fuels. These maps can be selected with a switch at startup. It can also run duel injectors with different fuels on the 2 injectors.

17. Can these units interface to my vehicle' ECU via the CAN BUS No, these devices do not have CAN BUS capability.


ECU How to Choose

Help > Product Selection >

How to choose the right ECU

Choosing the right ECU the first time is important to save time and confidence. Please read this part with an open mind to help you choose wisely. Sometimes the cheapest option is not the best one and it may end up costing u more. There are two group choices to be made. Firstly, which product range to choose and secondly which hardware class to choose for that product. Work through each point and narrow down your final choice.

Product Choice.

1. You need to consider your budget. Spitronics has the economy Pluto2, Saturn and Neptune2 range and the high quality Mercury2 range. Mercury2 is more expensive due to protected drivers, epoxy filled enclosure, more inputs and outputs and external firing modules for coils with no intelligence.

2. If you have people installing the unit that does not have lots of experience, Mercury2 is definitely the choice. It does not damage easily if short circuits are made. If installed properly, the economy range performs just as well as the Mercury2 range.

3. If you are abroad or far from Spitronics' home base, it is also best to go for the Mercury2 option. Courier and time lost could be far more expensive than the money saved with the low cost products.

4. If you require the unit to be installed under harsh conditions like an off-road vehicle with lots of vibration and dampness it is best to go for the Mercury2 unit. It is epoxy-filled for vibration and moisture. Pluto2 or Saturn can be epoxy-filled by yourselves after tuning should you require to do so.

5. If it is a complex engine with lots of drivers and sensors the economy range may not be adequate and you need the Mercury2 anyway. Browse through the product comparison chart to see if the product will be the right one.

6. The Economy range are repairable with some of the damage because it is not sealed. We do have a one year reduced exchange rate should any of the ECU's or TCU's be damaged. See the pricelist for more info or contact our dealers.

7. Coils also need to be considered. If you go for Mercury2, coils with built-in drivers are connected directly. Coils without built-in drivers require the Mercury2 Coil Driver. See how many coils you have and buy the right combination of the Coil Driver. If you decide on the Pluto2 or Saturn which has built-in coil drivers, it can connect to coils without built-in drivers directly. If you have coils with built-in drivers, then you need to wire in the 220 Ohm pull-up resistors and switch the firmware to external drivers. On Pluto2 or Saturn this setup is critical to have it right at startup or you may damage coils or drivers permanently.

Hardware Class Choice

1. If your engine has more than 1 coil or a wasted spark coil pack, you will require an Advance or Ultimate ECU. If not your engine should house a distributor with rotor to distribute the spark. Mostly older type engines.

2. If it has a distributor and more than 4 cylinders you need the Intermediate ECU for correct fuel distribution with Split-Sequential or Full-Sequential delivery. A 3 cylinder will also require the Intermediate. If you are really on a tight budget you may use a Standard system and share the injectors on the 2 drivers. Note that there is a different way to connect low and high impedance injectors. Note also that standard systems can only do trigger per event signals.

3. If your trigger in the distributor is one pulse per spark event, then you may use the Standard or Intermediate. If it has a crank trigger with TDC slot or complex distributor signal with Home pulse you will require the Intermediate ECU.

4. Make sure that there is firmware for your application for the specific ECU. Some firmware requires the abilities of Mercury2 and is not available on the economy range products.

5. Should you plan to do upgrades in the future buy the Advance or Ultimate ECU. You may also consider the programmer to change the firmware in the future.

6. Note that higher class ECU's will operate with lower class firmware for the same product. So if you buy an Advance ECU, you may start off with Standard or Intermediate firmware.

7. These hardware classes could be changed over the internet in the future following an upgrade payment. So you may buy a Standard ECU and upgrade it later to an Advance ECU. You may also consider the programmer to change the firmware in the future.


ECU Comparison Chart

Help > Product Selection >

ECU Features Comparison Chart

 | Pluto2 | Saturn | Mercury2 |
Hardware Inputs |  |  |  |
Map Sensor | 1 | 1 | 1 |
TPS Sensor | 1 | 1 | 1 |
Water Temp Sensor 2K NTC | 1 | 1 | 1 |
Air Temp Sensor 10K NTC | 1 | 1 | 1 |
Lambda | 1 | 1 | 1 |
Altitude Sensor |  |  | 1 |
Built In Altitude Sensor | 1 | 1 |  |
Tuning Pot | 1 | 1 | 1 |
Fuel Pressure Sensor |  |  | 1 |
Dual Map Switch | 1 | 1 |  |
Battery Volts | 1 | 1 | 1 |
Crank Trigger Pulse | 1 | 1 | 1 | Note 1
TDC/Home Pulse | 1 | 1 | 1 | Note 1
VVTI Cam 1 Pulse |  |  | 1 | Note 1
VVTI Cam 2 Pulse |  |  | 1 | Note 1
USB/Programmer 6Pin Molex | 1 | 1 | 1 |
Hardware Outputs |  |  |  |
Injector Drivers Negative Out | 2(4) | 2(4) | 8 | Note 2
Internal Coil Drivers Negative Out | 4(2) | 4(2) |  | Note 2
External Coil Triggers Positive Out |  |  | 8 |
RPM Output | 1 | 1 | 1 |
Electronic Relay Output |  |  | 1 |
Relay Output | 1 | 1 | 1 |
GP Outputs | 2 | 4 | 2 |
Features |  |  |  |
Graph Tuning | 1 | 1 | 1 |
Matrix Tuning | 1 | 1 | 1 |
Idle Control | 1 | 1 | 1 | Note 3
Dual Maps | 1 | 1 | 1 |
Micro Fuelling or Fazed Injector | 1 | 1 | 1 |
Full Sequential Injector Control |  |  | 1 |
Fuel Pressure Control |  |  | 1 |
V-Tech Cam Control | 1 | 1 | 1 |
VVTI Cam Control |  |  | X |
Launch control | 1 | 1 | 1 |
Anti-Lag control |  |  | X |
Flat-Shift control |  |  | X |
Boost control |  |  | X |
Throttle x Wire control |  |  | X |
RPM Calibration | 1 | 1 | 1 |
Power Management |  |  | 1 |
Epoxy filed |  |  | 1 |
Can be Epoxy filed | 1 | 1 |  |
Notes |  |  |  |
Note 1 - Only magnetic sensors directly - Requires an external Pull-up Resistor for Hall or Optic Sensors. Cam 1 input may be used for Dual Map selection.
Note 2 - There are 6 drivers that are shared by the injectors and coils.
Note 3 - For Stepper motors external hardware is required
X - Capable - Firmware not yet developed |  |  |


Mercury2 ECU/TCU

Help > Product Selection >

Mercury2 ECU_TCU

The MERCURY2 Control Unit is designed to be a cost effective replacement for high tech Engine Control Units (ECU) and Transmission Control Units (TCU). It uses unique and easy features which are easy to install and tune. It is designed with both novice and professional installer in mind.

This universal South African made product that can easily be customized for various engines or transmissions. It can be used for many applications such as racing engines, vehicle conversions, custom built vehicles, replacement parts for production vehicles etc. It is a compact reliable system which is epoxy filled to make it rugged and water tight for harsh environments and easy to mount in the driver's compartment.

The Mercury2 unit is designed to connect directly to most sensors and control components that are found on engines and transmissions. No need to modify them. It consists of the latest in high speed micro controllers with surface mount technology. These units are machine soldered to minimize human error.

The Mercury2 cover features like Lambda control, idle control, launch control, fuel pressure control, cam control, line pressure control, Tiptronic gear control, stepper motor control and lots more. It has 8 positive drivers that can be converted to 12 coil igniters drivers, 12 negative drivers for injectors or GP outputs, rpm output, relay and electronic relay outputs. These drivers are ranging from 3.5 Amp to 6 Amp.

There are 9 analog input signals to measure water, air or oil temperature, throttle position, manifold pressure, lambda, fuel pressure, altitude etc. Then there are 4 digital inputs to measure crank, cam & prop shaft angles.

The software is user-friendly and makes all the above features customizable by the tuner. This makes the Mercury2 adaptable for most engines and transmissions. Activations of features can be done over the internet, making the unit viable to keep in stock and customize on demand.

This Mercury2 was designed to be universal and adaptable. Some firmware is customized upon request to suit customers. New applications can easily be incorporated. Upgrades can be done over the internet.

To learn more about this amazing package browse through the features and specifications in the sub folders.


Features

Help > Product Selection > Mercury2 ECU/TCU >

Mercury2 Features

ECU Features

Note that these are all the current features covered by the Mercury2. There are some on the charts that is in the process to be developed in the future. The hardware has the capability for it. Also note that not all of the features may be included on the same ECU as there is limited amount of drivers available. Some of the hardware classes may not include certain features due to the price range. See the selection chart for the ability of the different classes.

Fuel Delivery

· Accurate fueling such as batch, Split Batch, Split Sequential, and Full Sequential gives better performance and fuel consumption due to constant atomization on each cylinder.

· Fueling is done in graph or matrix method for the tuners preference.

· All graphs or matrix data are interpolated to smooth fuel calculation accuracy for best performance though the operating ranges.

· Fuel is calculated with MAP or TPS sensor signals versus RPM or a combination of the two. This will accommodate most engines ranging from street to racing and from economy to performance.

· Other sensors that are used to alter the fuel mixture are Water, Air, Altitude, Lambda, Battery Volts, Fuel Pressure and throttle response.

· Fuel injection timing is adjustable on gear type crank angle sensors as low as 12 pulses per revolution.

· Adjustable MAP sensor, reading angle for multiple throttle body systems.

· Two types of micro fuel injection methods (staged injectors) namely Ratio adjust or Graph Fazed method.

· Fuel pressure control with pressure compensation maps.

· Injector trimming up to 8 injectors.

Ignition Spark & Timing

· The ECU can do Single & Multi Coil Spark Systems

· Use standard coil packs on the engine.

· Can be connected to most intelligent coils with internal drivers directly.

· The Mercury high performance firing module ensure a high performance spark adequate to ignite most mixtures of different fuels.

· Very accurate ignition timing especially with the gear type triggers.

· Timing is calculated with MAP or TPS sensor signals versus RPM or a combination of the two. This will accommodate most engines ranging from street to racing.

· Other sensors that is used to alter the Ignition Timing is Water, Air and Altitude,

· Battery Volts is used to compensate for coil charge time.

Sensors

· The ECU use most standard sensors on the engine - No need to do modifications on distributors or converter boards.

· Custom Bolt-On Timing Gears may be used for older engines that run carburetors or engines with incorrect setups. Gear type triggers do make timing more accurate and responsive during blip conditions. This is the preferred method for racing applications.

· Sensors can be calibrated to accommodate the different types found on the engines.

Idle Control & Cold Start - This functions will ease with starting a cold engine and keep the RPM's constant when air conditioners or automatic transmissions draw power from the engine. Idle control is included on board for one and two wire idle valves. The Spitronics stepper control units can be connected to control quad and bipolar stepper motors.

Launch Control - This feature will increase boost pressure during pull-off to eliminate Turbo Lag. Various methods are available to activate launch like buttons clutch switches TPS position etc.

Two General Purpose Outputs - This can be used for injectors, fan control, shift light, Aircon Cut-Out on Pull-Off or Up-Hill etc.

Standard Harness - No need to keep several harnesses in stock for different engines. There are however custom harnesses for certain engines that will ease installation time. All the input wiring harnesses use screened cables for neatness of installation and to prevent electromagnetic interference which may cause erratic behavior of the ECU.

Compact Electronics - This will make the ECU easy to install under the dashboard as it takes very little space.

Complete Kits for Most Engines.

Cost Effective - No need to buy expensive systems as all the necessary features are included with the ECU.

Rotary Systems - The 2 & 3 rotor engines are covered by this ECU. 4 to 6 can be done as well.

External Map Sensor - Easy to change between 1Bar, 2.5Bar, 3Bar 4Bar & custom configurations. External sensors are used to reduce the delay in the vacuum signal It makes the ECU more versatile to adapt to standard MAP sensors found on engines.

Altitude Compensation - This feature is important as the ECU will automatically compensate for differences in pressure.

Fuel Pressure control - This will control the speed of the fuel pump which eliminate the need for the mechanical fuel pressure regulator and return fuel line. It also compensates injector time versus fuel pressure to ensure accurate mixtures during blip conditions.

Standard Tuning Software - The features that is not used or allowed in the firmware will be blanked out.

Easy DIY Instructions - Save a lot of money on installation if you are a person who is up to the challenge.

Start-Up Maps included - This will make for easy start-up & tuning with the help of a Lambda sensor

User Friendly Tuning Software which is extensively explained in the manual.

Tuning map can be locked to prevent tampering. Useful for engine builders to gives guarantees.

No Dyno Required - Tune your own vehicle and save some more money. Just following the instructions in the manual carefully.

(Note that the last four points are for the person who is handy with tools and understand wiring and operation of an engine. If you are not sure, download the software, Map, manual and drawing and experiment with it first. It's free of charge!)


Specifications

Help > Product Selection > Mercury2 ECU/TCU >

Mercury2 Specifications

Power Supply

12V Ignition power 200mA, filtered by reverse polarity Diode, 700mA Poly switch and 25V Tranzorb

12V Relay power 14A Max, filtered by reverse polarity Diode

2.5mm2 Earth Strap

Inputs

4x Trigger inputs - Magnetic Isolated (2 Inputs require a 1K pull-up resistor for Hall or Optic inputs)

5x Analogue input 0 - 5V

1x 2K NTC Temperature Sensor Input

1x 10K NTC Temperature Sensor Input

1x Lambda Input 0 - 1 V or Processed 0 - 5V signal.

Software UART Connection via USB2 converter cable

Firmware Programmer Connection

Outputs

8x 6A P Channel Mossfets 12V Output Floating, Over-current protected

8x 6A N Channel Mossfets Ground Output Floating, Over-current protected

1x Mechanical Relay 3.5A Ground Output Floating, Over-current protected

1x RPM 3.5A Ground Output Floating with 1K pull-up resistor to 12V, Over-current protected

2x General Purpose 3.5A Ground Output Floating, Over-current protected

5V 600mA Power Output for TPS & Map Sensor

Electronic Relay 5V 5mA output for Spitronics custom 45A solid state relay

Dimensions

Size 145mm x 68mm x 21mm

Weight 240g

4 x Connector Type Plastic Molex 12, 10, 8, 6

1 x Comms Connector Type Plastic Molex 6

Load Sites ECU

Tuning Pallet | load sites | Resolution | Adjustment | Adjustment |
 |  |  | Resolution | Range |
Fuel Vacuum Graph | 64 | Auto Range | 0.1 ms | 0 to 25 ms | Interpolated
5 x Fuel RPM Graph | 32 | Auto Range | 1% | -50% to 50% |
Micro Fuel Vacuum Graph | 32 | Auto Range | 0.1 ms | 0 to 25 ms | Interpolated
Dynamic Timing Graph | 150 | 100 RPM | 1° | 0° to 45° | Interpolated
2 x Vacuum Timing Graph | 32 | Auto Range | 1° | -15° to 25° | Interpolated
Trailing Degrees Graph | 30 | 500 RPM | 1° | 0° to 45° | Interpolated
Water Temperature Timing Graph | 18 | -40° to 140° | 1° | -50° to 100° | Interpolated
Water Temperature Fuel Graph | 18 | -40° to 140° | 1% | -50% to 100% | Interpolated
Air Temperature Timing Graph | 18 | -40° to 140° | 1° | -50° to 100° | Interpolated
Air Temperature Fuel Graph | 18 | -40° to 140° | 1% | -50% to 100% | Interpolated
Lambda MAP Graph | 24 | Auto Range | 1% | -50% to 50% | Interpolated
Lambda RPM Graph | 24 | Auto Range | 1% | -50% to 50% | Interpolated
Injection Degrees Graph * | 30 | Firmware | Firmware | 0° to 720° | Interpolated
TPS Fuel Graph | 20 | 0% to 100% | 1% | -50% to 50% | Interpolated
Fuel Matrix | 16x16 | Auto Range | 0.1 ms | 0 to 25 ms | Interpolated
Timing Matrix | 16x16 | Auto Range | 1° | 0° to 45° | Interpolated
Cam1 Matrix * | 8x8 | Firmware | Firmware | Firmware | Interpolated
Cam1 Matrix * | 8x8 | Firmware | Firmware | Firmware | Interpolated
Fuel Pressure Set point Graph | 12 | Auto Range | 0.1 Bar | 0 to 7 Bar | Interpolated
Fuel Pressure Correction Graph | 30 | Auto Range | 1% | -50% to 50% | Interpolated
Battery Fuel Graph | 20 | 0.5V | 1% | -50% to 50% | Interpolated
Battery Charge Time Graph | 20 | 0.5V | 1% | -50% to 50% | Interpolated

* Not yet implemented


Selection Chart

Help > Product Selection > Mercury2 ECU/TCU >

Mercury2 ECU Selection

The Mercury2 is sold in six hardware classes categorized by the features required for each engine or transmission. The advantage is that basic applications is sold cheaper than more complex applications. These features can be activated or changed over the internet which eliminates time lost and courier costs. This makes it viable to have these units in stock at low entry cost and activate the features later when the project is started. The PC Tuning software is standard for all units. Certain features will be blanked out if it is not available. The firmware categories are Micro, Basic, Standard, Intermediate, Advance and Ultimate. On the ECU only 4 classes are implemented at this stage and on the TCU only 1 class. Please look at the following charts to see which hardware class will suit your application.

ECU Selection Chart

Mercury2 Hardware | Standard | Intermediate | Advance | Ultimate |
Hardware Inputs |  |  |  |  |
Map Sensor | 1 | 1 | 1 | 1 |
TPS Sensor | 1 | 1 | 1 | 1 |
Water Temp Sensor 2K NTC | 1 | 1 | 1 | 1 |
Air Temp Sensor 10K NTC | 1 | 1 | 1 | 1 |
Lambda | 1 | 1 | 1 | 1 |
Altitude Sensor | 1 | 1 | 1 | 1 |
Built In Altitude Sensor |  |  |  |  |
Tuning Pot | 1 | 1 | 1 | 1 |
Fuel Pressure Sensor |  |  | 1 | 1 |
Dual Map Switch |  |  |  |  |
Battery Volts | 1 | 1 | 1 | 1 |
Power Management | 1 | 1 | 1 | 1 |
Crank Trigger Pulse | 1 | 1 | 1 | 1 | Note 1
TDC/Home Pulse | 1 | 1 | 1 | 1 | Note 1
VVTI Cam 1 Pulse |  |  |  | 1 | Note 1
VVTI Cam 2 Pulse |  |  |  | 1 | Note 1
USB/Programmer 6Pin Molex | 1 | 1 | 1 | 1 |
Hardware Outputs |  |  |  |  |
Injector Drivers Negative Out | 2 | 8 | 8 | 8 |
Internal Coil Drivers Negative Out |  |  |  |  |
External Coil Triggers Positive Out | 1 | 1 | 8 | 8 |
RPM Output | 1 | 1 | 1 | 1 |
Electronic Relay Output | 1 | 1 | 1 | 1 |
Relay Output | 1 | 1 | 1 | 1 |
GP Outputs | 2 | 2 | 2 | 2 |
Features |  |  |  |  |
Graph Tuning | 1 | 1 | 1 | 1 |
Matrix Tuning | 1 | 1 | 1 | 1 |
Idle Control | 1 | 1 | 1 | 1 | Note 2
Dual Maps | 1 | 1 | 1 | 1 |
Micro Fuelling or Fazed Injector | 1 | 1 | 1 | 1 |
Full Sequential Injector Control |  | 1 | 1 | 1 |
Fuel Pressure Control |  |  | 1 | 1 |
V-Tech Cam Control | 1 | 1 | 1 | 1 |
VVTI Cam Control |  |  |  | X |
Launch control | 1 | 1 | 1 | 1 |
Anti-Lag control | X | X | X | X |
Flat-Shift control | X | X | X | X |
Boost control |  |  |  | X |
Throttle x Wire control |  |  |  | X |
RPM Calibration | 1 | 1 | 1 | 1 |
Epoxy filed | 1 | 1 | 1 | 1 |
Can be Epoxy filed |  |  |  |  |
Notes |  |  |  |  |
Note 1 - Only magnetic sensors - Requires external Pull-up Resistor for Hall or
Optic Sensors. Cam 1 input may be used for Dual Map selection. |  |  |  |  |
Note 2 - For Stepper motors external hardware is required |  |  |  |  |
X - Capable - Firmware not yet developed |  |  |  |  |


Saturn

Help > Product Selection >

Saturn

The SATURN Control Unit is designed to be a low cost effective replacement for high tech Engine Control Units (ECU). It uses unique and easy features which are easy to install and tune. It is designed with the novice and professional installer in mind.

This universal South African made product can easily be customized for various engines. It can be used for many applications such as racing engines, vehicle conversions, custom built vehicles, replacement parts for production vehicles etc. It is a compact reliable system which can be epoxy filled to make it rugged and water tight for harsh environments and easy to mount in the driver's compartment.

The Saturn unit is designed to connect directly to most sensors and control components that are found on engines. No need to modify them. It consists of the latest in high speed micro controllers with surface mount technology. These units are machine soldered to minimize human error.

The Saturn cover features like Lambda control, idle control, launch control, cam control, stepper motor control and lots more. It has 6 negative 18 Amp 500 Volt drivers that can drive basic coils directly without the need of a coil igniter driver. It has added cooling for the drivers to make it suitable in racing to drive high performance coils. These drivers are combined with injector drivers. There are 4 negative low voltage drivers for injectors or GP outputs. Then there is a RPM output & Relay output. These 6 drivers are 3.5 Amp each current protected.

There are 7 analog input signals to measure water & air temperature, throttle position, manifold pressure, lambda etc. Then there are 2 digital inputs to measure crank, cam angles.

The software is user-friendly and makes all the above features customizable by the tuner. This makes the Saturn adaptable for most engines. Activations of features can be done over the internet making the unit viable to keep in stock and customize on demand.

This Saturn was designed to be universal and adaptable. Some firmware is customized to suit customers. New applications can easily be incorporated. Upgrades can be done over the internet.

To learn more about this amazing package browse through the features and specifications in the sub folders.


Features

Help > Product Selection > Saturn >

Saturn Features

Note that these are all the current features covered by the Saturn. There are some on the charts that is in the process to be developed in the future. The hardware has the capability for it. Also note that not all of the features may be included on the same ECU as there is limited amount of drivers available. Some of the hardware classes may not include certain features due to the price range. See the selection chart for the ability of the different classes.

Fuel Delivery

· Accurate fueling such as batch, Split Batch, and Split Sequential gives better performance and fuel consumption due to constant atomization on each cylinder.

· Fueling is done in graph or matrix method for the tuners preference.

· All graphs or matrix data are interpolated to smooth fuel calculation accuracy for best performance though the operating ranges.

· Fuel is calculated with MAP or TPS sensor signals versus RPM or a combination of the two. This will accommodate most engines ranging from street to racing and from economy to performance.

· Other sensors that are used to alter the fuel mixture are Water, Air, Altitude, Lambda, Battery Volts and throttle response.

· Fuel injection timing is adjustable on gear type crank angle sensors as low as 12 pulses per revolution.

· Adjustable MAP sensor reading angle for multiple throttle body systems.

· Two types of micro fuel injection methods (staged injectors) namely Ratio adjust or Graph Fazed method.

Ignition Spark & Timing

· The ECU can do Single & Multi Coil Spark Systems

· Use standard coil packs on the engine.

· Can be connected to most coils without internal drivers directly. The latter requires a pull-up resistor.

· Very accurate ignition timing especially with the gear type triggers.

· Timing is calculated with MAP or TPS sensor signals versus RPM or a combination of the two. This will accommodate most engines ranging from street to racing.

· Other sensors that is used to alter the Ignition Timing is Water, Air and Altitude,

· Battery Volts is used to compensate for coil charge time.

Sensors

· The ECU use most standard sensors on the engine - No need to do modifications on distributors or converter boards.

· Custom Bolt-On Timing Gears may be used for older engines that run carburetors or engines with incorrect setups. Gear type triggers do make timing more accurate and responsive during blip conditions. This is the preferred method for racing applications.

· Sensors can be calibrated to accommodate the different types found on the engines.

Idle Control & Cold Start - This functions will ease with starting a cold engine and keep the RPM's constant when air conditioners or automatic transmissions draw power from the engine. Idle control is included on board for one and two wire idle valves. The Spitronics stepper control units can be connected to control quad and bipolar stepper motors.

Launch Control - this feature will increase boost pressure during pull-off to eliminate Turbo Lag. Various methods are available to activate launch like buttons clutch switches TPS position etc.

Four General Purpose Outputs - This can be used for injectors, fan control, shift light, Aircon Cut-Out on Pull-Off or Up-Hill etc.

Standard Harness - No need to keep several harnesses in stock for different engines. There are however custom harnesses for certain engines that will ease installation time. All the input wiring harnesses use screened cables for neatness of installation and to prevent electromagnetic interference which may cause erratic behavior of the ECU.

Compact Electronics - This will make the ECU easy to install under the dashboard as it takes very little space.

Complete Kits for Most Engines.

Cost Effective - No need to buy expensive systems as all the necessary features are included with the ECU.

Rotary Systems - The 2 & 3 rotor engines are covered by this ECU.

External Map Sensor - easy to change between 1Bar, 2.5Bar, 3Bar & 4Bar configurations External sensors are used to reduce the delay in the vacuum signal It makes the ECU more versatile to adapt to standard MAP sensors found on engines.

Altitude Compensation - this feature is important as the ECU will automatically compensate for differences in pressure.

Standard Tuning Software - the features that is not used or allowed in the tuning software will be blanked out.

Easy DIY Instructions - Save a lot of money on installation if you are a person who is up to the challenge.

Start-Up Maps included - This will make for easy start-up & tuning with the help of a Lambda sensor

User Friendly Tuning Software which is extensively explained in the manual.

Tuning map can be locked to prevent tampering. Useful for engine builders to give guarantees.

No Dyno Required - Tune your own vehicle and save some more money. Just following the instructions in the manual carefully.

(Note that the last four points are for the person who is handy with tools and understand wiring and operation of an engine. If you are not sure, download the software, Map, manual and drawing and experiment with it first. It's free of charge!)


Specifications

Help > Product Selection > Saturn >

Saturn Specifications

Power Supply

12V Ignition power 200mA, filtered by reverse polarity Diode, 700mA Poly switch and 25V Tranzorb

2.5mm2 Earth Strap

Inputs

2x Trigger inputs - Can be Magnetic or Hall or Optic inputs or combination of 2.

1x Map sensor input 0 - 5V

1x built in Altitude sensor input 0 - 5V optional

1x TPS sensor input 0 - 5V

1x Water Temperature Input - 2K NTC Resistance Sensor

1x Air Temperature Input - 10K NTC Resistance Sensor

1x Lambda Input 0 - 1 V or Processed 0 - 5V signal.

1x Dual Map Input

1x Tuning POT input 0 - 5V

Software UART Connection via USB2 converter cable

Firmware Programmer Connection

Outputs

6x 18A 500Volt N Channel Mossfets output Ground Floating (coil or injector drivers any combination)

1x Fuel Relay 3.5A Ground Output Floating, Over-current protected

1x RPM 3.5A Ground Output Floating with 1K pull-up resistor to 12V, Over-current protected

4x General Purpose 3.5A Ground Output Floating, Over-current protected

5V 600mA Power Output for TPS & Map Sensor and Magnetic Pickups

Dimensions

Size 145mm x 68mm x 21mm

Weight 118g

5 x Connector Type Plastic Molex 12, 10, 8, 6, 4

Load Sites

Tuning Pallet | load sites | Resolution | Adjustment | Adjustment |
 |  |  | Resolution | Range |
Fuel Vacuum Graph | 64 | Auto Range | 0.1 ms | 0 to 25 ms | Interpolated
5 x Fuel RPM Graph | 32 | Auto Range | 1% | -50% to 50% |
Micro Fuel Vacuum Graph | 32 | Auto Range | 0.1 ms | 0 to 25 ms | Interpolated
Dynamic Timing Graph | 150 | 100 RPM | 1° | 0° to 45° | Interpolated
2 x Vacuum Timing Graph | 32 | Auto Range | 1° | -15° to 25° | Interpolated
Trailing Degrees Graph | 30 | 500 RPM | 1° | 0° to 45° | Interpolated
Water Temperature Timing Graph | 24 | 0° to 120° | 1° | -50° to 50° | Interpolated
Water Temperature Fuel Graph | 24 | 0° to 120° | 1% | -50% to 50% | Interpolated
Air Temperature Timing Graph | 24 | -20° to 100° | 1° | -50° to 50° | Interpolated
Air Temperature Fuel Graph | 24 | -20° to 100° | 1% | -50% to 50% | Interpolated
Lambda MAP Graph | 24 | Auto Range | 1% | -50% to 50% | Interpolated
Lambda RPM Graph | 24 | Auto Range | 1% | -50% to 50% | Interpolated
Fuel Matrix | 16x16 | Auto Range | 0.1 ms | 0 to 25 ms | Interpolated
Graph Matrix | 16x16 | Auto Range | 1° | 0° to 45° | Interpolated
Battery Fuel Graph | 20 | 0.5V | 1% | -50% to 50% | Interpolated
Battery Charge Time Graph | 20 | 0.5V | 1% | -50% to 50% | Interpolated


Selection Chart

Help > Product Selection > Saturn >

Saturn Selection

The Saturn is sold in six hardware classes categorized by the features required for each engine. The advantage is that basic applications is sold cheaper than more complex applications. These features can be activated or changed over the internet which eliminates time lost and courier costs. This makes it viable to have these units in stock at low entry cost and activate the features later when the project is started. The PC Tuning software is standard for all units. Certain features will be blanked out if it is not available. The firmware categories are Micro, Basic, Standard, Intermediate, Advance and Ultimate. On the ECU only 5 classes are implemented at this stage. Please look at the following charts to see which hardware class will suit your application.

Saturn Hardware | Standard | Intermediate | Advance | Ultimate |
Hardware Inputs |  |  |  |  |
Map Sensor | 1 | 1 | 1 | 1 |
TPS Sensor | 1 | 1 | 1 | 1 |
Water Temp Sensor 2K NTC | 1 | 1 | 1 | 1 |
Air Temp Sensor 10K NTC | 1 | 1 | 1 | 1 |
Lambda | 1 | 1 | 1 | 1 |
Altitude Sensor |  |  |  |  |
Built In Altitude Sensor | 1 | 1 | 1 | 1 | Note 1
Tuning Pot | 1 | 1 | 1 | 1 |
Fuel Pressure Sensor |  |  |  |  |
Dual Map Switch | 1 | 1 | 1 | 1 |
Battery Volts | 1 | 1 | 1 | 1 |
Power Management | 1 | 1 | 1 | 1 |
Crank Trigger Pulse | 1 | 1 | 1 | 1 |
TDC/Home Pulse | 1 | 1 | 1 | 1 |
VVTI Cam 1 Pulse |  |  |  |  |
VVTI Cam 2 Pulse |  |  |  |  |
USB/Programmer 9Pin D-Sub |  |  |  |  |
USB/Programmer 6Pin Molex | 1 | 1 | 1 | 1 |
Hardware Outputs |  |  |  |  |
Injector Drivers Negative Out | 2 | 4 | 2(4) | 2(4) | Note 2
Internal Coil Drivers Negative Out | 1 | 1 | 4(2) | 4(2) | Note 2
External Coil Triggers Positive Out |  |  |  |  |
RPM Output | 1 | 1 | 1 | 1 |
Electronic Relay Output |  |  |  |  |
Relay Output | 1 | 1 | 1 | 1 |
GP Outputs | 4 | 4 | 4 | 4 |
Features |  |  |  |  |
Graph Tuning | 1 | 1 | 1 | 1 |
Matrix Tuning | 1 | 1 | 1 | 1 |
Idle Control | 1 | 1 | 1 | 1 | Note 2
Dual Maps | 1 | 1 | 1 | 1 |
Micro Fueling or Fazed Injector | 1 | 1 | 1 | 1 |
Full Sequential Injector Control |  |  |  |  |
Fuel Pressure Control |  |  |  |  |
V-Tech Cam Control | 1 | 1 | 1 | 1 |
VVTI Cam Control |  |  |  |  |
Launch control | 1 | 1 | 1 | 1 |
Anti-Lag control | X | X | X | X |
Flat-Shift control | X | X | X | X |
Boost control |  |  |  |  |
Throttle x Wire control |  |  |  |  |
RPM Calibration | 1 | 1 | 1 | 1 |
Epoxy filed |  |  |  |  |
Can be Epoxy filed | 1 | 1 | 1 | 1 |
Notes |  |  |  |  |
Note 1 - This sensor is optional and must be installed on request
Note 2 - There are 6 drivers to share in combination with injectors and coils
Note 3 - For Stepper motors external hardware is required |  |  |  |  |
X - Capable - Firmware not yet developed |  |  |  |  |


Pluto2

Help > Product Selection >

Pluto2

The PLUTO2 Control Unit is designed to be a low cost effective replacement for high tech Engine Control Units (ECU). It uses unique and easy features which are easy to install and tune. It is designed with the novice and professional installer in mind.

This universal South African made product can easily be customized for various engines. It can be used for many applications such as racing engines, vehicle conversions, custom built vehicles, replacement parts for production vehicles etc. It is a compact reliable system which can be epoxy filled to make it rugged and water tight for harsh environments and easy to mount in the driver's compartment.

The Pluto2 unit is designed to connect directly to most sensors and control components that are found on engines. No need to modify them. It consists of the latest in high speed micro controllers with surface mount technology. These units are machine soldered to minimize human error.

The Pluto2 cover features like Lambda control, idle control, launch control, cam control, stepper motor control and lots more. It has 6 negative 18 Amp 450 Volt drivers that can drive basic coils directly without the need of a coil igniter driver. These drivers are combined with injector drivers. There are 2 negative low voltage drivers for injectors or GP outputs. Then there is a RPM output & Relay output. These 4 drivers are 3.5 Amp each current protected.

There are 7 analog input signals to measure water & air temperature, throttle position, manifold pressure, lambda etc. Then there are 2 digital inputs to measure crank, cam angles.

The software is user-friendly and makes all the above features customizable by the tuner. This makes the Pluto2 adaptable for most engines. Activations of features can be done over the internet making the unit viable to keep in stock and customize on demand.

This Pluto2 was designed to be universal and adaptable. Some firmware is customized to suit customers. New applications can easily be incorporated. Upgrades can be done over the internet.

To learn more about this amazing package browse through the features and specifications in the sub folders.


Features

Help > Product Selection > Pluto2 >

Pluto2 Features

Note that these are all the current features covered by the Pluto2. There are some on the charts that is in the process to be developed in the future. The hardware has the capability for it. Also note that not all of the features may be included on the same ECU as there is limited amount of drivers available. Some of the hardware classes may not include certain features due to the price range. See the selection chart for the ability of the different classes.

Fuel Delivery

· Accurate fueling such as batch, Split Batch, and Split Sequential gives better performance and fuel consumption due to constant atomization on each cylinder.

· Fueling is done in graph or matrix method for the tuners preference.

· All graphs or matrix data are interpolated to smooth fuel calculation accuracy for best performance though the operating ranges.

· Fuel is calculated with MAP or TPS sensor signals versus RPM or a combination of the two. This will accommodate most engines ranging from street to racing and from economy to performance.

· Other sensors that are used to alter the fuel mixture are Water, Air, Altitude, Lambda, Battery Volts and throttle response.

· Fuel injection timing is adjustable on gear type crank angle sensors as low as 12 pulses per revolution.

· Adjustable MAP sensor reading angle for multiple throttle body systems.

· Two types of micro fuel injection methods (staged injectors) namely Ratio adjust or Graph Fazed method.

Ignition Spark & Timing

· The ECU can do Single & Multi Coil Spark Systems

· Use standard coil packs on the engine.

· Can be connected to most coils without internal drivers directly. The latter requires a pull-up resistor.

· Very accurate ignition timing especially with the gear type triggers.

· Timing is calculated with MAP or TPS sensor signals versus RPM or a combination of the two. This will accommodate most engines ranging from street to racing.

· Other sensors that is used to alter the Ignition Timing is Water, Air and Altitude,

· Battery Volts is used to compensate for coil charge time.

Sensors

· The ECU use most standard sensors on the engine - No need to do modifications on distributors or converter boards.

· Custom Bolt-On Timing Gears may be used for older engines that run carburetors or engines with incorrect setups. Gear type triggers do make timing more accurate and responsive during blip conditions. This is the preferred method for racing applications.

· Sensors can be calibrated to accommodate the different types found on the engines.

Idle Control & Cold Start - This functions will ease with starting a cold engine and keep the RPM's constant when air conditioners or automatic transmissions draw power from the engine. Idle control is included on board for one and two wire idle valves. The Spitronics stepper control units can be connected to control quad and bipolar stepper motors.

Launch Control - this feature will increase boost pressure during pull-off to eliminate Turbo Lag. Various methods are available to activate launch like buttons clutch switches TPS position etc.

Two General Purpose Outputs - This can be used for injectors, fan control, shift light, Aircon Cut-Out on Pull-Off or Up-Hill etc.

Standard Harness - No need to keep several harnesses in stock for different engines. There are however custom harnesses for certain engines that will ease installation time. All the input wiring harnesses use screened cables for neatness of installation and to prevent electromagnetic interference which may cause erratic behavior of the ECU.

Compact Electronics - This will make the ECU easy to install under the dashboard as it takes very little space.

Complete Kits for Most Engines.

Cost Effective - No need to buy expensive systems as all the necessary features are included with the ECU.

Rotary Systems - The 2 & 3 rotor engines are covered by this ECU.

External Map Sensor - easy to change between 1Bar, 2.5Bar, 3Bar & 4Bar configurations External sensors are used to reduce the delay in the vacuum signal It makes the ECU more versatile to adapt to standard MAP sensors found on engines.

Altitude Compensation - This feature is important as the ECU will automatically compensate for differences in pressure.

Standard Tuning Software - The features that are not used or allowed in the tuning software will be blanked out.

Easy DIY Instructions - Save a lot of money on installation if you are a person who is up to the challenge.

Start-Up Maps included - This will make for easy start-up & tuning with the help of a Lambda sensor

User Friendly Tuning Software which is extensively explained in the manual.

Tuning map can be locked to prevent tampering. Useful for engine builders to give guarantees.

No Dyno Required - Tune your own vehicle and save some more money. Just following the instructions in the manual carefully.

(Note that the last four points are for the person who is handy with tools and understand wiring and operation of an engine. If you are not sure, download the software, Map, manual and drawing and experiment with it first. It's free of charge!)


Specifications

Help > Product Selection > Pluto2 >

Pluto2 Specifications

Power Supply

12V Ignition power 200mA, filtered by reverse polarity Diode, 700mA Poly switch and 25V Tranzorb

2.5mm2 Earth Strap

Inputs

2x Trigger inputs - Can be Magnetic or Hall or Optic inputs or combination of 2.

1x Map sensor input 0 - 5V

1x built in Altitude sensor input 0 - 5V optional

1x TPS sensor input 0 - 5V

1x Water Temperature Input - 2K NTC Resistance Sensor

1x Air Temperature Input - 10K NTC Resistance Sensor

1x Lambda Input 0 - 1 V or Processed 0 - 5V signal.

1x Dual Map Input

1x Tuning POT input 0 - 5V

Software UART Connection via USB2 converter cable

Firmware Programmer Connection

Outputs

6x 18A 450Volt N Channel Mossfets output Ground Floating (coil or injector drivers any combination)

1x Fuel Relay 3.5A Ground Output Floating, Over-current protected

1x RPM 3.5A Ground Output Floating with 1K pull-up resistor to 12V, Over-current protected

2x General Purpose 3.5A Ground Output Floating, Over-current protected

5V 600mA Power Output for TPS & Map Sensor and Magnetic Pickups

Dimensions

Size 95 x 60mm x 21mm

Weight 106g

3 x Connector Type Plastic Molex 12, 10, 6

Load Sites

Tuning Pallet | load sites | Resolution | Adjustment | Adjustment |
 |  |  | Resolution | Range |
Fuel Vacuum Graph | 64 | Auto Range | 0.1 ms | 0 to 25 ms | Interpolated
5 x Fuel RPM Graph | 32 | Auto Range | 1% | -50% to 50% |
Micro Fuel Vacuum Graph | 32 | Auto Range | 0.1 ms | 0 to 25 ms | Interpolated
Dynamic Timing Graph | 150 | 100 RPM | 1° | 0° to 45° | Interpolated
2 x Vacuum Timing Graph | 32 | Auto Range | 1° | -15° to 25° | Interpolated
Trailing Degrees Graph | 30 | 500 RPM | 1° | 0° to 45° | Interpolated
Water Temperature Timing Graph | 24 | 0° to 120° | 1° | -50° to 50° | Interpolated
Water Temperature Fuel Graph | 24 | 0° to 120° | 1% | -50% to 50% | Interpolated
Air Temperature Timing Graph | 24 | -20° to 100° | 1° | -50° to 50° | Interpolated
Air Temperature Fuel Graph | 24 | -20° to 100° | 1% | -50% to 50% | Interpolated
Lambda MAP Graph | 24 | Auto Range | 1% | -50% to 50% | Interpolated
Lambda RPM Graph | 24 | Auto Range | 1% | -50% to 50% | Interpolated
Fuel Matrix | 16x16 | Auto Range | 0.1 ms | 0 to 25 ms | Interpolated
Graph Matrix | 16x16 | Auto Range | 1° | 0° to 45° | Interpolated
Battery Fuel Graph | 20 | 0.5V | 1% | -50% to 50% | Interpolated
Battery Charge Time Graph | 20 | 0.5V | 1% | -50% to 50% | Interpolated


Selection Chart

Help > Product Selection > Pluto2 >

Pluto2 Selection

The Pluto2 is sold in six hardware classes categorized by the features required for each engine. The advantage is that basic applications is sold cheaper than more complex applications. These features can be activated or changed over the internet which eliminates time lost and courier costs. This makes it viable to have these units in stock at low entry cost and activate the features later when the project is started. The PC Tuning software is standard for all units. Certain features will be blanked out if it is not available. The firmware categories are Micro, Basic, Standard, Intermediate, Advance and Ultimate. On the ECU only 5 classes are implemented at this stage. Please look at the following charts to see which hardware class will suit your application.

Pluto2 Hardware | Standard | Intermediate | Advance | Ultimate |
Hardware Inputs |  |  |  |  |
Map Sensor | 1 | 1 | 1 | 1 |
TPS Sensor | 1 | 1 | 1 | 1 |
Water Temp Sensor 2K NTC | 1 | 1 | 1 | 1 |
Air Temp Sensor 10K NTC | 1 | 1 | 1 | 1 |
Lambda | 1 | 1 | 1 | 1 |
Altitude Sensor |  |  |  |  |
Built In Altitude Sensor | 1 | 1 | 1 | 1 | Note 1
Tuning Pot | 1 | 1 | 1 | 1 |
Fuel Pressure Sensor |  |  |  |  |
Dual Map Switch | 1 | 1 | 1 | 1 |
Battery Volts | 1 | 1 | 1 | 1 |
Power Management | 1 | 1 | 1 | 1 |
Crank Trigger Pulse | 1 | 1 | 1 | 1 |
TDC/Home Pulse | 1 | 1 | 1 | 1 |
VVTI Cam 1 Pulse |  |  |  |  |
VVTI Cam 2 Pulse |  |  |  |  |
USB/Programmer 9Pin D-Sub |  |  |  |  |
USB/Programmer 6Pin Molex | 1 | 1 | 1 | 1 |
Hardware Outputs |  |  |  |  |
Injector Drivers Negative Out | 2 | 4 | 2(4) | 2(4) | Note 2
Internal Coil Drivers Negative Out | 1 | 1 | 4(2) | 4(2) | Note 2
External Coil Triggers Positive Out |  |  |  |  |
RPM Output | 1 | 1 | 1 | 1 |
Electronic Relay Output |  |  |  |  |
Relay Output | 1 | 1 | 1 | 1 |
GP Outputs | 2 | 2 | 2 | 2 |
Features |  |  |  |  |
Graph Tuning | 1 | 1 | 1 | 1 |
Matrix Tuning | 1 | 1 | 1 | 1 |
Idle Control | 1 | 1 | 1 | 1 | Note 2
Dual Maps | 1 | 1 | 1 | 1 |
Micro Fueling or Fazed Injector | 1 | 1 | 1 | 1 |
Full Sequential Injector Control |  |  |  |  |
Fuel Pressure Control |  |  |  |  |
V-Tech Cam Control | 1 | 1 | 1 | 1 |
VVTI Cam Control |  |  |  |  |
Launch control | 1 | 1 | 1 | 1 |
Anti-Lag control | X | X | X | X |
Flat-Shift control | X | X | X | X |
Boost control |  |  |  |  |
Throttle x Wire control |  |  |  |  |
RPM Calibration | 1 | 1 | 1 | 1 |
Epoxy filed |  |  |  |  |
Can be Epoxy filed | 1 | 1 | 1 | 1 |
Notes |  |  |  |  |
Note 1 - This sensor is optional and must be installed on request
Note 2 - There are 6 drivers to share in combination with injectors and coils
Note 3 - For Stepper motors external hardware is required |  |  |  |  |
X - Capable - Firmware not yet developed |  |  |  |  |


Safety Precautions

Help >

Safety Precautions

The following guidelines in this manual will ensure proper product operation the first time. Failure to install the product correctly may cause the device damage or other equipment permanently. These failures will solely be the responsibility of the installer and no guarantees will be given by Spitronics. Make sure you have read the Terms and Conditions in this manual or on the website www.spitronics.co.za before you install this product. By installing the product you automatically agree to these conditions. All equipment is tested before it leaves the factory. We accept no liability for malfunctioning of the equipment, or to injury that may result from installation or the use of the equipment. We also accept no liability for costs of traveling of transportation of the equipment or parts or vehicle recovery due to failures of any equipment. Please read the instructions, drawings and make sure you understand before you begin.

2.1 Operator Safety

  • Use only proper tools and products suited for auto installations. Substandard products and installation procedures may cause failure to the equipment having your customer break down in dangerous areas.
  • Use correct thickness and approved quality of wire to carry the entire current requirement for that circuit. Too thin wires will heat up and may start a fire causing injury.
  • Use fuses to protect each circuit separately. Joint circuits require large fuses which may heat and melt lesser circuits causing fires.
  • Solder joints, and cover them with shrink sleeve to prevent loose connections which may cause fire. Space solder-joints so that they are not situated next to each other in the harness thus minimizing the chance of a short circuit.

See the individual Safety Precautions for each product.


Mercury2

Help > Safety Precautions >

Mercury2 Safety Precautions

Connecting

· Never connect a Mercury2 on other harnesses that have the same connectors.

· Connect the ECU earth strap and the harness Earth wires to a proper earth on the body.

· Leave the output connectors P2, P3 and P5 disconnected when you switch the ECU on the first time.

· Test the installation before connecting the ECU. This will prevent damage due to faulty wiring.

· Make sure that relay pin numbers of the relay correspond with the drawing. Some relays differ on the contact pattern and may damage the ECU.

· Make sure that the coils and injectors get their power from the Saturn power relays. This relay will only switch on after the ECU has selected the logic level for the driver. Powering them from the vehicles power will damage the drivers and coils.

· Check that coil connections are secure. Loose connections will damage the coil driver Mossfets.

· The TPS must be connected correctly as it may damage the ECU or TPS permanently.

· Do not put cutout switches from coil negative to earth as this will damage the coil permanently. Rather break the supply line through a switch so that the module does not have power.

· Do not connect the ECU outputs directly to solenoids or fuel pumps unless it is shown on a drawing. Check the current rating or the outputs in the Specifications.

· Test the coil resistance to see which type coil you are using and if it is still functional. This is important to program the correct parameters. See Coil Selection. If you are not sure take it to your agent for a test, or start with the lowest Coil charge time values namely 1 or 2 milliseconds.

· Make sure of the type of injectors and connect them according to the recommendations. There is a wiring difference between low and high impedance injectors.

· Never connect direct injection injectors to the ECU. Their resistance is very low and will damage the ECU and the Injector.

· The trigger input may not be connected to coil negative. The high voltage spikes on coil negative will damage the unit permanently.

· Make sure about the correct Jumper Settings before you switch the ignition on.

· Do not disconnect high tension leads and let them hang loose. It creates feedback voltage that may destroy the ECU.

· Never run HT leads with ECU harnesses. A crack in the HT lead will cause a spark to jump to the ECU harness and damage it.

Power

· Ensure that fuses are the minimum value required to hold the current. Too large fuses will not blow resulting in driver or coil destruction.

· Connect the relay supply power directly to battery positive via a fuse as shown in the drawings, otherwise voltage drops will cause lean mixtures.

· Connect the injectors to its own relay if mechanical relays are used as other items will cause a voltage drop and result in leaner mixtures.

· Do not connect screen wires on the engine. The starter will draw current through them melting the harness. It will also bring all the engine interference in the ECU.

· Ensure a proper earth between battery negative and chassis and also between battery negative and the engine. Do not earth the engine on the body or the body on the engine.

· Do not disconnect the battery while engine is running. The alternator will create high voltage spikes which will damage the ECU permanently.

· Ensure that all connections from the battery and alternator are secure.

· Connect the alternator charge wire directly to battery positive and not to the harness somewhere. This causes voltage spikes on the common wire.

· Never switch the power on, if the ECU earth strap is not earthed properly - this may damage sensors or the ECU.

Programmer

If you have a firmware programmer, ensure you only load firmware with the starting name Mercury2. Never press the ''Erase All Code space'' button. This will wipe the device information and it will have to be reset at the manufacturer. Always disconnect the output cables P2, P3 and P5 when using the programmer. Outputs may switch on damaging drivers, coils or fill the cylinder with fuel. See the programmer manual for correct operation.

Interference

· Install free-wheel Diodes on other relays to prevent spikes from interfering with the ECU. Always put the stripe side of the diode to the positive side of the signal. See the drawings for correct connections.

· Connect screen input wires as close to the sensor wires to minimise exposure of open wires to electro-magnetic noise.

· The spark plug leads can cause interference with the ECU wiring. Keep the ECU wires away from the ignition leads wherever possible. If it is necessary to cross the ignition leads, cross it at right angles.

Wiring Reliability
The wiring is critical for reliable operation of the ECU. The following points will help to ensure that the wiring is reliable:

Earth Wiring
One of the most common wiring problems is poor earth wiring. The earth wire must be earthed properly to the chassis and there must be no paint or anodizing between the earth wire and mounting point. Temporary wiring is likely to cause problems, use the proper terminal that is securely crimped to the earth wires. These comments apply to both the ECU earth wire and the ignition system earth wires.

Power wiring
The power required for the fuse box must be wired by the shortest possible path to the battery via relays activated by the ECU. This power must not be fed directly from the ignition switch because it won't be able to handle the required current. The relay must be in good condition and the wires must be crimped securely to the appropriate terminals.

Terminal crimping
Use the correct crimping tool for each type of terminal. Do a pull test on a sample wire and terminal to verify that the crimp is done properly. In theory the wire should break before the wire pulls out the crimp. Most crimp tools are only designed for a certain range of wire sizes so be sure to test the crimp with the particular wire size being used. Soldering the terminal is the last resort if the correct crimping tool is not available.

Terminal Damage
Connector terminals are easily damaged if probes are inserted into them. If checking a circuit for continuity gently touch the side of the terminal only.

Wire splicing
Use a crimp splice to join wires. If you solder a wire in a splice, ensure that wire movement near the splice is avoided because a fracture might occur at the stress point created by the solder. Use heat shrink to insulate and provide support to the wires. Never simply connect wire splices without solder or a crimp splice. These types of joins will corrode rendering it without connection. Never use 'Vampire Taps' & 'Plastic Butt Splices'. The first is an absolute NO. Vampire taps only work under ideal conditions and wire thickness. Too big and they make a poor connection, too small and they chop the wire in half. Both of these failures are acceptable for stereo systems, but not when you're hooking up things like injectors or ignition coils.

Wire strain

Avoid pulling wires tight at the connectors. Ensure that wires are kept away from hot or sharp parts in the engine. Also ensure that engine movement does not put strain on the wires, as metal fatigue will break the wires in time, resulting in ECU failure.


Pluto2

Help > Safety Precautions >

Pluto Safety Precautions

Connecting

· Never connect a Pluto on other harnesses that have the same connectors.

· Connect the ECU earth strap and the harness Earth wires to a proper earth on the body.

· Leave the output connector P2 disconnected when you switch the ECU on the first time.

· Test the installation before connecting the ECU. This will prevent damage due to faulty wiring.

· Make sure that relay pin numbers of the relay correspond with the drawing. Some relays differ on the contact pattern and may damage the ECU.

· Make sure that the coils and injectors get their power from the Saturn power relays. This relay will only switch on after the ECU has selected the logic level for the driver. Powering them from the vehicles power will damage the drivers and coils.

· Check that coil connections are secure. Loose connections will damage the coil driver Mossfets.

· Ensure that the Trigger Output Level of the coils is correctly set for the coils you are using, before you connect the 10 Way connecter. Having this wrong may damage the ECU and coil permanently.

· The TPS must be connected correctly as it may damage the ECU or TPS permanently.

· Do not put cutout switches from coil negative to earth as this will damage the coil permanently. Rather break the supply line through a switch so that the module does not have power.

· Do not connect the ECU outputs directly to solenoids or fuel pumps unless shown on a drawing. Check the current rating in the Specifications.

· Test the coil resistance to see which type coil you are using and if it is still functional. This is important to program the correct parameters. See Coil Selection. If you are not sure take it to your agent for a test, or start with the lowest Coil charge time values namely 1 or 2 milliseconds.

· Make sure of the type of injectors and connect them according to the recommendations. There is a wiring difference between low and high impedance injectors.

· Never connect direct injection injectors to the ECU. Their resistance is very low and will damage the ECU and the Injector.

· The trigger input may not be connected to coil negative. The high voltage spikes on coil negative will damage the unit permanently.

· Make sure about the correct Jumper Settings before you switch the ignition on.

· Do not disconnect high tension leads and let them hang loose. It creates feedback voltage that may destroy the ECU.

· Never run HT leads with ECU harnesses. A crack in the HT lead will cause a spark to jump to the ECU damaging it.

Power

· Ensure that fuses are the minimum value required to hold the current. Too larger fuses will not blow resulting in driver or coil destruction.

· Connect the relay supply power directly to battery positive via a fuse as shown in the drawings, otherwise voltage drops will cause lean mixtures.

· Connect the injectors to its own relay if mechanical relays are used as other items will cause a voltage drop and result in leaner mixtures.

· Do not connect screen wires on the engine. The starter will draw current through and melt the harness. It will also bring all the engine interference in the ECU.

· Ensure a proper earth between battery negative and chassis and also between battery negative and the engine. Do not earth the engine on the body or the body on the engine.

· Do not disconnect the battery while engine is running. The alternator will create high voltage spikes which will damage the ECU permanently.

· Ensure that all connections from the battery and alternator are secure.

· Connect the alternator charge wire directly to battery positive and not to the harness somewhere. This causes voltage spikes on the common wire.

· Never switch the power on, if the ECU earth strap is not earthed properly - this may damage sensors or the ECU.

Programmer

If you have a firmware programmer, ensure you only load firmware with the starting name Pluto2. Never press the ''Erase All Code space'' button. This will wipe the device information and it will have to be reset at the manufacturer. Always disconnect the output cables P2 when using the programmer. Outputs may switch on damaging drivers, coils or fill the cylinder with fuel. See the programmer manual for correct operation.

Interference

· Install free-wheel Diodes on other relays to prevent spikes from interfering with the ECU. Always put the stripe side of the diode to the positive side of the signal. See the drawings for correct connections.

· Connect screen input wires as close to the sensor wires to minimise exposure of open wires to electro-magnetic noise.

· The spark plug leads can cause interference with the ECU wiring. Keep the ECU wires away from the ignition leads wherever possible. If it is necessary to cross the ignition leads, cross it at right angles.

Wiring Reliability
The wiring is critical for reliable operation of the ECU. The following points will help to ensure that the wiring is reliable:

Earth Wiring
One of the most common wiring problems is poor earth wiring. The earth wire must be earthed properly to the chassis and there must be no paint or anodizing between the earth wire and mounting point. Temporary wiring is likely to cause problems, use the proper terminal that is securely crimped to the earth wires. These comments apply to both the ECU earth wire and the ignition system earth wires.

Power wiring
The power required for the fuse box must be wired by the shortest possible path to the battery via relays activated by the ECU. This power must not be fed directly from the ignition switch because it won't be able to handle the required current. The relay must be in good condition and the wires must be crimped securely to the appropriate terminals.

Terminal crimping
Use the correct crimping tool for each type of terminal. Do a pull test on a sample wire and terminal to verify that the crimp is properly done. In theory the wire should break before the wire pulls out the crimp. Most crimp tools are only designed for a certain range of wire sizes so be sure to test the crimp with the particular wire size being used. Soldering the terminal is the last resort if the correct crimping tool is not available.

Terminal Damage
Connector terminals are easily damaged if probes are inserted into them. If checking a circuit for continuity gently touch the side of the terminal only.

Wire splicing
Use a crimp splice to join wires. If you solder a wire in a splice ensure that wire movement near the splice is avoided because a fracture might occur at a stress point created by the solder. Use heat shrink to insulate and provide support to the wires. Never simply connect wire splices without solder or a crimp splice. These type of joins will corrode rendering it without connection. Never use 'Vampire Taps' & 'Plastic Butt Splices'. The first is an absolute NO. Vampire taps only work under ideal conditions and wire thickness. Too big and they make a poor connection, too small and they chop the wire in half. Both of these failures are acceptable for stereo systems, but not when you're hooking up things like injectors or ignition coils.

Wire strain

Avoid pulling wires tight at the connectors. Ensure that wires are kept away from hot or sharp parts in the engine. Also ensure that engine movement does not put strain on the wires, as metal fatigue will break the wires in time, resulting in ECU failure.


Saturn

Help > Safety Precautions >

Saturn Safety Precautions

Connecting

· Never connect a Saturn on other harnesses that have the same connectors.

· Connect the ECU earth strap and the harness Earth wires to a proper earth on the body.

· Leave the output connector P2, P3 and P4 disconnected when you switch the ECU on the first time.

· Test the installation before connecting the ECU. This will prevent damage due to faulty wiring.

· Make sure that relay pin numbers of the relay correspond with the drawing. Some relays differ on the contact pattern and may damage the ECU.

· Make sure that the coils and injectors get their power from the Saturn power relays. This relay will only switch on after the ECU has select the logical level for the driver. Powering them from the vehicles power will damage the drivers and coils.

· Check that coil connections are secure. Loose connections will damage the coil driver Mossfets.

· Ensure that the Trigger Output Level of the coils is correctly set for the coils you are using, before you connect the 10 Way connector. Having this wrong may damage the ECU and coil permanently.

· The TPS must be connected correctly as it may damage the ECU or TPS permanently.

· Do not put cutout switches from coil negative to earth as this will damage the coil permanently. Rather break the supply line through a switch so that the module does not have power.

· Do not connect the ECU outputs directly to solenoids or fuel pumps unless shown on a drawing. Check the current rating in the Specifications.

· Test the coil resistance to see which type coil you are using and if it is still functional. This is important to program the correct parameters. See Coil Selection. If you are not sure take it to your agent for a test, or start with the lowest Coil charge time values namely 1 or 2 milliseconds.

· Make sure of the type of injectors and connect them according to the recommendations. There is a wiring difference between low and high impedance injectors.

· Never connect direct injection injectors to the ECU. Their resistance is very low and will damage the ECU and the Injector.

· The trigger input may not be connected to coil negative. The high voltage spikes on coil negative will damage the unit permanently.

· Make sure about the correct Jumper Settings before you switch the ignition on.

· Do not disconnect high tension leads and let them hang loose. It creates feedback voltage that may destroy the ECU.

· Never run HT leads with ECU harnesses. A crack in the HT lead will cause a spark to jump to the ECU damaging it.

Power

· Ensure that fuses are the minimum value required to hold the current. Too larger fuses will not blow resulting in driver or coil destruction.

· Connect the relay supply power directly to battery positive via a fuse as shown in the drawings, otherwise voltage drops will cause lean mixtures.

· Connect the injectors to its own relay if mechanical relays are used as other items will cause a voltage drop and result in leaner mixtures.

· Do not connect screen wires on the engine. The starter will draw current through and melt the harness. It will also bring all the engine interference in the ECU.

· Ensure a proper earth between battery negative and chassis and also between battery negative and the engine. Do not earth the engine on the body or the body on the engine.

· Do not disconnect the battery while engine is running. The alternator will create high voltage spikes which will damage the ECU permanently.

· Ensure that all connections from the battery and alternator are secure.

· Connect the alternator charge wire directly to battery positive and not to the harness somewhere. This causes voltage spikes on the common wire.

· Never switch the power on, if the ECU earth strap is not earthed properly - this may damage sensors or the ECU.

Programmer

If you have a firmware programmer, ensure you only load firmware with the starting name Saturn. Never press the ''Erase All Code space'' button. This will wipe the device information and it will have to be reset at the manufacturer. Always disconnect the output cables P2, P3 and P4 when using the programmer. Outputs may switch on damaging drivers, coils or fill the cylinder with fuel. See the programmer manual for correct operation.

Interference

· Install free-wheel Diodes on other relays to prevent spikes from interfering with the ECU. Always put the stripe side of the diode to the positive side of the signal. See the drawings for correct connections.

· Connect screen input wires as close to the sensor wires to minimise exposure of open wires to electro-magnetic noise.

· The spark plug leads can cause interference with the ECU wiring. Keep the ECU wires away from the ignition leads wherever possible. If it is necessary to cross the ignition leads, cross it at right angles.

Wiring Reliability

The wiring is critical for reliable operation of the ECU. The following points will help to ensure that the wiring is reliable:

Earth Wiring
One of the most common wiring problems is poor earth wiring. The earth wire must be earthed properly to the chassis and there must be no paint or anodizing between the earth wire and mounting point. Temporary wiring is likely to cause problems, use the proper terminal that is securely crimped to the earth wires. These comments apply to both the ECU earth wire and the ignition system earth wires.

Power wiring
The power required for the fuse box must be wired by the shortest possible path to the battery via relays activated by the ECU. This power must not be fed directly from the ignition switch because it won't be able to handle the required current. The relay must be in good condition and the wires must be crimped securely to the appropriate terminals.

Terminal crimping
Use the correct crimping tool for each type of terminal. Do a pull test on a sample wire and terminal to verify that the crimp is properly done. In theory the wire should break before the wire pulls out the crimp. Most crimp tools are only designed for a certain range of wire sizes so be sure to test the crimp with the particular wire size being used. Soldering the terminal is the last resort if the correct crimping tool is not available.

Terminal Damage
Connector terminals are easily damaged if probes are inserted into them. If checking a circuit for continuity gently touch the side of the terminal only.

Wire splicing
use a crimp splice to join wires. If you solder a wire in a splice ensure that wire movement near the splice is avoided because a fracture might occur at a stress point created by the solder. Use heat shrink to insulate and provide support to the wires. Never simply connect wire splices without solder or a crimp splice. These type of joins will corrode rendering it without connection. Never use 'Vampire Taps' & 'Plastic Butt Splices'. The first is an absolute NO. Vampire taps only work under ideal conditions and wire thickness. Too big and they make a poor connection, too small and they chop the wire in half. Both of these failures are acceptable for stereo systems, but not when you're hooking up things like injectors or ignition coils.

Wire strain

Avoid pulling wires tight at the connectors. Ensure that wires are kept away from hot or sharp parts in the engine. Also ensure that engine movement does not put strain on the wires, as metal fatigue will break the wires in time, resulting in ECU failure.


ECU Hardware Description

Help >

ECU Hardware

The Spitronics Mercury2, Pluto2 and Saturn ECU's are featured in this manual as these units are current production models. Some older models using this firmware will also be addressed in this manual, however the hardware descriptions will not be covered here. Mercury2 is the Spitronics flagship product with overcurrent protection. Pluto2 and Saturn are the economy products for lower budget applications.

(See sub folders for more information on this hardware)


ECU Layout

Help > ECU Hardware Description >

Connector Pin Layout

This chapter indicates which signals is found on each Pin of the harnesses. Note: The sample pictures are the harness connector viewed from the wire side. Or it could be the PCB connector viewed from the Pin side. Always make sure about this when you work from a drawing.

12 Way

10 Way

8 Way

6 Way

4 Way

(See sub folders for Product Pin-Outs.)


Mercury2 Layout

Help > ECU Hardware Description > ECU Layout >

Mercury2 Layout

1. Yellow LED - 5 Volt Power on

2. Green1 LED - RPM Output

3. Green2 LED - N8 output

4. Red1 LED - P8 output

5. Red2 LED - P7 output

6. Coms - Communication Connecter 6 Way - USB Cable & Programmer

7. Jumpers Hall Sensors - Crank Pull-up Left - TDC Pull-up Right

8. P1 - Input Connector 12 Way

9. P4 - Input and Output Connector 6 Way

10. P2 - Positive Output Connector 10 Way

11. P5 - Positive & Ground Output Connector 4 Way

12. P3 - Ground Output Connector 8 Way

13. Mounting Holes 5mm


Mercury2 Connector Sample

Help > ECU Hardware Description > ECU Layout >
Mercury2 Input / Outputs
P1 - 12 Way Input
Water Temp | 7 | 1 | Air Temp
Lambda | 8 | 2 | TPS
.+5 Volt Out | 9 | 3 | MAP
.+12 Volt Ign | 10 | 4 | GND
TDC Sensor | 11 | 5 | Cam2 Sensor
Crank Sensor | 12 | 6 | Cam1 Sensor
P2 - 10 Way TCU
P2 12 Volt | 6 | 1 | P1 12 Volt
P4 12 Volt | 7 | 2 | P3 12 Volt
P6 12 Volt | 8 | 3 | P5 12 Volt
Electronic Relay | 9 | 4 | Relay Out
.+12 Volt In | 10 | 5 | .+12 Volt In
P3 - 8 Way ECU
N6 Ground | 5 | 1 | N5 Ground
N4 Ground | 6 | 2 | N3 Ground
N2 Ground | 7 | 3 | N1 Ground
RPM Out | 8 | 4 | GP1 Out
P4 - 6 Way
Fuel Sensor | 4 | 1 | GP2 Out
POT | 5 | 2 | Altitude
.+5 Volt Out | 6 | 3 | GND
P5 - 4 Way
N8 Ground | 3 | 1 | N7 Ground
P8 12 Volt | 4 | 2 | P7 12 Volt
Comms - 6 Way USB
Programmer 2 | 4 | 1 | Programmer 1
Receive | 5 | 2 | Transmit
.+5 Volt Out | 6 | 3 | GND


Pluto2 Layout

Help > ECU Hardware Description > ECU Layout >

Pluto2 Layout

1. Yellow LED - 5 Volt Power on

2. Green LED - Multi Function - Normally Crank Sensor

3. Red LED - Multi Function - Normally Cam Sensor

4. Coms - Communication Connecter 6 Way - USB Cable, Programmer, Dual Map SW and Tuning POT

5. P1 - Input Connector 12 Way

6. P2 - Ground Output Connector 10 Way

7. Mounting Holes 5mm


Pluto2 Connector Sample

Help > ECU Hardware Description > ECU Layout >
Pluto2 Input / Outputs
12 Way Input
Water Temp | 7 | 1 | Air Temp
Lambda | 8 | 2 | TPS
.+5 Volt Out | 9 | 3 | MAP
.+12 Volt Ign | 10 | 4 | GND
TDC Sensor | 11 | 5 | TDC Power
Crank Sensor | 12 | 6 | Crank Power
10 Way ECU
N1 Ground | 6 | 1 | N2 Ground
N3 Ground | 7 | 2 | N4 Ground
N5 Ground | 8 | 3 | N6 Ground
RPM Out | 9 | 4 | Relay Out
GP2 Out | 10 | 5 | GP1 Out
6 Way USB
Programmer 2 (Tuning Pot) | 4 | 1 | Programmer 1 (Dual Map Sw)
Receive | 5 | 2 | Transmit
.+5 Volt Out | 6 | 3 | GND


Saturn Layout

Help > ECU Hardware Description > ECU Layout >

Saturn Layout

1. Yellow LED - 5 Volt Power on

2. Green1 LED - Multi Function - Normally Crank Sensor

3. Green2 LED - Multi Function - Normally Cam Sensor

4. Red1 LED - Not used

5. Red2 LED - Not used

6. Coms - Communication Connecter 6 Way - USB Cable, Programmer, Dual Map SW and Tuning POT

7. Jumpers Hall Sensors - Crank(TDC) Hall/Mag Left - Cam(Home) Hall/Mag Right

8. P1 - Input Connector 12 Way

9. P4 - Not Used

10. P3 - 2xGP Output Connector 8 Way

11. P2 - Negative Output Connector 10 Way

12. Mounting Holes 5mm


Saturn Connector Sample

Help > ECU Hardware Description > ECU Layout >
Saturn Input / Outputs
12 Way Input
Water Temp | 7 | 1 | Air Temp
Lambda | 8 | 2 | TPS
.+5 Volt Out | 9 | 3 | MAP
.+12 Volt Ign | 10 | 4 | GND
TDC Sensor | 11 | 5 | TDC Power
Crank Sensor | 12 | 6 | Crank Power
10 Way ECU
N1 Ground | 6 | 1 | N2 Ground
N3 Ground | 7 | 2 | N4 Ground
N5 Ground | 8 | 3 | N6 Ground
RPM Out | 9 | 4 | Relay Out
GP2 Out | 10 | 5 | GP1 Out
8 Way ECU
Not Used | 5 | 1 | Not Used
Not Used | 6 | 2 | Not Used
Not Used | 7 | 3 | Not Used
GP4 Out | 8 | 4 | GP3 Out
6 Way USB
Programmer 2 (Tuning Pot) | 4 | 1 | Programmer 1 (Dual Map Sw)
Receive | 5 | 2 | Transmit
.+5 Volt Out | 6 | 3 | GND


Engine Sensor and Inputs

Help > ECU Hardware Description >

Engine Sensors

The Spitronics ECU's were designed to read most standard sensors on most engines without modification to them. This will ease installation and lower costs.

(See sub folders for explanation on each different type.)


Crank and Cam angle sensors

Help > ECU Hardware Description > Engine Sensor and Inputs >

Crank and Cam angle sensors

The crank and cam angle sensors on an engine is used to determine crank and cam angles. (See the sub folders for more information.)

A crank angle sensor can be used alone for non VVTI engines, but this can only give information relative to 360 degrees. This engine will only run with split sequential injection and wasted spark coil firing. If full sequential injection is selected, injection is not in sink per engine stroke. It means you may sometime inject on the bottom deck of exhaust stroke and sometimes on bottom end of compression stroke. The aim is to always go for injection angle at bottom stroke just after the intake valve closes. Here atomization will be at its best and also consistent even if the stroke is not in sink. Full sequential spark is not possible in this scenario.

The cam angle sensor will give the ECU information over 720 degrees. This will indicate the 4 strokes for sequential injection or coil firing. Depending on the trigger wheel designs, some engines may need up to 2 revolutions cranking before the ECU can sink properly. Some programs may start in split sequential injection and fire the injectors in split sequential to enhance starting. Thereafter it will go to full sequential mode and stay there.

VVTI engines may have additional cam angle sensors that indicates the cam angle relative to the crank angle. This will let the ECU calculate and manipulate the cam angle for RPM and load variances. There may be intake cam control, exhaust cam control and also lift control. Then V type engines have all this in dual banks.

There are three types of sensors. The Magnetic reluctor sensor, Optic sensor and Hall type sensor.

The Magnetic reluctor sensor is a coil wound over a magnet. The teeth on the crank gear will disturb the magnetic field and that will generate a voltage spike over the 2 wires. The sensor is normally located on the engine block and picks up from a toothed wheel on the crankshaft. The physical position of the sensor may vary from front pulley, inside block and flywheel.

Hall and optic sensors both give a square wave outputs and are treated exactly the same. They have electronic components in the sensor which convert the signals to square wave. The Hall sensor uses magnetic field where optic sensor uses infrared light. In both cases a beam is broken and detected. The sensor output is usually an open collector transistor which means it will require a pull-up resistor normally situated in the ECU or TCU. This sensor is normally located on the valve cover and picks up protruded teeth from the camshaft. The physical position of the sensor may vary. The VVTI sensor will be positioned on the actual camshaft and not on the cam pulley to measure cam movement.

Related Links

Software Setup


Crank and Cam sensor tapping

Help > ECU Hardware Description > Engine Sensor and Inputs > Crank and Cam angle sensors >

Crank & Cam signal tapping

The Spitronics ECU's can be tied into existing OEM ECU circuits. There are a few rules around this to ensure that both systems operate correctly and are not damaged. This varies for the different products and sensors.

ECU's that share a sensor has to share a common earth connection. Differences in earth will have an effect on the sensors signal. So make sure you connect the Spitronics earth with the OEM earth.

Isolating capacitors is required for Pluto2 and Saturn when tapping into magnetic sensors. There are DC volt connections on their signal wire inputs that will cause current flow into the sensor, this will cause the signal to deform and the ECU will not operate correctly. This is a 1uF 100-volt non-polarised capacitor. Using a polarised cap may work in some cases, if the polarity is connected in the correct voltage level. If not, it will act as a short in the wrong voltage level. Ask your dealer about this before ordering. Mercury2 has built-in capacitors for this purpose.

NB: Never connect the reference voltage of the Spitronics ECU to any wire of the OEM sensor. Only the sensor wire. It may damage either ECU. The sensor already has power or reference voltage from the OEM ECU. (See the drawings below.)

Always put the jumper settings for the Spitronics Pluto2 and Saturn to magnetic setting and open the 2 pin filter or pull-up jumpers.

Isolate the Spitronics wires that are not used. They will have power on them and may short circuit, damaging the ECU or harness.

If the OEM sensor is not screened, it is best to tie in close to the sensor and use the Spitronics screened harness. It may reduce some interference from coils. Remember Spitronics inputs need to cater for all kinds of sensors and cannot cater for week signals with interference. If you still have interference, then you may add a 100uF and 100nF cap is filtering on their reference line. See drawings below on Mercury2 Tap-in Sensor filtering. NB. Do make sure which line is signal and which is reference. Crank the engine and measure AC volts. The one with the highest value will be the signal line.

The blue Reference volts come from the OEM ECU and differs between car manufacturers. Some use earth as a reference, other 2.4 volt, 5 volt and even 12 volt. The isolating capacitor will block the DC volts from flowing and only let AC signal volts through. The 1uF cap will only let a small amount of energy through, enough for the sensitive inputs to read. Mercury2 reference its sensor to earth. Pluto2 and Saturn reference to 5 volt. Note: Mercury2 requires a minimum 0.5 volt peak to peak signal while Pluto2 and Saturn requires a 1.0 volt signal.

Some cars may have a magnetic crank sensor in combination with a Hall cam sensor. Connect them accordingly. All the Spitronics P1 connectors has the same pattern for crank (Pin 12) and cam (Pin 11) input signal. Note: Harness colours differ and should be verified on drawings or GP Priority charts. (See the drawings below for the basic connections.)

Mercury2 Magnetic Sensor

Mercury2 Hall Sensor

Mercury2 Tap-in Sensor Filtering

Pluto2 Saturn Magnetic Sensor

Pluto2 Saturn Hall Sensor

Isolating Capacitor

Related Links

Software Setup

Jumper Settings


Testing Magnetic Crank sensor

Help > ECU Hardware Description > Engine Sensor and Inputs > Crank and Cam angle sensors >

Testing Magnetic Crank Triggers

Work through each point below to find your problem.

1. First ensure that the setup in Hyperspace is done according to the startup procedure. This means you will only have a P1 connector, and on Mercury2 also a P4 connector. The other connectors must be open, except for the comms cable. Open the software and connect to the ECU.

2. Ensure that the correct firmware is loaded into the ECU for the specific trigger pattern of your engine. You can click on information button [image] to verify.

3. Make sure the Jumper settings are set for magnetic sensors. On Pluto2 and Saturn it must be set to 5-volt position and the 2 pin jumper must be open. On Mercury2 the 2-pin jumper must be open. You may now crank the engine without the other connectors.

4. Ensure that battery volts on the Real-time Volt Bar [image] does not fall too low. A healthy battery will crank at 11 volts and higher. Under 9 volts, the sensor signal becomes weak and falls below the voltage threshold of the specific ECU. Note: If it falls below 10 see chapter about 'Power Connection'.

5. Look if any error codes are displayed at the bottom. If there are errors remedy the fault. See Error codes.

6. Look at the RPM signal in the Real-time Display while cranking. It should show 200 to 300 rpm consistently. If it shows erratic readings and runs wild do not proceed to start! It must be constant. It means the edge setting is wrong or incorrect firmware or there is interference on the trigger signal and the ECU sees them as trigger pulses.

7. If it shows no error and no RPM it means that the ECU does not pick up the signal from the crank sensor. Proceed to testing the crank sensor itself.

8. Make sure you use the correct sensor size with your crank trigger wheel size. If the magnet of the sensor is larger than the gap in the teeth, then your signal will be very week. Rather use a gear with less teeth for the diameter or a sensor with a smaller sensing diameter. If you can't see the magnet protruding from the sensor, put a bit of iron filings on the tip. The magnetic field will show the diameter of the internal magnet immediately. In this case you may enlarge the sensing distance it the signal is strong enough. See the illustration below.

Testing the sensor.

1. Ensure that the thick black earth wire from the ECU is earthed properly. Also make sure that the thin black wires coming from the harnesses are also tied to this point. We call this junction Test Point A

2. Disconnect P1 from the ECU. Now use a multi meter and set it on 2000-ohm scale.

3. For Mercury2, measure from Test Point A to pin 12 on the P1 harness connecter. Pluto2 or Saturn is measured between pin 12 and 6. You should get a resistance of 300 to 2000 ohm depending on the sensor. If you swop the meter wires you must read the same ohm measurement. If you don't get a reading it means your sensor is not connected correctly. Check your wiring connections. NB! Do not press too hard on the female pins as you may damage them resulting in poor contact later.

Harness Pin view

4. If you do get a reading put the meter on AC volts and measure on the same points. Use the lowest scale or 20 volts. Now crank the engine. The sensor will generate AC volts. If it is Pluto2 or Saturn you are using, a voltage of more than 1 Volt is required for operation. Mercury2 requires a voltage above 0.5 volt and above. If this voltage is lower, it means the signal is too weak and the ECU will not sense it properly. This could be due to a dirty sensor or the gap is too wide between the sensor and the gear. The gap is normally below 1 mm. It could also be that the sensor magnet inside the sensor is wider than the width in the teeth if it's a custom installation.

Errors and misfire during running or starting.

If the startup procedure tested correctly but you get errors during starting the engine, read through the following points.

1. The ignitions' coils may generate interference spikes on the crank sensor wires. Ensure that the sensor wire is screened as close to the sensor as possible. If you connect to a distant connector there is usually a screen pin that has to be connected to the ECU harness screen.

2. The coils may spike the ECU and it may want to restart. This may be to incorrect supply currents or relay wiring. An indication of this error is that the software will lose connection momentarily to the ECU. A restart error wil come up.

3. Errors that comes at higher RPM's may be due to a trigger wheel that is not balanced or is buckled. Sensing distance may be too large. It could also be due to a small gear teeth pitch, or a sensor with a large sensing magnet. The 2-pin jumper is on and it should be off.

4. Ensure that the test signal next to the crank sensor is off.

5. The RPM on the sensor signal could fade, this could be due to the gap between it and the trigger wheel been too close or too far apart.

6. Incorrect sparkplugs may generate feedback which leave spikes in the trigger signal. Normally resistor plugs are used for COP engines and non-resistor plugs for HT leads. Note: Ensure that you use carbon HT leads and not copper leads. Cracked lead also play havoc. A trick is to look at them in the dark while it idles. It will show flashes in the dark.

Related Links

Software Setup

Jumper Settings

Power Connection

Error Codes


Testing Hall Crank Triggers

Help > ECU Hardware Description > Engine Sensor and Inputs > Crank and Cam angle sensors >

Testing Hall Crank Triggers

Work through each point below to find your problem.

1. First ensure that the setup in Hyperspace is done according to the startup procedure. This means you will only have a P1 connector, and on Mercury2 also a P4 connector. The other connectors must be open, except for the comms cable. Open the software and connect to the ECU.

2. Ensure that the correct firmware is loaded into the ECU for the specific trigger pattern of your engine. You can click on information button [image] to verify.

3. Make sure the Jumper settings are set for Hall sensors. On Pluto2 and Saturn it must be set to 12-volt position and the 2 pin jumper must be closed. On Mercury2 the 2-pin jumper must be closed. You may now crank the engine without the other connectors.

4. Ensure that battery volts on the Real-time Volt Bar [image] does not fall too low. A healthy battery will crank at 11 volts and higher. Under 9 volts, the sensor signal becomes weak and falls below the voltage threshold of the specific ECU. Note: If it falls below 10 see chapter about 'Power Connection'.

5. Look if any error codes are displayed at the bottom. If there are errors remedy the fault. See Error codes.

6. Look at the RPM signal in the Real-time Display while cranking. It should show 200 to 300 rpm consistently. If it shows erratic readings and runs wild do not proceed to start! It must be constant. It means the edge setting is wrong or incorrect firmware or there is interference on the trigger signal and the ECU sees them as trigger pulses.

7. If it shows no error and no RPM it means that the ECU does not pick up the signal from the crank sensor. Proceed to testing the crank sensor itself.

8. Make sure you use the correct sensor size with your crank trigger wheel size. If the magnet of the sensor is larger than the gap in the teeth, then your signal will be very week. Rather use a gear with less teeth for the diameter or a sensor with a smaller sensing diameter. If you can't see the magnet protruding from the sensor, put a bit of iron filings on the tip. The magnetic field will show the diameter of the internal magnet immediately. In this case you may enlarge the sensing distance it the signal is strong enough. See the illustration below.

Testing the sensor.

1. The hall or optic sensor requires power to operate. So it cannot be dry tested like a magnetic sensor.

2. First measure continuity from the ECU ground to the sensor ground. There should be 0 ohms as the earth comes from the thin black wire coming from the harness to the thick black earth of the ECU.

3. Measure continuity from the sensor power to the ECU ignition power that comes from the key. There should be 0 ohms.

4. Now measure continuity from the sensor signal to the ECU input for that sensor, see the drawing. You can disconnect P1 and measure on the pin.

5. The fastest way to test it is while it is powered in the circuit. While P1 is connected switch the ignition on.

6. Measure at the power at the sensor between negative and positive. You should measure around 12V DC.

7. Now unbolt the sensor from the engine. Measure DC volts between sensor negative and signal. It should be 12 volt and if you bring a metal object to the sensor it should go to 0 volt. The logic may be reversed for some sensors. As long as you see the step change. On optic or some hall sensors you may need to move a plate between the sensor and transmitter part. If the voltage doesn't go to less than 1 volts, then it means the ECU will not detect the change.

8. If you don't measure the 12 volt on any condition on the sensor signal, it may be the pull-up jumper is not in closed position. If it is then disconnecting the sensor signal wire and measure at the ECU side for the 12 volt. If you measure 12 volt, it means the sensor output is damaged and short the signal wire to ground. If you don't measure 12 volt then the ECU does not provide power through the pull-up resistor.

9. Now bolt the sensor in place and measure on the signal negative and positive with AC volts. Crank the engine and you should see 12 volts AC.

Errors and misfire during running or starting.

If the startup procedure tested correctly but you get errors during starting the engine, read through the following points.

1. The ignitions' coils may generate interference spikes on the crank sensor wires. Ensure that the sensor wire is screened as close to the sensor as possible. If you connect to a distant connector there is usually a screen pin that has to be connected to the ECU harness screen.

2. The coils may spike the ECU and it may want to restart. This may be to incorrect supply currents or relay wiring. An indication of this error is that the software will lose connection momentarily to the ECU. A restart error will come up.

3. Errors that comes at higher RPM's may be due to a trigger wheel that is not balanced or is buckled. Sensing distance may be too large. It could also be due to a small gear teeth pitch, or a sensor with a large sensing magnet. The sensor may require an extra pull-up resistor.

4. Ensure that the test signal next to the crank sensor is off.

5. The RPM on the sensor signal could fade, this could be due to the gap between it and the trigger wheel been too close or too far apart.

6. Incorrect sparkplugs may generate feedback which leave spikes in the trigger signal. Normally resistor plugs are used for COP engines and non-resistor plugs for HT leads. Note: Ensure that you use carbon HT leads and not copper leads. Cracked lead also generates interference. A trick is to look at them in the dark while it idles. It will show flashes in the dark.

Mercury2 pull-up

The Mercury2 use an isolated digital input to allow for magnetic sensor tap-in. For hall sensors an external jumper will connect a 1K pull-up resistor internally to the 12 volt power from the key. If this power is erratic due to other switching elements, then it may cause secondary triggering or interference of the input. To remedy this, you may add a 1K pull-down resistor to minimize the rippling effect on the power. If this does not help you may open the jumper and add a 1K pull-up resistor to 5 volt power from the ECU P1 pin 9. See the drawings below.

Related Links

Software Setup

Jumper Settings

Power Connection

Error Codes


Jumper Settings

Help > ECU Hardware Description > Engine Sensor and Inputs > Crank and Cam angle sensors >

ECU Jumper Settings

The Spitronics ECU's are universal products that cater for all kinds of sensors and features. Therefore, it has Jumper switched that will expand the universality of these products. Most jumper settings are around the crank and cam angle sensors to select between hall or magnetic sensors. Pluto2 and Saturn also has the option to select between the Firmware Programmer and the Dual Map and Tuning Pot inputs. Mercury is a sealed unit with only the option of 2 pull-up jumpers for hall sensors.

Click on the links below for the different products.

Mercury2 Jumper Settings

Pluto2 Jumper Settings

Saturn Jumper Settings


Rotor Phasing

Help > ECU Hardware Description > Engine Sensor and Inputs > Crank and Cam angle sensors >

Setting Distributor Rotor Fazing

This setup for distributors with rotors requires you to align the rotor with actual crank degrees. Rotor fazing is a mechanical adjustment to ensure that the Rotor is under the relevant high tension pole during the spark distribution. If not, the spark will have to jump the gap in the distributor which will cause less energy at the spark plug. It will also generate interference on the sensors causing erratic misfires. As most cars operate between 14 and 36 °BTDC you must ensure that the Rotor is under the pole during this span. Put the engine on 25°BTDC and place the rotor under the center of the pole. Then it can advance a total of 11 degrees, up to 36° or retard a total of 11 degrees, down to 14° and still have contact between rotor and pole. Lock the distributor nut properly and ensure that wiring is tied in the correct manner to prevent damage or strain due to engine movement.

NB! Do not adjust the distributor again. Rotor fazing is now complete.

(See Illustration below.)

Related Links

Software Setup


Cam Angle 24T + Home

Help > ECU Hardware Description > Engine Sensor and Inputs > Crank and Cam angle sensors >

Cam Angle 24T + Home

The popular 24+TDC configuration from the Toyota, Mazda Rotary, Honda etc. engines can be used in many different ways. The 24 tooth gear gives a pulse every 30 degrees of crank rotation. Some distributor encoders use a combination of TDC and Home triggers with this gear. Below are explanations of the different types and also the modifications that could improve stability and simplicity in wiring when using the Spitronics ECU's.

Toyota usually have one tooth on a separate space in combination with two sensors. Each sensor provides a home pulse on a different revolution of the engine. This allows the ECU to sink injection and timing to a specific stroke of the engine every time it starts. This setup requires three inputs from the ECU. The ECU could sync in one revolution. Pluto2 and Saturn have only one home input which means then engine may have to turn sometimes two revolutions before crank angle can be established. Mercury2 have four digital inputs but also use the two input programs.

Using the sensors without modifications is possible but due to the differences in sensor that the Spitronics ECU's have to cater for, this one needs a bit of external filtering. See the drawing below.

The Reference wire is usually common in these encoders. The older ones used these colours and white is common. Then Crank and Home are connected to P1 pin 12 and 11 respectively. Check the drawings for wire colours. Usually we use only Home1 sensor. You may add the Home2 sensor on the same connection as shown in optional jumper settings. If the sensor signal is strong this will work perfectly. If it is week then it cannot be used. This method is only for Split sequential injection. For full sequential only use Home1 sensor. If you find interference during cranking or at higher revs add the optional resistor A to the circuit. Resistor B is seldom required due to constant excitement of the crank sensor. If it is possible, move the sensors closer to the tooth gears but they must not touch. Ensure a paper can move between them easy. It they touch it will make more interference.

These 24 tooth trigger wheels can be modified and used with different firmware if it is available for that product. Make sure about this before you proceed. This means that the home sensors are not required. The interference with the 24 tooth gear is very little as the sensor is constantly exited by the many teeth. If you are going to fuel the engine with Split-sequential injection you may grind out two opposing teeth on TDC and BDC. This will then convert to the 12-1 programs which is available. NB. Engine must be on TDC in the drawing below. Note that the Home pulses on the Toyota CAS units have a gradual build-up of metal in front of the sensor as it turns. This is to prevent interference on the sensor due to no excitement. The Mercury2 style input cannot sense this configuration successfully so you may need to modify the sensor as described below.

If you want to do full sequential then only take 1 tooth out under the sensor when the engine is on TDC. The firmware for this gear is Program 84 24-1 Dizzy 4Cyl Full/Seq. It is not popular and may be supplied on request. See the drawing below.

Mazda Rotary engines are 2 stroke and don't require a home pulse. They opted for the pattern below.

Using the sensors without modifications is possible but due to the differences in sensor that the Spitronics ECU's have to cater for, this one needs a bit of external filtering. See the drawing below.

The older ones used these colours. Then Crank and Home are connected to P1 pin 12 and 11 respectively. Check the drawings for wire colours. If you find interference during cranking or at higher revs add the optional resistor A to the circuit. Resistor B is seldom required due to constant excitement of the crank sensor. If it is possible, move the sensors closer to the tooth gears but they must not touch. Ensure a paper can move between them easy. It they touch it will make more interference.

Honda use a 3 level crank angle sensor like below. The 4-point wheel is handy to start quickly because spark does not need to be synced to the stroke of the engine due to the distributor cap that does the syncing. Pluto2 and Saturn have only one home input which means then engine may have to turn sometimes two revolutions before crank angle can be established. Mercury2 have four digital inputs but most of the 24+TDC programs use only two like the Pluto2 and Saturn. Spitronics only use the crank 30° and the Home 720° sensors.

Using the sensors without modifications is possible but due to the differences in sensor that the Spitronics ECU's have to cater for, this one needs a bit of external filtering. See the drawing below.

The older ones used these colours. Then Crank and Home are connected to P1 pin 12 and 11 respectively. Check the drawings for wire colours. If you find interference during cranking or at higher revs add the optional resistor A to the circuit. Resistor B is seldom required due to constant excitement of the crank sensor. If it is possible, move the sensors closer to the tooth gears but they must not touch. Ensure a paper can move between them easy. It they touch it will make more interference.

These 24 tooth trigger wheels can be modified and used with different firmware if it is available for that product. Make sure about this before you proceed. This means that the home sensors are not required. The interference with the 24 tooth gear is very little as the sensor is constantly exited by the many teeth. If you are going to fuel the engine with Split-sequential injection you may grind out two opposing teeth on TDC and BDC. This will then convert to the 12-1 programs which is available. NB. Engine must be on TDC in the drawing below.

If you want to do full sequential then only take 1 tooth out under the sensor when the engine is on TDC. The firmware for this gear is Program 84 24-1 Dizzy 4Cyl Full/Seq. It is not popular and may be supplied on request. See the drawing below.


Crank Angle 12T + 2Home

Help > ECU Hardware Description > Engine Sensor and Inputs > Crank and Cam angle sensors >

Crank Angle 12T + 2Home

The 12+2home configuration has the same signal pattern as the old 24+TDC configuration from the Toyota. Here there is no CAS but only sensors on the crank and cam directly. The 12 tooth gear gives a pulse every 30 degrees of crank rotation. There are 2 separate Home sensors. Usually one on each cam and they are 360° out of phase. Sometimes they also act as VVTI movement detection sensor. This allows the ECU to sink injection and timing to a specific stroke of the engine every time it starts. This setup requires three inputs from the ECU. The ECU could sync in one revolution. Pluto2 and Saturn have only one home input which means then engine may have to turn sometimes two revolutions before crank angle can be established. Mercury2 have four digital inputs but also use the two input programs. Below are explanations and also the modifications that could improve stability and simplicity in wiring when using the Spitronics ECU's.

Using the sensors without modifications is possible but due to the differences in sensors that the Spitronics ECU's have to cater for, this one needs a bit of external filtering. If your harness has all the wires in one cable, then you need to make an adapter cable from the crank or cam sensor to the other one. They may be far apart so the connecting lead must be screened and the screen wire must be connect to the screen wire of the original loom. Do not connect the screen to the engine. See the drawing below.

Then Crank and Home are connected to P1 pin 12 and 11 respectively. Check the drawings for wire colours. Usually we use only Home1 sensor. You may add the Home2 sensor in parallel to the Home1 sensor. Positives together and reference together. If the sensor signal is strong this will work perfectly. If it is week then it cannot be used. This method is only for Split sequential injection. For full sequential only use Home1 sensor. If you find interference during cranking or at higher revs add the optional resistor A to the circuit. Resistor B is seldom required due to constant excitement of the crank sensor. If it is possible you may grind the teeth under the sensor out when the engine is on TDC and use this with the 12-1 split sequential program. Then you don't need the cam sensors.


Optic CAS Cam Anfle Sensor

Help > ECU Hardware Description > Engine Sensor and Inputs > Crank and Cam angle sensors >

Optic CAS Cam Angle Sensor

This chapter discuss the connection and settings for the Optical CAS. For fault finding and testing see the Testing Magnetic Crank sensor chapter in this manual.

1. First ensure that the setup in Hyperspace is done according to the startup procedure. This means you will only have a P1 connector, and on Mercury2 also a P4 connector. The other connectors must be open, except for the comms cable. Open the software and connect to the ECU.

2. On the CAS there is a 360 slot output and a home or TDC slot output. The Spitronics ECU's only use the Home slots. Connect it to the crank sensor input. These sensors the Crank is forced to rising edge and the Cam is disabled. In older software use the same settings. Gear Teeth is locked on 1 and Timing Sensor is usually between 60 and 65 degrees BTDC. Make sure the CAS is in its original mounting position where the bolt slides in the slotted groove. See the illustrations below:

3.

4. Ensure that the correct firmware is loaded into the ECU for the specific trigger pattern of your engine. You can click on information button [image] to verify.

5. Make sure the Jumper settings are set for Hall sensors. On Pluto2 and Saturn the crank sensor jumper must be set to 12-volt position and the 2 pin jumper must be closed. On Mercury2 the 2-pin jumper of the crank sensor must be closed. The cam sensor input is not used. Leave the jumpers open. You may now crank the engine without the other connectors.

6. Ensure that battery volts on the Real-time Volt Bar [image] does not fall too low. A healthy battery will crank at 11 volts and higher. Under 9 volts, the sensor signal becomes weak and falls below the voltage threshold of the specific ECU. Note: If it falls below 10 see chapter about 'Power Connection'.

7. Look if any error codes are displayed at the bottom. If there are errors remedy the fault. See Error codes. If it is a Mercury2 ECU, then see also the drawings below the document on slight modifications to improve sensor quality.

8. Look at the RPM signal in the Real-time Display while cranking. It should show 200 to 300 rpm consistently. If it shows erratic readings and runs wild do not proceed to start! It must be constant. It means the edge setting is wrong or incorrect firmware or there is interference on the trigger signal and the ECU sees them as trigger pulses.

9. If it shows no error and no RPM it means that the ECU does not pick up the signal from the crank sensor. Proceed to testing the crank sensor itself.

Testing the sensor.

1. The optic sensor requires power to operate. So it cannot be dry tested like a magnetic sensor.

2. First measure continuity from the ECU ground to the sensor ground. There should be 0 ohms as the earth comes from the thin black wire coming from the harness to the thick black earth of the ECU.

3. Measure continuity from the sensor power to the ECU ignition power that comes from the key. There should be 0 ohms.

4. Now measure continuity from the sensor signal to the ECU input for that sensor, see the drawing. You can disconnect P1 and measure on the pin.

5. The fastest way to test it is while it is powered in the circuit. While P1 is connected switch the ignition on.

6. Measure at the power at the sensor between negative and positive. You should measure around 12V DC.

7. Now unbolt the CAS from the engine. Make a proper mark so you can install it in the exact position. Measure DC volts between sensor negative and signal. It should be 12 volt and if you turn the shaft slowly it should go to 0 volt. If the voltage doesn't go to less than 1 volts, then it means the ECU will not detect the change.

8. If you don't measure the 12 volt on any condition on the sensor signal, it may be the pull-up jumper is not in closed position. If the jumpers are correct, then disconnect the sensor signal wire and measure at the ECU side for the 12 volt. If you measure 12 volt, it means the sensor output is damaged and short the signal wire to ground. If you don't measure 12 volt then the ECU does not provide power through the pull-up resistor.

10. Now bolt the sensor in place and measure on the signal negative and positive with AC volts. Crank the engine and you should see 12 volts AC.

Errors and misfire during running or starting.

If the startup procedure tested correctly but you get errors during starting the engine, read through the following points.

1. The ignitions' coils may generate interference spikes on the crank sensor wires. Ensure that the sensor wire is screened as close to the sensor as possible. If you connect to a distant connector there is usually a screen pin that has to be connected to the ECU harness screen.

2. The coils may spike the ECU and it may want to restart. This may be to incorrect supply currents or relay wiring. An indication of this error is that the software will lose connection momentarily to the ECU. A restart error will come up.

3. Errors that comes at higher RPM's may be due to a weak pull-up signal. The sensor may require an extra pull-up resistor between the sensor signal and the sensor positive. Use a 1K resistor.

4. Ensure that the test signal next to the crank sensor is off.

5. Incorrect sparkplugs may generate feedback which leave spikes in the trigger signal. Normally resistor plugs are used for COP engines and non-resistor plugs for HT leads. Note: Ensure that you use carbon HT leads and not copper leads. Cracked leads also make interference. A trick is to look at them in the dark while it idles. It will show flashes in the dark.

Mercury2 pull-up

The Mercury2 use an isolated digital input to allow for magnetic sensor tap-in. For hall sensors an external jumper will connect a 1K pull-up resistor internally to the 12 volt power from the key. If this power is erratic due to other switching elements, then it may cause secondary triggering or interference of the input. To remedy this, you may add a 1K pull-down resistor to minimize the rippling effect on the power. If this does not help you may open the jumper and add a 1K pull-up resistor to 5 volt power from the ECU P1 pin 9. See the drawings below.

Related Links

Software Setup

Jumper Settings

Power Connection

Error Codes


Water Temperature

Help > ECU Hardware Description > Engine Sensor and Inputs >

Water Temperature Sensors

The water temperature sensor is mostly used by the ECU for cold-start and run enrichment, engine over temperature limit and thermostatic radiator fan control. They come in different shapes and resistance values.

Operation
The resistance of the temperature sensor changes in relation to the temperature it senses. It has a negative temperature resistance co-efficiency (NTC). Each sensor has a preprogrammed curve to indicate its resistance to temperature. Note: The Spitronics ECU uses a 2K resistance NTC and this value is measured at 25°c. (See below a sample of such a curve.)

Image result for NTC sensor graph

Electronics sensors

Spitronics build and supply small sensors for customers to build into their own units. There are 2 sizes but it does the same work. Note: These sensors require a pull-up resistor to let a constant current through them. (See below a picture of what these sensors look like in their raw form.)

How to measure a sensor
Use a multi-meter set to the 10,000 ohm (10 K) range. With the sender unit at approximately 25°c, measure the resistance. It should be between 1800ohm and 2200ohm at 25°c. Those two pins will be used for the ECU. The remaining two pins are normally used for the dash cluster and measure in the region of 3500ohm at 25°c. This same test can be done on engines with multiple sender units to determine which sender unit will be used for the ECU. Example: Toyota 1uz-fe, where there is three water temperature sender units.

Multiple Devices on One Sender Unit.
Do not share temperature sender units between two devices. Only one device may be coupled onto a sender unit at any one time. Both devices will excite the sensor with current which in turn will change the signal value and then both will display the wrong temperature. In such a case you may need to add an extra sensor for the Spitronics ECU. The only exception for this rule is when a data logging device is used that has no internal pull up resistor. Example: Race Technology DL1.

Sensor Location.
The ideal location for the temperature sender unit is on the engine side of the thermostat as this side will show the exact temperature at all times. The radiator side of the thermostat will show lower temperatures and take longer to react.

Air Cooled Engines
For air cooled engines it is better to measure cylinder head temperature for cold start compensation as the oil takes too long to pick up temperature. A simple cylinder head temperature sender unit can be made by clamping an NTC 2k ohm thermistor on a lug terminal and bolting it onto the cylinder head.

Related Links

Software Setup


Air Temperature

Help > ECU Hardware Description > Engine Sensor and Inputs >

Air Temperature Sensor

The air temperature sensor is used by the ECU to correct air density changes due to air temperature variation. This input can also be used for general purpose output controls like Intercooler fans or water spray pumps.

Operation
The resistance of the temperature sensor changes in relation to the temperature it senses. It has a negative temperature resistance co-efficiency, ( NTC). Each sensor has a preprogrammed curve to indicate its resistance to temperature. Note that the Spitronics ECU uses a 10K resistance NTC and this value is measured at 25°c .(See below for a sample of such a curve.)

Electronics sensors

Spitronics build and supply small sensors for customers to build into their own units. There are 2 sizes, both do the same work. Note: These sensors requires a pull-up resistor to enable a constant current through them. (See below a picture of what these sensors look like in their raw form.)

How to measure a sensor
Use a multi-meter set to the 20,000 ohm (20 K) range. With the sender unit at approximately 25°c, measure the resistance. It should be between 8000ohm and 12000ohm at 25°c.

Multiple Devices on One Sender Unit.
Do not share temperature sender units between two devices. Only one device may be coupled onto a sender unit at any one time. Both devices will excite the sensor with current which in turn will change the signal value and then both will display the wrong temperature. In such a case you may need to add an extra sensor for the Spitronics ECU. The only exception for this rule is when a data logging device is used that has no internal pull up resistor. Example: Race Technology DL1.

Sensor Location
The ideal sensor location is before the butterfly and after the intercooler if turbo charged. Mount away from fuel "stand-off" to avoid the sensor being cooled by the fuel vapor. Use a High Speed Air Temp sensor on turbo applications where the intercooler comes out as temperature varies quickly.

Related Links

Software Setup


MAP Sensor

Help > ECU Hardware Description > Engine Sensor and Inputs >

MAP Sensor

The Mean Absolute Pressure (MAP) sensor provides instantaneous manifold pressure information to the ECU. The data is used to calculate air density and determine the amount fuel required for optimum combustion. This sensor influences also the advancement or retardation of ignition timing. This sensor is a reliable replacement for the Mass meter type sensors.

This Aluminum model comes in 1.1 Bar, 2.5 Bar, 3 Bar and 4 Bar versions.

Operation
The Pressure Sensor requires 5 volts DC which is supplied to the sensor by the ECU. It then generates a signal from 0 to 5 volt equivalent to the pressure range of the sensor.

Sensor Location
The manifold take off point should be at a position that best represents the average manifold pressure with minimum pulsations. A filter can be fitted inline to reduce manifold pressure pulsations. Do not T-off idle or brake booster fittings etc. The take-off pipe must be direct to the manifold. When mounting the MAP sensor, face the intake port down and mount it above the take-off point. This will prevent moisture to build up so it can drain out. Ensure that the hose runs downhill all the way to the manifold if possible.

MAP sensor types
The MAP sensors available from Spitronics is the Motorola series sensors that come in two packaged styles; Sealed plastic enclosure or Aluminum machined enclosure. The MAP sensors are rated at 1.1 bar, 2.5 bar, 3 bar and 4 bar respectively. Be sure to order the correct map sensor for your application. In some cases, the vehicle's existing MAP sensor can be used, ensure that you have the sensor wired and calibrated correctly.

Map Sensor Calibration
The MAP sensor is pre calibrated to the specifications of the 4 models. If you use another map sensor you may select custom and calibrate it yourself. Make sure you use the correct altitude pressure value from your altitude level in order for this to function correctly. Calibration needs to be done with the ECU switched on, but the engine must not be running.

Sample Sensor Pinouts

Related Links

Software Setup


TPS Sensor

Help > ECU Hardware Description > Engine Sensor and Inputs >

TPS Sensor

The throttle position sensor is used by the ECU to determine what the driver's intent is. It is also a representation of the load that will be required by the engine. This input is critical for idle control operation, accelerator pump operation etc. in some cases it can be used as fuel calculation parameter with RPM.

Operation:
The TPS is a variable resistor normally around 5K ohms. The signal voltage varies as the wiper moves. It is connected to 5 volts from the ECU and then the wiper signal will produce a voltage between 0 and 5 volts, proportional to the angle of the throttle plate. New generation sensors is hall effect sensors that does not have moving parts that make contact with each other.

Which Pin is which?

Use a multi-meter set to the 20,000 ohm (20 K) range.

· With throttle closed, find the two pins with the lowest resistance between them. They are C & B. The remaining pin is the 5 V pin A.

· With one probe on the 5 V pin A, find the pin whose resistance changes when the throttle moves. This is the Signal pin B.

· The remaining pin is the earth pin C.

This same route can be used on a four pin throttle position sensor, note that only three of the four pins will be connected or one pin may be a switch to ground or 5 Volt as an idle activation switch. The Spitronics ECU does not require this pin.

Pre-load the Sensor
The sensor has a dead band at either end so it must be rotated slightly to move the wiper into the operating range of the sensor.

Life Time
Vibration can cause high wear. Avoid high pressure washing on the sensor.

TPS Sample Pin outs:

Related Links

Software Setup


Lambda

Help > ECU Hardware Description > Engine Sensor and Inputs >

Lambda Sensor

The Lambda Sensor or Oxygen Sensor is used by the ECU to display Air Fuel Ratios AFR and optimize the fuel economy after the vehicle has been tuned. Note: In the ECU software it shows a voltage signal and not the actual AFR value. The reason is that the ECU is not a tuning tool with calibration software. It is merely using the sensor for control purposes which is tuned to the correct mixture.

Different Lambda sensors
1 to 4 wire sensors are normally narrow band sensors. Their signal could be used directly in the ECU as it is a 0.1 volt to 0.9-volt signal. The 5 and 6 wire sensors require driving electronics and give a 0 to 5-volt signal out for the ECU. This wideband signal could be used by the ECU.

Testing a Lambda sensor for the correct Pin-outs
Test the resistance with an Ohm Meter between two pins at a time. The heater element normally has the same colors and has a resistance of 6 to 12 ohm. Connect the element wires to earth and 12 volts as above. The element does not have a specific polarity. The sensor output can only be measured while the engine is running. Connect the two remaining wires to the ECU signal input wires as indicated on the drawing. The sensor will only give an output when the engine has achieved some temperature. If the sensor is not working, swop the signal and earth wires and test again. The sensor will not be damaged if the earth and signal output has been swopped.

Life expectancy.
The life expectancy of a lambda sensor varies due to fuel type and application. On unleaded fuel around 500 hours. Very rich mixtures will shorten sensor life. Lambda sensors can be damaged by gasket sealants, anti-seize and some fuel additives.

Position
The ideal position for mounting the lambda sensor is at least half a meter from the engine and after the exhaust collector or turbo down pipe. The lambda should be orientated on the top or side of the pipe. Never at the bottom!

Sample Sensor Pin outs

Related Links

Software Setup


Tuning POT

Help > ECU Hardware Description > Engine Sensor and Inputs >

Tuning POT

The multi-function variable resistance potentiometer can be configured in the software to perform numerous features. These features include making changes to the fueling, ignition angle or adjusting the launch RPM without having to connect a laptop computer.

Operation
The POT is a variable resistor normally around 5K ohms. The signal voltage varies as the wiper moves. It is connected to 5 volts from the ECU and then the wiper signal will produce a voltage between 0 and 5 volts, proportional to the angle of the throttle plate.

Sample sensor Pin out

Related Links

Software Setup


Fuel Pressure Sensor

Help > ECU Hardware Description > Fuel Supply >

Fuel Pressure Sensor

The fuel pressure sensor relays the fuel pressure back to the ECU to control the fuel pump with PWM and keep a constant pressure over the injectors. This is important for the ECU to supply an accurate amount of fuel per engine stroke. The ECU can vary the speed of the fuel pump to increase or decrease fuel pressure accordingly. The sensor gives a continual feedback of fuel rail pressure so that the ECU can make pressure adjustments almost instantaneously. This setup allows the engine to run without a manual fuel pressure regulator or return line. The 4 Bar Map sensor, 5.5 Bar DP sensor, or 7 Bar Map sensor can be used as a fuel pressure sensor. The setting differs for each of them and is discussed in the software.

Operation
The Pressure Sensor requires 5 volts DC which is supplied to sensor by the ECU. It then generates a signal from 0 to 5 volt equivalent to the pressure range of the sensor.

Sensor Location
The fuel pressure sensor must be mounted inside the engine bay. The pressure input pipe must be securely connected to the high pressure fuel line with a T piece. The sensor must be mounted higher than the fuel line with the pressure nipple facing downwards. This will produce an air bubble between the sensor and the fuel to prevent damage. The fuel does not actually contact the sensor element and the bubble acts as a damper to the pulsing fuel. The other pipe of the DP sensor must be connected to the intake manifold. It could be joined with the MAP sensor line if the takeoff pipe has a large enough hole to prevent delays in the signal.

Pressure sensor types
The fuel pressure sensor available from Spitronics is the Motorola series sensor

The fuel pressure sensor is rated at 5.5 bar differential pressure (DP) and the aluminum one is 4 or 7 Bar MAP.

Sample Sensor Pinout and layout

Related Links

Software


Altitude Pressure

Help > ECU Hardware Description > Engine Sensor and Inputs >

Altitude Sensor

The altitude pressure sensor provides instantaneous altitude pressure information to the Mercury2 ECU. It uses an external 1.1 bar map sensor. Pluto2 and Saturn has an optional built in 3 bar sensor on the electronic board. You may swop the map and altitude sensors but then the external sensor must be a 1.1 Bar like Mercury2. The data is used to calculate air density, which in turn determines the required fuel compensation for optimum combustion. It influences also the advancement or retardation of ignition timing as the altitude changes.

Operation
The Pressure Sensor requires 5 volts DC which is supplied to the sensor by the ECU. It then generates a signal from 0 to 5 volt equivalent to the pressure range of the sensor.

Sensor Location
The altitude pressure sensor can be mounted inside the cabin and the pipe should be left open to ambient pressure. It could also be connected to the air intake box.

Pressure sensor types
The pressure sensor available from Spitronics is Motorola series sensors that comes in 1.1 Bar calibration.

Sample Sensor Pinouts

Related Links

Software Setup


Launch Control

Help > ECU Hardware Description > Engine Sensor and Inputs >

Launch Control

The launch control input is an analogue input that combines a digital switch with a resistor to make a dual function input. It is used for Launch, Anti-Lag and Retard functions. There are different ways to activate launch but most methods use the switch on the dashboard. Same cases a push button is used and other an on/off switch. This function is mainly used on racing applications to keep the engine RPM at the desired RPM before taking off. It also helps to spin the turbo before taking off or during cornering. This increases boost pressure at startup.

The clutch switch is a whisker switch that will deactivate launch the moment the clutch pedal is released.

The connections for Mercury2, Pluto2 and Saturn differs. (See sub folders for connection options.)

Related Links

Software Setup


Mercury2

Help > ECU Hardware Description > Engine Sensor and Inputs > Launch Control >

Mercury2 Launch Control Wiring

The input for the launch button is situated with the 6 Pin Molex connecter pin 5.

Option 1

Dashboard Launch will only be activated as long as the button is pressed.

Option 2

Dashboard pushbutton with resistor and clutch pedal switch. This method will latch the launch action and deactivate it the moment the clutch pedal is released. This method is more automatic and lets the driver focus on other things.

Option 3

Dashboard on/off switch is used for the TPS 90% method. When switched on, this method will activate Launch up to 90% TPS value, and cancel it above 90% TPS value. Revs must fall below 3000 RPM to re-activate the launch feature.

Option 4

Use the tuning POT with TPS 90% to make an adjustable Launch RPM for different traction. To disable this function turn it clockwise so that launch RPM is very high.

Related Links

Software Setup


Pluto2 & Saturn

Help > ECU Hardware Description > Engine Sensor and Inputs > Launch Control >

Pluto2 Saturn Launch Control Wiring

The input for the launch button is situated with the 9 Pin D-Sub connector pin 8.

Option 1

Dashboard launch will only be activated as long as the button is pressed.

Option 2

Dashboard pushbutton with resistor and clutch pedal switch. This method will latch the launch action and deactivate it the moment the clutch pedal is released. This method is more automatic and will let the driver focus on other things.

Option 3

Dashboard on/off switch is used for the TPS 90% method. When switched on, this method will activate Launch up to 90% TPS value, and cancel it above 90% TPS value. Revs must fall below 3000 RPM to re-activate the launch feature.

Option 4

Use the tuning POT with TPS 90% to make an adjustable Launch RPM for different traction. To disable this function turn it clockwise so that launch RPM is very high.

Tuning Adapter

You can make an adapter for using the Launch while you have the tuning software connected.

Related Links

Software Setup


Dual Map Switch

Help > ECU Hardware Description > Engine Sensor and Inputs >

Dual MAP Switch

The Dual MAP selection switch is a normal on/off switch that is connected to the ECU. When it is on it will connect the input to earth, this indicates to the ECU which map is required. Note: The ECU only tests this switch at startup and not on the fly. The reason is that all the maps have to be uploaded from flash memory and then new settings must be implemented. So the ECU must be switched off and on again to change to the alternate map.

(See the sub folders for connection options.)


Mercury2

Help > ECU Hardware Description > Engine Sensor and Inputs > Dual Map Switch >

Mercury2 Dual MAP Switch

The Mercury2 ECU does not have a dedicated input for the Dual MAP selection switch. It can be selected on one of three inputs if any of them have not been used by the tuner. The inputs are Cam 2, fuel pressure sensor input and altitude sensor input. Cam2 does not always function correctly due to the capacitor isolator. Try and keep the wire to the switch as short as possible. The dashboard on/off switch selects which map will be used. If not connected it will default to Map 1 at startup. If the switch is on, it will be Map 2.

Altitude Sensor

The 6-way connector pin 2 which is the altitude input. Open is map 1 and close is map 2. This is the preferred sensor to use.

Fuel Pressure Sensor

The 6-way connector pin 4 which is the fuel pressure input. Note that here a 1 K pull-up resistor is required to 5 volts. Do not connect it to 12 volts. It will damage the ECU. Open is map 1 and close is map 2.

Cam 2 input

The 12-way connector pin 5 which is the cam 2 sensor input. Open is map 1 and close. It may require a 2K pull-up to the ignition power of the ECU.

Related Links

Software


Pluto2 & Saturn

Help > ECU Hardware Description > Engine Sensor and Inputs > Dual Map Switch >

Pluto2 Saturn Dual MAP Switch

The input for the Dual MAP selection switch is situated on the 6 Pin Molex Comms connecter pin 1. You can make an adapter for this dual MAP switch if you have the tuning software connected. Spitronics also supply these cables pre-made.

Selection Switch

Dashboard on/off will select which map will be used. If not connected it will default to Map 1 at startup. If the switch is on it will be Map 2.

Tuning adapter

The tuning adapter cable will let you use a switch while tuning. If you do not have this cable start the ECU on Map 2 and then connect the comms cable.

Related Links

Software


Driver Outputs

Help > ECU Hardware Description >

Driver Outputs

The Spitronics ECU's were designed to control the hardware found on most engines without modification to them. This will ease installation and lower costs. These are items like coils, injectors, idle controls, fans, fuel pumps etc.

(See the sub folders for explanation on each different type.)


Fuel Injectors

Help > ECU Hardware Description > Driver Outputs >

Fuel Injectors

The fuel injector outputs drive the fuel injectors to allow measured amounts of fuel into the engine. These signals are on/off control signals that are varied by duty cycle. The more fuel is required the higher the duty cycle will be. The injectors are connected to common positive and the drive signals from the ECU is ground signals.

Operation
The injectors are solenoid valves that are opened by current to let fuel pass through the nozzle. The nozzle has a spray pattern that will help in atomizing the fuel with air. This in turn will make a combustible mixture.

Injection types

Batch Injection

With this method, injector drivers are being pulsed at the same time once or twice per revolution. Very rare firmware from Spitronics, although not preferred, can use this method. However, fuel metering and timing is done very accurately and should still give excellent results. Split the injectors in groups to divide the current evenly between the available driver outputs. For bigger engines keep the mean supply current below the current capability of the drivers of that product. (See specifications.) Note: More outputs are available in the intermediate and advance units. (See specific wiring diagram.) The biggest disadvantage with this method is the fuel pressure pulses due to uneven tapping. Advantage is easy wiring.

Split Batch Injection

With this method, two injector drivers are being pulsed 180° out of faze. Although not preferred, fuel metering and timing is done very accurately and should give excellent results. Split the injectors in two groups to divide the current on the 2 driver outputs. Put alternate numbers on the firing order together to ensure a more even fuel distribution. For bigger engines keep the mean supply current below the current capability of the drivers of that product. Note: More outputs are available in the intermediate and advance units. (See specific wiring diagram.)

Split Sequential Injection

This method will inject on the two cylinders that move up and down together simultaneously and then in sequence on the other cylinders at the same position. Injecting once per revolution and will start at BDC or it may be adjusted otherwise. Fuel is injected very accurately and excellent CO adjustments can be achieved. The advantage of this method is that each cylinder receives its fuel under the same conditions, resulting in very smooth idling and revving. It is definitely better on power and consumption than the batch injection method. Injectors are wired in the same sequence as wasted spark. The fuel is distributed more evenly from the fuel pump and pulsing of fuel pressure comes to a minimum. The ECU only requires half the amount of drivers than cylinders on the engine. (See driver selection chart on how to combine these injectors.)

Full Sequential Injection

With this method each injector requires a driver. Fuel is injected once in 2 revolutions and normally starts at Bottom Deck Centre (BDC). Note: Not all the ECU's have enough drivers, so this feature is mainly for the Mercury2, up to 8 cylinders. Disadvantage is that this method does require the Cam or home pulse to sink injection with fazes and low impedance injectors require a ballast resistor. Advantages are better fueling at lower RPM and longer duty cycle makes for more accurate measuring on large injectors. (See wiring diagram on how to combine the injection methods.)

Throttle Body Injection

With this method, injectors are situated at the throttle body. The first generation injection systems used this method. It is important to inject in the right sequence especially on the 4 barrel systems. Some injectors are aimed at certain ports and must be pulsed in sequence to get a smooth distribution of the fuel mixture. (See specific wiring diagram to ensure the correct injectors are on the correct drivers.) Advantage of this method is easy to convert carburetor engines to fuel injection.

Micro Fueling or Dual Injectors

The ECU allows for the use of dual injectors per cylinder to be used. This has the advantage for turbo and duel fuel applications. If the power range of an engine is very big, one injector is too small at maximum load or too large to control at minimum load. Then the ECU will use 1 injector for light loads and 2 for high loads. The second injector could also be phased in with a different fuel mix for racing. Wiring is done in two ways depending on how many drivers are available on the ECU. Some may require an electronic relay to power the second set. (See wiring methods in the sub folders.)

Injector Sizing
Sizing example: 5 cc fuel is required for every 1 HP. This means that an 8 cylinder 600 HP requires 600 HP x 5 cc / 8 injectors = 375 cc/min. This is assumed at Lambda 1.00 (14.7 AFR) so if you are running richer, the desired Lambda reading needs to be taken into account. This calculation is based on information from the internet and should be researched with other manufacturers. It is merely as an example.

Resistance & Current
Different injectors have different resistance from 0.5 ohms to 16 ohms. This means that they require different operating currents and wiring circuits to open them. The Spitronics ECU's were designed for high impedance injectors. They draw 1 Amp each and can be connected together on the drivers in parallel. (See specifications on how much current the drivers can handle between the different products.) Low impedance, 3 to 5 ohm injectors, require current limited drivers to peak and hold drivers. With a minor wiring difference, the ECU's can do low impedance injectors connected in series. They draw 4 Amp each but in series they draw 2 Amp. Again, see the specifications on the ratings of the ECU's. If you want to do full sequential you need to add a 3.3 Ohm 10 Watt resistor in series to limit the current. Injectors with lower resistances like direct injection drivers cannot be used with the ECU's.

Dead Time
Dead time is the amount of time the injector takes to open from when the injector pulse starts. This varies with battery voltage and fuel pressure. Also varies between different kinds of injectors but is usually about 1 milliseconds or less at 14 volts. This dead time needs to be accounted for with Battery Voltage Compensation. But it is tuned in when the engine is mapped on the Dyno or street.

Spray Patterns
Some injectors have better spray patterns and atomize the fuel better than others. Injector position can dictate what type of spray pattern is required. Cycle, Duty Cycle and Pulse Width

A fuel injector is continuously powered by battery positive. The ECU output switch to ground to turn the injector 'on'.

Frequency: Number of complete cycles in one second, measured in Hertz. 1 Hz = 1 cycle/second. It is engine RPM / 60.

Cycle: Time from when an injector is turned 'on' until the next time it is turned 'on'.

Pulse Width: The time in seconds the injector is 'on'.

Duty Cycle: Percentage of time the injector is 'on' in one cycle.

Most injector ratings are to be used within 85% duty cycle. You may get more fuel through with higher fuel pressure but stay within the working limits of the injector.

(See sub folders for explanation on wiring and connections.)

Related Links

Software


High Impedance

Help > ECU Hardware Description > Driver Outputs > Fuel Injectors >

High Impedance Injectors

These drawings explain only how the injectors are connected for each driver. The amount of connections will vary with engine size. (See specific drawings for your application.)

Batch & Split Sequential Wiring

With this method you always combine 2 drivers in Parallel. In this drawing A1 is on cylinder 1 and A2 is on the cylinder that moves with it.

Batch & Split Sequential Wiring with Dual injectors

With this method you still combine 2 drivers in parallel. The electronic relay will split the power from getting to the dual injectors. The ECU will switch the electronic relay on with a positive signal from one of the positive drivers reserved for this function. Note: Make sure that the driver can take the combined current for the 4 injectors. Mercury with serial number lower than 300 could only handle 3.5 amp where the later models and Mercury2 can handle 6 Amp per driver. A diode large enough must be wired-in for each bank from the electronic relay. This will prevent power feedback from the injector drivers when the electronic relay is off. For 2 high impedance injectors the diode must be 3A or higher. In this drawing A1 & A2 is the primary injector and A3 & A4 is the dual injectors. A1 & A3 is on cylinder 1 and A2 & A4 is on the cylinder that moves with it.

Full Sequential Wiring

With this method only one injector is connected per driver.

Full Sequential Wiring with Dual injectors

The electronic relay will split the power from getting to the dual injectors. The ECU will switch the electronic relay on with a positive signal from one of the positive drivers reserved for this function. Some applications have enough drivers and then the dual drivers are connected (as above) onto its own driver. No electronic relay will be required. A diode large enough must be wired in for each injector from the electronic relay. This will prevent power feedback from the injector drivers when the electronic relay is off. For high impedance injectors the diode must be 3A or higher. In this drawing A1 is the primary injector and A2 is the dual injectors.

Related Links

Software


Low Impedance

Help > ECU Hardware Description > Driver Outputs > Fuel Injectors >

Low Impedance Injectors

These drawings explain only how the injectors are connected for each driver. The amount of connections will vary with engine size. (See specific drawings for your application.)

Batch & Split Sequential Wiring

With this method you always combine 2 drivers in series. This will lower the voltage to each of them simulating a current limit driver. In this drawing A1 is on cylinder 1 and A2 is on the cylinder that moves with it.

Batch & Split Sequential Wiring with dual injectors

With this method you still combine 2 injectors in series. The electronic relay will split the power from getting to the dual injectors. The ECU will switch the electronic relay on with a positive signal from one of the positive drivers reserved for this function. A diode large enough must be wired-in for each bank from the electronic relay. This will prevent power feedback from the injector drivers when the electronic relay is off. For low impedance injectors the diode must be 3A or higher.

Note: Make sure that the driver can take the combined current for the 4 injectors. Mercury with serial numbers lower than 300 could only handle 3.5 amp where the later models and Mercury2 can deliver 6 Amp per driver. In this drawing A1 & A2 is the primary injector and A3 & A4 is the dual injectors. A1 & A3 is on cylinder 1 and A2 & A4 is on the cylinder that moves with it.

Full Sequential Wiring

With this method only one injector is connected per driver. Then you need to install a ballast resister to reduce the current. In some cases, where the injector is on the large side, you may omit the resistor as the driver on the Mercury2 can handle the current and the fuel will cool the injector. Note: The resistors will produce heat, so it is advisable not to tape them in the harness. They may require air cooling on them. On the Pluto feel if the enclosure generates excessive heat in the last case.

Full Sequential Wiring with dual injectors

With this method you must install the ballast resistors. The electronic relay will split the power from getting into the dual injectors. The ECU will switch the electronic relay on with a positive signal from one of the positive drivers reserved for this function. A diode large enough must be wired in for each bank from the electronic relay. This will prevent power feedback from the injector drivers when the electronic relay is off. For low impedance injectors the diode must be 3A or higher. Some applications have enough drivers and then the dual drivers are connected as above onto its own driver. No electronic relay will be required. In this drawing A1 is the primary injector and A2 is the dual injectors.

Relate Links

Software


Injector Combinations

Help > ECU Hardware Description > Driver Outputs > Fuel Injectors >

Injector Combinations Mercury2

Injectors | 3 Cyl | 4 Cyl | 4 Cyl | Subaru | Subaru | 5 Cyl | 5 Cyl |
Injection Type | F/Seq | S/Seq | F/Seq | S/Seq | F/Seq | S/Seq | F/Seq |
Firing Order | 123 | 1342 | 1342 | 1324 | 1324 | 12453 | 12453 |
DRV 6 |  |  |  |  |  |  |  |
DRV 5 |  |  |  |  |  |  | 5 |
DRV 4 |  |  | 2 |  | 4 |  | 4 |
DRV 3 | 3 |  | 4 |  | 2 |  | 3 |
DRV 2 | 2 | 2 & 3 | 3 | 3 & 4 | 3 |  | 2 |
DRV 1 | 1 | 1 & 4 | 1 | 1 & 2 | 1 | 12345 | 1 |
Injectors | V6 Cyl | V6 Cyl | V6 Cyl | V6 Cyl | Str 6 Cyl | Str 6 Cyl | V8 Cyl | V8 Cyl
Injection Type | S/Seq | F/Seq | S/Seq | F/Seq | S/Seq | F/Seq | S/Seq | F/Seq *
Firing Order | 123456 | 123456 | 142536 | 142536 | 153624 | 153624 | 18436572 | 18436572
DRV 8 |  |  |  |  |  |  |  | 2
DRV 7 |  |  |  |  |  |  |  | 7
DRV 6 |  | 6 |  | 6 |  | 4 |  | 5
DRV 5 |  | 5 |  | 3 |  | 2 |  | 6
DRV 4 |  | 4 |  | 5 |  | 6 | 3 & 2 | 3
DRV 3 | 3 & 6 | 3 | 2 & 6 | 2 | 3 & 4 | 3 | 4 & 7 | 4
DRV 2 | 2 & 5 | 2 | 4 & 3 | 4 | 5 & 2 | 5 | 8 & 5 | 8
DRV 1 | 1 & 4 | 1 | 1 & 5 | 1 | 1 & 6 | 1 | 1 & 6 | 1
DRV x | Injector Driver numer x |  |  |  |  |  |  |
S/Seq | Split-Sequential Injection |  |  |  |  |  |  |
F/Seq | Full-Sequential Injection |  |  |  |  |  |  |
* | Only if firmware is available |  |  |  |  |  |  |

Relate Links

Software


Injector Wiring Options

Help > ECU Hardware Description > Driver Outputs > Fuel Injectors >

Injector Wiring Options

This section indicates the different wiring options for injectors on the different products. It shows which settings in Hyperspace to set for the different configurations. Do this while you are planning the system and before connecting the injectors to the units. Note: It is not necessarily according to actual pairing of the injectors or firing order but merely for explanation purposes.

An electronic relay is required for dual injectors when there aren't enough drivers. Each dual driver also requires an isolating diode. Primary and secondary injectors are commonly connected on the drivers and the power is split by the electronic relay. Only the Ratio fuel method can be used here. Note: A positive driver is required for the electronic relay so it cannot be used on Pluto2 or Saturn for that reason.

Terminology:

P = Primary

S = Secondary

E-Relay = Electronic Relay

Micro Fuel = Dual Injectors.

Split-Sequential = Phased Sequential

Power comes from the Injector Relay Pin 87

(See the sub folders for the different engines.)

Relate Links

Software


1 Cylinder

Help > ECU Hardware Description > Driver Outputs > Fuel Injectors > Injector Wiring Options >

Injector Options 1 Cyl

Full Sequential uses 1 driver - Mercury2 Saturn Pluto2

Full Sequential Dual Injectors uses 2 injector drivers - Mercury2

or


2 Cylinder

Help > ECU Hardware Description > Driver Outputs > Fuel Injectors > Injector Wiring Options >

Injector Options 2 Cyl

Split Sequential uses 1 driver - Mercury2 Saturn Pluto2 (cylinders that move in same stroke)

Split Sequential uses 2 drivers - Mercury2 Saturn Pluto2

Full Sequential uses 2 drivers - Mercury2

Full Sequential Dual Injectors uses 4 injector drivers - Mercury2

or


3 Cylinder

Help > ECU Hardware Description > Driver Outputs > Fuel Injectors > Injector Wiring Options >

Injector Options 3 Cyl

Full Sequential uses 3 drivers - Mercury2 Saturn Pluto2

Full Sequential Dual Injectors uses 6 injector drivers - Mercury2

or


4 Cylinder

Help > ECU Hardware Description > Driver Outputs > Fuel Injectors > Injector Wiring Options >

Injector Options 4 Cyl

Split Sequential uses 2 injector drivers - Mercury2 Saturn Pluto2

Full Sequential uses 4 drivers - Mercury2

Split Sequential Dual Injectors uses 4 injector drivers - Mercury2

or

Full Sequential Dual Injectors uses 8 injector drivers - Mercury2

or


5 Cylinder

Help > ECU Hardware Description > Driver Outputs > Fuel Injectors > Injector Wiring Options >

Injector Options 5 Cyl

Full Sequential uses 5 drivers - Mercury2

Full Sequential Dual Injectors uses 6 injector drivers - Mercury2

or


6 Cylinder

Help > ECU Hardware Description > Driver Outputs > Fuel Injectors > Injector Wiring Options >

Injector Options 6 Cyl

Split Sequential uses 3 injector drivers - Mercury2 Saturn Pluto2

Full Sequential uses 6 drivers - Mercury2

Split Sequential Dual Injectors uses 6 injector drivers - Mercury2

or

Full Sequential Dual Injectors uses 6 injector drivers - Mercury2


8 Cylinder

Help > ECU Hardware Description > Driver Outputs > Fuel Injectors > Injector Wiring Options >

Injector Options 8 Cyl

Split Sequential uses 4 injector drivers - Mercury2 (Saturn Pluto2 only 2Coil engines like 1UZ non VVTI)

Full Sequential uses 8 drivers - Mercury2

Split Sequential Dual Injectors uses 8 injector drivers - Mercury2

or

Full Sequential Dual Injectors uses 8 injector drivers - Mercury2


10 Cylinder

Help > ECU Hardware Description > Driver Outputs > Fuel Injectors > Injector Wiring Options >

Injector Options 10 Cyl

Split Sequential uses 5 injector drivers - Mercury2

Split Sequential Dual Injectors uses 5 injector drivers - Mercury2


12 Cylinder

Help > ECU Hardware Description > Driver Outputs > Fuel Injectors > Injector Wiring Options >

Injector Options 12 Cyl

Split Sequential uses 6 injector drivers - Mercury2

Split Sequential Dual Injectors uses 6 injector drivers - Mercury2


Ignition Coils

Help > ECU Hardware Description > Driver Outputs >

Ignition Coils

Distributed Spark System
With this system, which was popular in the older cars, there is only one ignition coil for all the cylinders. The spark is distributed to the spark plugs with a rotor and distributor cap. Here only one driver is required from the ECU. The disadvantage of this system is that the coil has to charge and discharge a couple of times in one revolution. With high revving and performance motors this means that spark quality will deteriorate with increased RPM's. Another problem is spark deterioration with the gap between rotor and cap. It also has a higher maintenance service. Very important for these systems is the rotor fazing. Advantage is one coil and driver and full sequential spark system. (View it further in the manual.)

Wasted Spark System
With this system there is one coil for the two cylinders that move up and down simultaneously. The cylinders that are 360 degrees apart are paired. These coils have two High Tension towers which spark on the two plugs simultaneously, one on compression stroke and the other on exhaust stroke. Each dual coil is being driven by its own driver in sequence from the ECU. The advantage is less drivers and coils and better spark than distributors. This method only requires a crank gear with TDC slot. Disadvantage is the coils energy is divided between 2 spark plugs. Also the fact that current is reversed through on plug. This deteriorate copper cored sparkplugs unevenly.

Multi Coil Spark system

With this system there is one coil for every spark plug. The coils must be driven by separate drivers from the ECU. This makes the ECU larger and more expensive. The coils are fired in full sequential or wasted spark method. The advantage is more spark energy per cylinder. Disadvantage is the number of coils and drivers required.

Different Types of Coils

Coil Selection

It is important to know which coil on the engine has a faulty setting as this may destroy the ECU driver or coil. Always start the ECU with a disconnected output connecter till you set the trigger level output to the correct setting, or alternatively wire the ECU correctly. Start with a 5A Fuse in the coil positive circuit which will blow quickly if you have an error. If you have coil packs with a common positive, insert 5A fuses in each driver signal to protect the coil against damage.

Oil filled coils

The point-condenser coil has a resistance of +/- 1.5 ohm and a charge-time of 7 m/s. the spark on this coil will be weak. Should you need to use it do not connect the ballast resistor. If the coil has a resistance of 3 to 3.5 ohms it has a built in ballast resistor and will produce poor spark. It is not recommended to use these coils.

Electronic ignition coils were designed for variable dwell systems to improve spark at high Rpm's. They have a resistance of +/- 0.8 ohm. and a charge time of 3 to 5 m/s. they can be used effectively but are being phased out by manufacturers.

For all of the above coils the Pluto2 and Saturn ECU Trigger Level Output must be set to the ECU Driver so that the ECU charges the coil with a negative pulse and fires it with a positive going pulse. Mercury2 uses external drivers and does not have a software setting.

Epoxy filled Basic coils

These hard resin coils and consist of single, wasted spark or combinations of coils in a single housing. Some have built in driver electronics. If it has no driver there is usually a common pin and one pin for each coil. To measure this coil put the meter on Ohms and measure all the points. You should get a 0.8 Ohm reading for each coil. If you measure over the two coils it should read 1.6 Ohm. For all of the above coils the ECU Trigger Level Output must be set to ECU Driver so that the ECU charges the coil with a negative pulse and fires it with a positive going pulse.

Epoxy filled coils with built in drivers

If you measure high resistances on open circuit, then the coils have an internal driver. These coils normally have a positive, ground and trigger input for each coil. These coils are normally charged with a positive pulse and fired with a negative going pulse. Using these coils with the Pluto2 or Saturn ECU requires an external resistor between the trigger and positive of the coil. The reason is that the Pluto ECU only gives a ground signal for normal coils. For all these coils the ECU Trigger Level Output must be set to External Driver so that the ECU can charge the coil with a positive pulse and fire it with a negative going pulse. Mercury2 can drive these coils directly without mods. These Coils with internal drivers can be connected two coils per output. You must add a pull-up resistor per driver and make sure on the firing order to connect the two cylinders of these coils that move up and down simultaneously.

Spark Plugs and Leads

Use high quality inductive suppression leads such as Bougi Cord. Don't use wire leads: Possible interference.

Be careful when changing spark plug type. Always consult the vehicle's owner's manual first. Some ignition coils are sensitive to the type of spark plug used. If the ignition system uses resistive type plugs from the factory NEVER use non-resistive plugs as it may result in coil failure.

Run high tension leads as far from the ECU wiring as possible (especially sensor signals). Otherwise reconsider the wiring loom and layout. If the loom must cross the ignition wiring it should do so at right angles to minimize the interference.

(See the sub folders for explanation on wiring and connections.)

Related Links

Software


Basic Coils

Help > ECU Hardware Description > Driver Outputs > Ignition Coils >

Basic Coil Wiring

With the Mercury Coil Driver only one coil may be connected to each output. The Mercury2 uses a wasted spark firing algorithm so when you have single coils on the engine you need to combine 2 trigger inputs of the firing module to one output of the Mercury2. The coil driver triggers of the two cylinders that move up and down together, are tied together.

Related Links

Software


Coils with Drivers

Help > ECU Hardware Description > Driver Outputs > Ignition Coils >

Coils with Built in drivers

Coils with built in drivers are connected directly on the Mercury2 output. Single coils are combined so that the two cylinders that move up and down together are tied together. The Mercury2 uses a wasted spark firing algorithm as the popular choice.

Wasted spark coils are connected only one per Mercury2 driver and up to 6 coils.

Single coils must be combined 2 per Mercury2 driver and up to 12 coils.

Related Links

Software


Mercury Coil Driver

Help > ECU Hardware Description > Driver Outputs > Ignition Coils >

Mercury Coil driver

The Mercury2 ECU was designed for the latest technology in engines. Most coils today found on engines has built in drivers to minimize wiring and interference. These coils require a positive charge signal and will spark at negative transition of that signal. The Mercury2 has 8 positive drivers. It can trigger up 8 coils in sequential and 12 coils in wasted spark mode. Note: Firmware determines this action. (See availability in the firmware chart.)

For Basic coils that do not have built in drivers Spitronics designed the Mercury Coil Driver and it comes in 2, 4 or 6-way driver combinations. For large engines like 8, 10 and 12 cylinders a combination of 2 can be used.

(See the Coil Wiring Options for the different wiring methods.)

Related Links

Software


Coil Combinations

Help > ECU Hardware Description > Driver Outputs > Ignition Coils >

Coil Combinations Mercury2

Mercury use a wasted spark algorithm even for COP coils. Each coil will have a driver. Full sequential spark is possible but will use the other drivers that are available for idle, fuel, fazed injector control etc. Note: Firmware is separate as it is mostly used for racing engines with serious overlap cams.

Coils | Distributor | 3 Cyl | 4 Cyl | 4 Cyl | Subaru | Subaru | 5 Cyl
Coil Comb. | M/Coil | M/Coil | W/S Coil | M/Coil | W/S Coil | M/Coil | M/Coil
Firing Order |  | 123 | 1342 | 1342 | 1324 | 1324 | 12453
DRV 6 |  |  |  |  |  |  |
DRV 5 |  |  |  |  |  |  | 5
DRV 4 |  |  |  | 2 |  | 4 | 4
DRV 3 |  | 3 |  | 4 |  | 2 | 3
DRV 2 |  | 2 | 2 & 3 | 3 | 3 & 4 | 3 | 2
DRV 1 | 1 | 1 | 1 & 4 | 1 | 1 & 2 | 1 | 1
Coils | V6 Cyl | V6 Cyl | V6 Cyl | V6 Cyl | Str 6 Cyl | Str 6 Cyl | V8 Cyl
Coil Comb. | W/S Coil | M/Coil | W/S Coil | M/Coil | W/S Coil | M/Coil | W/S Coil
Firing Order | 123456 | 123456 | 142536 | 142536 | 153624 | 153624 | 18436572
DRV 6 |  | 6 |  | 6 |  | 4 |
DRV 5 |  | 5 |  | 3 |  | 2 |
DRV 4 |  | 4 |  | 5 |  | 6 | 3 & 2
DRV 3 | 3 & 6 | 3 | 2 & 6 | 2 | 3 & 4 | 3 | 4 & 7
DRV 2 | 2 & 5 | 2 | 4 & 3 | 4 | 5 & 2 | 5 | 8 & 5
DRV 1 | 1 & 4 | 1 | 1 & 5 | 1 | 1 & 6 | 1 | 1 & 6
DRV x | Coil Driver numer x
M/Coil | Multi Coil - 1 per Cylinder
W/S Coil | Wasted Spark Coil

Related Links

Software


Coil Wiring Options

Help > ECU Hardware Description > Driver Outputs > Ignition Coils >

Coil Wiring Options

This section indicates the different wiring options for coils on the different products. The sub folders are grouped for Mercury2 and then Pluto2 and Saturn to prevent confusion.

Mercury2 has no Coil drivers on board and can only be wired to Coils with built in drivers or external coil drivers.

Pluto2 and Saturn has up to 6 built in coil drivers that is shared with injectors. Usually 6 cylinder is the most cylinder's engines that they can run with the exception of the engines with 1 or 2 distributors. There are an ignition only program that can run 6 coils.

Terminology:

Coil Driver = Power Mossfet or IGBT electronic component that amplifies current for driving coils

Basic Coils = Coil with no Driver

Intelligent Coils = Coil with built in Driver

Wasted Spark fires every revolution on exhaust stroke as well.

Power comes from the Injector Relay Pin 87

Earth comes from Chassis

(See the sub folders for the different coil combinations.)

Related Links

Software


1 Coil

Help > ECU Hardware Description > Driver Outputs > Ignition Coils > Coil Wiring Options > Mercury2 >

Coil Options 1 Coil

Note that most of the 1 Cylinder engines are used with distributors but in some cases the 4 Cylinder firmware can be used in wasted spark mode. So the settings may be one of the following:

Intelligent Coils uses 1 ECU driver.

Basic Coils uses 1 ECU drivers and a 2-Way Coil Driver


2 Coil

Help > ECU Hardware Description > Driver Outputs > Ignition Coils > Coil Wiring Options > Mercury2 >

Coil Options 2 Coils

Note that most of the 2 Cylinder engines are used with the 4 Cylinder firmware and therefore used in wasted spark mode.

Intelligent Coils for 2 Cylinder uses 1 ECU driver if firing is 360° out of faze.

Intelligent Coils uses 2 ECU drivers.

Basic Coils uses 2 ECU drivers and a 2-Way Coil Driver


3 Coil

Help > ECU Hardware Description > Driver Outputs > Ignition Coils > Coil Wiring Options > Mercury2 >

Coil Options 3 Coils

Intelligent Coils uses 3 ECU drivers

Basic Coils uses 3 ECU drivers and a 4-Way Coil Driver


4 Coil

Help > ECU Hardware Description > Driver Outputs > Ignition Coils > Coil Wiring Options > Mercury2 >

Coil Options 4 Coils

Intelligent Coils uses 2 ECU drivers

Intelligent Coils uses 4 ECU drivers

Basic Coils uses 2 ECU drivers and a 4-Way Coil Driver

Basic Coils uses 4 ECU drivers and a 4-Way Coil Driver


5 Coil

Help > ECU Hardware Description > Driver Outputs > Ignition Coils > Coil Wiring Options > Mercury2 >

Coil Options 3 Coils

Intelligent Coils uses 3 ECU drivers

Basic Coils uses 3 ECU drivers and a 4-Way Coil Driver


6 Coil

Help > ECU Hardware Description > Driver Outputs > Ignition Coils > Coil Wiring Options > Mercury2 >

Coil Options 6 Coils

Intelligent Coils uses 3 ECU drivers

Intelligent Coils uses 6 ECU drivers

Basic Coils uses 3 ECU drivers and a 6-Way Coil Driver

Basic Coils uses 6 ECU drivers and a 6-Way Coil Driver


8 Coil

Help > ECU Hardware Description > Driver Outputs > Ignition Coils > Coil Wiring Options > Mercury2 >

Coil Options 8 Coils

Intelligent Coils uses 4 ECU drivers

Intelligent Coils uses 8 ECU drivers

Basic Coils uses 4 ECU drivers and two 4-Way Coil Drivers

Basic Coils uses 8 ECU drivers and two 4-Way Coil Drivers


10 Coil

Help > ECU Hardware Description > Driver Outputs > Ignition Coils > Coil Wiring Options > Mercury2 >

Coil Options 10 Coils

Intelligent Coils uses 5 ECU drivers

Basic Coils uses 5 ECU drivers and two 6-Way Coil Drivers


12 Coil

Help > ECU Hardware Description > Driver Outputs > Ignition Coils > Coil Wiring Options > Mercury2 >

Coil Options 12 Coils

Intelligent Coils uses 6 ECU drivers

Basic Coils uses 6 ECU drivers and two 6-Way Coil Drivers


1 Coil

Help > ECU Hardware Description > Driver Outputs > Ignition Coils > Coil Wiring Options > Pluto2 Saturn >

Coil Options 1 Coils

Basic Coils uses 1 ECU drivers

Intelligent Coils uses 1 ECU drivers and 1 Pull-up resistors.


2 Coil

Help > ECU Hardware Description > Driver Outputs > Ignition Coils > Coil Wiring Options > Pluto2 Saturn >

Coil Options 2 Coils

Basic Coils uses 2 ECU drivers

Intelligent Coils uses 2 ECU drivers and 2 Pull-up resistors.


3 Coil

Help > ECU Hardware Description > Driver Outputs > Ignition Coils > Coil Wiring Options > Pluto2 Saturn >

Coil Options 3 Coils

Basic Coils uses 3 ECU drivers

Intelligent Coils uses 3 ECU drivers and 3 Pull-up resistors.


4 Coil

Help > ECU Hardware Description > Driver Outputs > Ignition Coils > Coil Wiring Options > Pluto2 Saturn >

Coil Options 4 Coils

Basic Coils uses 4 ECU drivers

Intelligent Coils uses 2 ECU drivers and 2 Pull-up resistors.

Intelligent Coils uses 4 ECU drivers and 4 Pull-up resistors.


6 Coil

Help > ECU Hardware Description > Driver Outputs > Ignition Coils > Coil Wiring Options > Pluto2 Saturn >

Coil Options 6 Coils

Intelligent Coils uses 3 ECU drivers


General Purpose Outputs

Help > ECU Hardware Description > Driver Outputs >

General Purpose Outputs

General purpose outputs can be configured to perform several functions required by the installer. These functions can be to control electric cooling fans, shift lights, V-Tech Cams, idle valve control, battery charge warning, economy light, to mention a few. Some of these functions will be on/off controls, while others may be duty cycle controls. The drivers are not strong enough to perform certain functions and has to be wired via a relay. Note: Make sure about the specifications of your product and the correct wiring thereof.

Click on the link below for the different wiring diagrams.

Electric Fan Control

V-tech Solenoid Control

Variable Intake Solenoid Control

Lamp Control

Related Links

Software Setup

GP Output Priority


Idle Control

Help > ECU Hardware Description > Driver Outputs >

Idle Control

Spitronics ECU's has the capabilities to do idle control. There are 2 main types of idle control motors namely; valve and stepper motor controllers. The new generation engines use the throttle by wire to do idle control. See the TxW manual for its explanation. It is not covered in this manual as it is a Spitronics standalone product.

(For more information, see sub folders.)

Related Links

Software

Idle Control Tuning


Valve Idle Motor

Help > ECU Hardware Description > Driver Outputs > Idle Control >

Valve Idle Motor

Valve type idle motors are very robust and a popular choice. They only need one or two drivers from the ECU to operate. Usually it is a DC motor or solenoid that is powered by Pulse Width Modulation PWM, and has a spring action to return it to closed position. The electronic magnetism that is generated from the current running through the coil will act on a metal core and pull it into the coils. The more the current flows, the harder the pull against the spring and in turn more movement will open a valve. The ECU can position these valves very fast at start-up and make quick idle changes. (See below for the four types discussed here in this section.)

Single coil with spring

This model is found on most cars and comes in different shapes and sizes. The air opening will be closed and PWM will open it. The Driver from the ECU will drive this coil directly. No additional hardware is required except a free wheel diode that goes over the inductive coil. This diode is always tied with the stripe on the positive side of the current. Some ECU's use a positive driver and some a negative driver, so you need to be sure. Having this connected wrong may damage the driver. Note: Look into the specs of the ECU and the resistance or current requirement of the valve to ensure that you don't damage the driver. (See the drawing below for explanation on both connection methods.)

Duel coil with spring

This green model is scarce and mostly used on older Toyota engines. The opening is partially open to allow for fast idling in limp mode if it is not powered. The two drivers from the ECU will drive this two-coil directly with PWM. One PWM signal will be inverted from the other so that more power is put on one side to open while the other side power is reduced. No additional hardware is required except two free wheel diode that goes over the inductive coils. This diode is always tied with the stripe on the positive side of the current. Some ECU's use a positive driver and some a negative driver, so you need to be sure. Having this connected wrong may damage the driver. Note: Look into the specs of the ECU and the resistance or current requirement of the valve to ensure that you don't damage the driver. (See the drawing below for explanation on both connection methods.)

Dual coil without spring

This model is also scarce and mostly older BMW engines. The opening will stay in that position if the power is taken off. It has no spring. Power on one side will completely open and on the other side completely close. The two drivers from the ECU will drive the two coils directly with PWM. It is the same program and connection as the 2 coil spring model. See description above. (Use the same connection diagrams.)

Idle control with electronics

This black model is scarce and found mostly in older Toyota engines. This idle control unit has built in electronics and its own driver. It requires 12 volts, earth and a position signal from the ECU. The opening is partially open to allow for fast idling in limp mode if it's not powered. The driver's signal from the ECU will drive this idle control directly with PWM. Note: This is only a duty signal to the device to indicate its opening position. No free wheel diode is required for this device. This device has a pull-up resistor inside so it requires a negative driver. Should you only have the positive driver you will require a special firmware program like the Toyota 6 Cyl VVTI one that has an additional negative driver spare. (See the drawing below for explanation on both connection methods.)

Throttle Adjustment

The throttles must be adjusted mechanically to let the engine idle at 100 RPM's below the Idle RPM at normal operating temperature. This will ensure that the engine always have enough air to keep idling to a minimum, even if the idle valve is completely shut. To do this you can blank-off the air intake to the idle valve or stepper motor and adjust the mechanical position of the throttle. Or you can enter a value of 100 RPM below mechanical idle RPM into the PC software at Idle RPM so that the idle control does not interfere with adjustments. Then adjust the throttle to the desired value. Reset the PC Idle RPM to the normal RPM's again. The engine must be hot and in neutral or park for this adjustment. If the throttle does not have an adjustment, then you need to set the Low Limit duty cycle to maintain minimum idle opening.

Related Links

Software

Idle Control Tuning


Stepper Idle Motor

Help > ECU Hardware Description > Driver Outputs > Idle Control >

Stepper Idle Motor

Stepper type idle motors are popular with certain manufacturers. They require four drivers from the ECU to operate. Spitronics made a separate Stepper idle control to free up some outputs in the ECU. It only requires one driver from the ECU to communicate with the idle control. The stepper motor is pulsed from the idle stepper control and has coils and magnets in 90° angles. A small gearbox will carry movement to a screw type valve. If the unit is disconnected it will hold its position. Positioning at start-up takes time due to the slow speed of these devices.

Idle Controller2

Spitronics has their own unique idle controls to control stepper motors. There are 2 types as discussed below and each type is required for specific models. This model can be triggered by a positive or negative driver from the ECU. This is to cater for Pluto2 and Saturn that has no positive drivers. The idle control has a wire to choose the pulse type from the ECU. You need to connect it to ground or positive. It is an internal resistor that can be in pull-up or pull-down mode. (See the wiring diagrams on how they are connected with the different products.)

4 Coil Stepper motor

This stepper motor is not very popular and mostly used by Toyota, it has six wires. This stepper controller has four coils that are positioned in 90° angles around the stator. Each time a separate coil is exited the stator is moved 90° in forward or reverse detection. The Stepper controller determine the sequence of excitements as it is required by the ECU. There are two separate positives, one positive for two coils each. The Idle2 stepper control from Spitronics comes in two models. Type 1 is used for this stepper type. (For connection on the harness see the drawings manual for each product.)

2 Coil Bipolar Stepper motor

This stepper is more popular and used by many manufacturers. This stepper controller has two coils that are positioned in 90° angles around the stator. Each time a separate coil is exited the motor part is moved 90° in forward or reverse detection. The 90° movement is possible by reverse power through the solenoids. This is done by two H-bridge connections or 8 drivers. Four positive and four negative. There are connection differences in some of these models. If it turns in the wrong direction, then swop driver 1 and 2. Leave the other one as is. The Stepper controller determines the sequence of excitements as it is required by the ECU. The Idle2 stepper control from Spitronics comes in two models. Type 2 is used for this stepper type. (For connection on the harness see the drawings manual for each product.)

Throttle Adjustment

The throttle must be adjusted mechanically to let the engine idle at 100 RPM's below the Idle RPM at normal operating temperature. This will ensure that the engine always has enough air to keep idling to a minimum, even if the idle valve is completely shut. To do this you can blank the air intake to the idle valve or stepper motor off and adjust the mechanical position of the throttle. Or you can enter a value of 100 RPM below mechanical idle RPM into the PC software at Idle RPM so that the idle control does not interfere with adjustments. Then adjust the throttle value to as desired. Reset the PC Idle RPM to the normal RPM's again. The engine must be hot and in neutral or park for this adjustment.

Related Links

Software

Idle Control Tuning


Power Relay Wiring

Help > ECU Hardware Description >

Power Relay Wiring

The ECU controls the power to all the hardware via the power relay circuit. These relays also act as a safety cutout for the fuel pump in case of engine stalls. When you switch the ignition on, the ECU will switch the relay output on for 3 seconds. If the engine is not cranked in that time it will be shut off again. This is to prime the fuel rails. In case of an accident these relays will be shut down in one second after the engine has died. This will stop the fuel pump from pumping fuel in ruptured lines. Note: Do not connect control hardware like coils and pumps to other power sources as they will feed back power after the ECU is switched off. They must be connected to the control relays.

Mechanical Relays

Always use 3 mechanical relays. For 2 or less coils you may reduce to 2 relays. On large systems like 8 coils or more, you may add a fourth relay to share the load. Use Relay 1 for clean power for the ECU and lambda sensor. Use Relay 2 for injectors and fuel pump. This will prevent uneven voltage drops on the line that will cause the injectors to open unevenly resulting in fuel mixtures variation. Use Relay 3 for coils which create high voltage inductive spikes.

Pin 86 of the Relay 1 is tied to batter positive. Note that some of the older Mercury2 units had a built in freewheel diode which prevented the ECU from switching off when the key is switched off. In these cases, connect Pin 86 to ignition power that feed the ECU power on the P1. See the drawings for more instructions.

Note: There is a diode on Relay 1 pin 86 and 85 that will prevent spikes and relay buzz. Do not use this relay for other inductive loads.

Click on the links below to open the relevant drawings.

Power Distribution MEX01

Power Distribution with Fuse box

Electronic Relay

The electronic relay was designed by Spitronics to eliminate contact wear and to be waterproof. It is a solid state product with no moving parts. It can handle current up to 45 Amp and is short circuit protected. You only need one relay as the power handling should be enough. Note: One large fuse placed in front of the unit is recommended and the normal fuses for the different circuits.

Click on the links below to open the relevant drawings.

Electronic Relay Option

Related Links

Power Connection

Safety Precautions


Tachometer Wiring

Help > ECU Hardware Description > Driver Outputs >

Tachometer Wiring

The rev counter output can be used to drive an external rev counter (Tachometer), data logger or Spitronics transmission control unit. This output is a ground square wave signal with a 1K pull-up resistor to 12V. The output of the square wave is adjustable to calibrate external rev counters. Most digital tachometers or ECU's can be connected directly, there are 3 main types i.e.: Digital signal, Magnetic reluctor signal and H.V. Spike Tachometers. (See below.) It is important to know which type you have as the spike circuit could damage the other 2 permanently.

Digital Tachometers

This type can be connected directly on the ECU RPM output.

Magnetic Pickup Tachometers

This type requires a spike circuit that is earth based. Since the 12-volt square wave only goes to earth it does not trigger the tachometer. In this case a 10uF 25V capacitor can be used to isolate the DC which will generate a 6-volt spike circuit around earth. If you use a polarized capacitor, then put the positive side to the ECU side. If their ref wire is 12 Volt you may need to turn the cap around. If you use a non-polarized cap you should be ok both sides. You may need to add a 1K resistor in option 2 for the tachometer electronics. In some cases, you may require a 1K resistor on both sides as in option 3. You may also need to tweak the capacitance in some cases. There is no fixed circuit that will work with all of them.

HV Spike Tachometers

This type requires a high voltage spike more than 100 volts to operate. The reason is that this type was connected to coil negative. Spitronics manufacture a circuit that uses a relay coil and a high voltage Mossfet to achieve this. Do not use this circuit unless you are absolutely certain it is required by the tachometer and may damage other electronics if incorrect. Break out the contacts as thy will make a noise.

Related Links

Software Setup


Fuel Pressure Control

Help > ECU Hardware Description > Fuel Supply >

Fuel Pressure Control

The Mercury2 ECU has the feature to control fuel pressure by controlling the speed of the fuel pump. This is done with Pulse Width Modulation (PWM) from the power that is supplied to the fuel pump. In some cases, the positive driver of the Mercury2 is strong enough to directly control the fuel pump. But most fuel pumps draw more than 6-amp power at full delivery which will current limit the driver. To remedy this an amplifier is used in the form of the Spitronics Electronic Relay. The relay is pulsed in PWM and then does all the hard work and protects the ECU. Note: All inductive loads that are pulsed requires the free wheel diode over the power wires. This diverts generated currents back through the inductive loads eliminating electrical interference. Note: Cathode or the stripe on the diode must always be on the positive side, otherwise it will act as a short circuit and may damage itself and other components. Always put a fuse inline to protect the circuit and as close to the power supply as possible.

(See all the settings required under the Product Software Description.)

Related Links

Software


Power Connection

Help > Frequently asked questions >

Power Connection

When an ECU does not have proper connections to Power or Earth it will generate spikes and erratic behavior. The starter and alternator needs to be wired correctly.

Earth straps can cause interference and is usually a problem during cranking. The starter draw around 60 amp during cranking. Its current flow is a thick strap from battery negative directly to the engine. Then form battery positive to the starter solenoid to the starter motor. You do not want to share these wires with sensitive electronics. The chassis also needs to be earthed. The best way is another earth strap from battery negative to the chassis. Do not earth the chassis and engine to each other to simplify wiring. This cause a common wire that will share the starter spikes and will cause interference. The Alternator is also a source of interference. It is best to connect the charge wire which is the thick one directly to the battery positive. Remember the battery acts as a damping source for interference. So it is best to connect all different supplies to the poles.

Testing for earth problems.

1. Make sure all earth points are properly earthed. Sometimes paint of the chassis will prevent a good electrical connection.

2. Ensure that the thick black earth wire from the ECU is earthed properly. Also make sure that the thin black wires coming from the harnesses is also tied to this point. We call this junction Test point A

3. First ensure that the setup in galaxy is done according to the startup procedure. This means you will only have P1 connecter and on Mercury2 also P4. The other connecters must be open except the comms cable.

4. Now use a multi meter and put it on AC volts. Now measure on test point a to battery negative pole. Now crank the engine. The reading should be less than 0.2 volt. If it is higher it means a bad earth. See the advice above.

5. Now do the same test for the ECU positive. Measure between the ECU power pin 10 that comes from the key to battery positive terminal. Here you may find a slight more voltage due to other electronics that draw current from the ignition. Again if the volts is more that 1volt then you may need to put a relay in to bypass ignition key voltage drops. Remember the key does not supply much current and is only low amperage power to activate relays. Below is a circuit of a bypass relay.

Related Links

Power Relay Wiring

Safety Precautions


Fuel Suply Problems

Help > Frequently asked questions >

Fuel Supply

The fuel supply is mostly a basic mechanical system which is not controlled by the ECU except for switching and controlling the power of the fuel pump. The Mercury2 does have a fuel pressure control feature which gives the ECU more control over the system.

The basic fuel rail and pressure regulator system.

External Fuel Pump

In this system the fuel pump is supplied from the tank via a petrol filter through a thick pipe at gravity feed pressures. The pump pressurizes the fuel through the high pressure fuel filter into the fuel rail with injectors. A fuel pressure regulator will bleed fuel back to the tank if the pressure is higher that it calibrated bypass diaphragms. The regulator senses the intake manifold pressure and adjusts the fuel pressure to a set level. The return fuel also cools the fuel pump. The fuel pump is always on full power.

Internal Fuel Pump

In this system the fuel pump is mounted inside the tank with a sift as a pre-filter. The pump pressurizes the fuel via a high pressure fuel filter through the fuel rail with injectors against a fuel pressure regulator. The regulator senses the intake manifold pressure and adjusts the fuel pressure to a set level. This is done by returning the excess pressure and fuel via a return line straight back to the tank. The fuel in the tank cools the fuel pump. The fuel pump is always on full power. Some systems have the pressure regulator built into the tank and then there is only one fuel line to the fuel rail and injectors. No return line.

Pressure controlled Fuel Pump

In this system the fuel pump is mounted inside or outside the tank with a pre-filter. The pump pressurizes the fuel via high pressure fuel filter through to the fuel rail and injectors. In the fuel rail a fuel pressure sensor will relay the pressure to the ECU. The ECU will speed control the fuel pump with PWM to increase or decrease the pressure. There is no return line or mechanical fuel pressure regulator. The fuel DP fuel pressure sensor also senses the manifold pressure.

Related Links

Software


Fuel system Trouble Shooting

Help > ECU Hardware Description > Fuel Supply >

Fuel system Trouble Shooting

Fuel supply line to the pump is too thin. This will cause the fuel pump to draw a very low pressure on the inlet. When the fuel becomes hotter it will percolate due to the low pressure. This gas will then enter the pump making the pressure erratic. The gas is then pressurized at the injector tip and will reduce petrol flow and cause lean mixtures. The gas bubbles can also damage the pump.

Fuel pump heats up. It could be mounted too close to the exhaust or the pump is too large for the fuel rail system. The fuel flowing through it is too little to cool it off. It could be a dirty fuel pressure filter down stream that causes the pump to pump at too high pressures. If the pump is hot it will also cause the fuel to percolate and make gas bubbles. Do not bring the return line to the front of the fuel pump. The fuel must be cooled off in the tank.

Mechanical fuel pressure failure. Inside is diaphragms that could rupture or become soft with heat. Then accuracy may be a factor in cold and hot conditions. The vacuum line to the intake manifold can leak causing pressure differences.

Fuel lines are too thin. If the line to the fuel rail is too thin, the fuel pressure will drop before it reaches the injectors. If the return line is too thin the fuel pressure regulator cannot regulate properly and the pressure will be too high.

Erratic fuel pressure. This is usually caused by batch fueling as all the injectors open and close all at once. This makes for differences in pressure and fuel supply between the cylinders upstream and downstream.

Fuel pump is noisy and makes uneven sounds. These pumps get damaged by dirt, water and air bubbles. It is good practice to put an inline filter in front of the pump to ensure that dirt does not go through the pump. This will also indicate if air is in the system as most filters are see-through. It may pull in air through the connections.

Related Links

Software


GP Output Priority

Help > ECU Hardware Description >

GP Output priority

These spreadsheets assist in understanding the specific firmware programs on how the general purpose outputs are handled. Sometimes a single output will share 2 or 3 features. This document will explain which one takes priority over the other. These documents are saved on the website with the firmware, or in a folder called GP Layout Files

When you see a Software refreshed message then you must go through the setup and see which devices has been changed and set them accordingly.

Click on these links below for an example file of your product. Note This is only an example and may not be precise.

Mercury2 Example

Pluto2 Example

Saturn Example

Related Links

Software Setup

GP Output Wiring


Harness Level Discription

Help > ECU Hardware Description >

Harness Level description

To make ordering easier we categorize harness's in different groups. The price increases as the categorization level increases, however the installer will save time while carrying out the installation by opting for the more expensive Harness.

Level 1

Basic harnesses. These harness's come with a connector and the wires that go in them and predetermined lengths. The wires are marked and the colors are found on the drawings. Each installer will customize these harnesses in the car to his liking. He will add relays and fuse box wiring himself and supply all the power wires to the components like coils, injectors, fuel pump etc.

Advantages

· Cheapest option.

· Easy to customize in the car

Disadvantages

· No fuse boxes included

· No power wires included

· Long install time

Level 2

Premade complete loom untidy. These harness's come with all the connectors and the wires in one loom with predetermined lengths. The wires are marked and the colors are found on the drawings. Relays and fuses are wired into the loom which will save installation time. The loom is not tidied up yet to leave the installer the option to reroute GP output wires to different locations. The heat shrink on the connectors are supplied loosely to be tidied afterwards. There is also a roll of cloth tape provided to cover all wires neatly.

Advantages

· Easy to preparation for a customer

· Easy to customize in the car

· Saves time during installation in the car

· Eliminate errors in wiring

Disadvantages

· Price is higher

· There is still a bit of work to tidy the harness.

Level 3

Premade complete loom tidied. These harness's are the same as level 2 but have been tidied-up for the customer. The dealer prepares the GP outputs and marks them. The heat shrink is shrunk and the loom is neatly wrapped on the open sides with cloth tape. All the customer needs to do is solder and neaten up his connectors.

Advantages

· Easy to install in the car

· Saves time during installation in the car

· Eliminate errors in wiring

Disadvantages

· Price is higher

· Connectors need to be soldered on.

Level 4

Plug & Play loom. These harness's are the same as level 3 but has the connectors soldered on. Now this may be new connectors or the ones supplied from that engine. Not all looms will come like this as there are a big variation in connector types.

Advantages

· Easy to install in the car

· Saves time during installation in the car

· Eliminate errors in wiring

Disadvantages

· Price is higher


ECU Software Desciption

Help >

ECU Software Description

This software is used to adjust all parameters in the ECU. There is information, setup, graph, matrix and real time screens. Please read the sub folders for more information on this software.


Startup Screen

If you open the software without a live device connected, you will come to the main pallet or screen which forms the framework of the Hyperspace software. It looks the same for all the devices. From here you can open map files, connect to devices and set basic settings required for the software to operate. See below all the functions that can be set from here.

At the top is the start instructions to manipulate the software.

At the bottom left corner is a connect button and also a tab that show the status and ECU that are connected.

At bottom right corner is error and information codes. This will indicate what is happening with the software or device.

See the sub folders for detail explanation.


Top Toolbar

Help > ECU Software Desciption > Startup Screen >

Top Toolbar

This part of the start-up screen reflects on the version of the software, normal windows manipulation buttons and then the main menu for device settings, file functions and help files and manual.

This software is Version 3.5.1 The last 1 is a sub release as fixes etc. are made. Beta means it is in final test phase or pre release.

See the sub folders for detail explanation on the Tuning, File and Help menus.


Tuning Menu

Help > ECU Software Desciption > Startup Screen > Top Toolbar >

Tuning Menu

Settings is to set up units, software and device communications and auto map save settings.

Exit is to quit the software.

Connect is to connect or dis-connect to the ECU,

Settings

Unit selection

Select Metric or Imperial units. Change the style of the software colours.

Device Settings

These settings are important to cater for all kinds of laptops with different speeds. When the program is distributed it comes with the settings below:

If your tuning laptop or device is too slow the software will detect that some handshake signals did not occur in time and give you a warning. It will also tell you which setting to increase till the error disappear. See below:

Read Interval: This is the time it takes to read the limit table and product tables from the device via the serial USB port. This is normally about 1 seconds.

Write Interval: This is the time it takes to write values or strings of data from the graphs to the device via the serial USB port.

Flash Write Interval: This is the time it takes to write a map or two maps to the device via the serial USB port. This is the setup tables, graphs and matrix data. It could range from 2 to 4 seconds.

Poll Interval: This is the time it takes to read the real time values from the device via the serial USB port. This is information that constantly change like TPS, MAP, water temperature etc. This is normally read every 30 milliseconds.

Save Settings

The software will do Auto saves at time intervals. The intervals can be adjusted here. It will also have a max display list on the open file menu. Then the software will also make a backup copy of each download to ECU and it is called Device Saves. File location for these maps is in the folder where the Hyperspace is saved on the hard disk.


File Menu

Help > ECU Software Desciption > Startup Screen > Top Toolbar >

File Menu

This menu is to open the different saved maps or to save a map from a device onto the pc. The software will save periodic files in Auto Saves folder and also when you do a Device save it will make a copy in the Device Save folder.

Open is to open Map files offline

Open Recent is to open the last previous map files

Auto Saves is to open the last auto saved files

Device Saves is to open the last device saved files

Save is to save Map files on the PC

Save As is rename Map files on the PC


Help Menu

Help > ECU Software Desciption > Startup Screen > Top Toolbar >

Help Menu

This menu holds a list of all the hot keys that could be changed to suit each user. It also unlocks the embedded manual and will save a copy of it in the Hyperspace folder where the software was saved initially. About will indicate all the release fixes and changes between versions released.

Hotkeys

Here all the keyboard keys for manipulating features and tuning values are explained. You may change the way they work and also set up alternate keys that would make tuning better.

About

Information on version changes of the software.

Manual

A copy of the software manual is imbedded in the software.


ECUToolbar

Help > ECU Software Desciption > Startup Screen >

Toolbar

Toolbar Shortcut Buttons guide you to basic operations. Some of them also have Hot-keys that activate or deactivate them with one key stroke. Green background means activated.

Hide button - H

This button is used to show all lines on a graph or hide the ones that is not selected. It is handy if graphs are on top of each other to see each one separately.

Easy tune - E

This is a very handy feature if you have to lift graph dots simultaneously. There are different algorithms. That will only move dots from the tuning bar.

Initialise will make the whole line the same value as where the green tune bar cross

When easy tune is on then SHIF-Z will initialise every dot with the same selection to the same value as the bar.

Mouse on - M

This is handy to use mouse tuning on the graphs or disable it for arrow tuning.

Real-Time tracking - R

This is a very handy tool to move the green tuning bar with the real time bar of a graph. It is used with or without Easy Tune to adjust the same value that the ECU use at that time.

Data Logger

This feature is used for logging signal and tuning on the road. See the sub folder for explanation on its operation.

Connect Button

This indicates if the unit is connected. If you click on it then it will toggle to the other option.

Map Lock Option

This is handy to lock tuning maps so that the customer cannot change parameters. It is also a feature to clone the device with calibrations from another device. See the sub folder for explanation on its operation.

Open Map file

This is to load a Map file from the hard disk into the ECU.

Save Map file

This is to save a Map file from the ECU onto the hard disk.

Save to ECU

If you made changes you can save them permanently in the flash with these buttons. You can also press CTRL-S for save or click on the yellow flashing LED.

Upload ECU memory

This is used with the simulator and when firmware is flashed to the device. It will refresh the software with restarting it.

Quit button

Enough said

Communication LED

This indicates the status of the device.

Flashing green means ECU flash memory and PC memory are the same. No save is required.

Flashing yellow means you have changed parameters in the device but you have not made them permanent by saving to the flash memory.

Flashing red means no communication to the ECU.

Copyright © 2013. All rights reserved.


MAP Lock feature

Help > ECU Software Desciption > Startup Screen > ECUToolbar >

MAP Lock feature

Locking a device means entering a 6-digit password into the device. It will then require that password to unlock it and retrieve the tuning information. There is no master password so ensure you save a copy of that MAP or password for future reference in case of a device fail and you need to clone it with the same data Map.

If a device is locked and you don't have the password, you may load another map into the device to enable tuning again. Note : The previous maps will then be cleared from flash memory. It is not retrievable.

When you are finished tuning and you want to lock your ECU you can click on the Lock button. Enter your 6-digit password twice and press ok.

Your device is locked. Close the software.

When you connect to an ECU that is locked the software will require this password. It does not matter in which map the ECU is at the time.

If you enter the password, it will unlock the ECU for as long as the software is connected to the device. No matter in which tuning map it is at the time. If you save Map 1 then the password will be cleared and the ECU will be open for future connections. If you don't save Map1 and cycle the power the password will be reinstalled.

If you don't have the lock password, press Cancel. You now have the opportunity to load a new map and cloning the ECU. Note that this will clear all the calibrations and map data and you will have to start from scratch.

You may load an open map into the device to unlock it. Remember to go through all your settings as with a Start-up Procedure.

Click the connect button

Click Download to Device

Click Yes

Click Yes

The device will now be unlocked as well as cloned to the exact map you used. This feature is handy if you want to make a carbon copy of a device. Or a spare unit for backup.


Real Time Display

Help > ECU Software Desciption > Startup Screen >

Real-Time Display

This block displays all the analogue sensor values as they change in the ECU. You may change the appearance of some of the signals. Double click will toggle between 2 types of views. Below is a description of the meaning of each signal.

Lambda Sensor

This is the Lambda sensor value displayed in %. Notice on the graph that the rich and lean is inverted between wideband and narrowband.

MAP Sensor

This value displays the manifold pressure and is scaled according to the MAP range setting.

Injection Time

This value displays the total injection time that is applied after all calculations are done. It is in 0.1 milliseconds resolution.

Injection Duty

This value displays the ratio of injection time to revolution time in %.

TPS Sensor

This value displays the throttle position opening in %.

POT Sensor

This input can be connected to a potentiometer or other connections to achieve functions like launch control etc.

RPM

This value indicates engine revolutions per minute.

Ignition Timing

This value displays the total ignition timing that is applied after all calculations are done. It is in 1 degree's resolution.

Water Temperature Sensor

This value displays the current engine water temperature.

Air Temperature Sensor

This value displays the current air temperature at the air intake.

Battery Voltage

This value displays battery voltage that is connected to the ECU.

Fuel Pressure Sensor

This value displays the fuel rail pressure and is scaled according to the Fuel range setting.

Copyright © 2013. All rights reserved.


Status Bar

Help > ECU Software Desciption > Startup Screen >

Status Bar Display

This block at the bottom of the software displays all kinds of information messages, warnings and fault codes in the right corner. Also the connection status in the left corner.

See the sub folders for the different messages displayed on the Status bar:

Copyright © 2013. All rights reserved.


Error Codes

The ECU software has Error, Warning and Information codes displayed in the Status tool bar at the bottom. These codes will help the tuner to find problems during startup and tuning, also to see if the ECU is functioning correctly. Some of the functions on the ECU will indicate to the tuner what is happening. He can then see if these functions are operating correctly.

The codes are displayed at the right hand bottom corner. The code list [image] will display a list of accumulating codes so that the tuner can see what the codes were and in which order. The bottom indication will only show the last code. Also note that a code is only updated once, until it disappears and when it appears again the code will be logged again. This is to prevent the list from being too long. This does not apply to the angle sensor error codes during cranking. They will increment the counter as each one occurs.

Press the ''C'' key to clear the error codes. This is handy as you will not be able to see is the code is still present or if it was only listed once.

Note: If you crank an engine and it does not start, there will be one error code, error code 6 for Emergency Engine Shutdown. This is normal and not an actually an error. The ECU was expecting more trigger pulses but pulses were stopped. Therefore, the ECU goes into a safe shutdown of coils and injectors etc. A tip, press C then crank the engine. There should be no error and it will read 200 RPM's on the rev counter until the key is released.

The blue codes are for crank and cam related sensor errors. This is normally the angle signals that makes the ECU operate correctly. The red codes are warnings like over temperature etc. The green codes are for information of functions that were activated. The colors are only for explanation in this document.

The following list explain the different error codes

1 - Missing crank pulses - The crank sensor senses too little teeth per revolution

2 - Too many crank pulses or spikes - The crank sensor senses too many teeth per revolution

3 - Incorrect crank TDC slot - The crank sensor did not sense a TDC slot. (Maybe incorrect wiring)

4 - Missing TDC pulse - The TDC pulse is not present

5 - Missing home pulse - The Home pulse is not present

6 - Emergency engine shutdown - Safe shutdown of engine due to lack of or incorrect signals

7 - Fuel pressure safety cut-out - The fuel pressure sensor low limit has been reached

8 - Economy fuel cut-out - The fuel economy cut is implemented

9 - RPM limiter reached - The engine RPM limiter has been exceeded

10 - Max boost limiter reached - The boost pressure limit has been exceeded

11 - Water hot/cold temperature limiter reached - The water temperature limit has been exceeded

12 - Launch limiter reached - The launch limit RPM has been exceeded

13 - Lambda control limits reached - The lambda control limit has been reached

14 - Battery low voltage limit reached - The battery voltage falls below a critical limit

15 - Selection refreshed. Confirm driver placement - The ECU changed driver output configurations

16 - Timing retarded - Ignition timing is retarded during an automatic transmission shift procedure

17 - Flood control injector cut-out - Fuel is cut by injectors during cranking when the throttle is fully opened

18 - Flat-shift activated - Ignition or fuel is cut for a moment to enhance gearshift for racing engines

19 - Ignition power switched off - Ignition key power is switched off

20 - Sponsor counter depleted - The sponsor counter is depleted for sponsored ECU's

21 - Anti-Lag activated - Anti-Lag is activated on the Launch features


Selection Refreshed

Help > ECU Software Desciption > Startup Screen > Status Bar >

Selection Refreshed

This feature is initiated by the firmware to force the software to refresh its database. It happens when the tuner makes selections that are not legal for that specific firmware or when GP outputs are re-arranged by the features. The software will refresh and change the setting of the tuner to a safe level or disable other features. The messages below will then appear:

When you see this then you must go through the setup and see which devices have been changed and set them accordingly.


ECU Information

The device information screen displays vital information regarding the Spitronics ECU that has been connected. Note: Firmware is the program that is loaded into the ECU to make the electronics operate in a specific way. This is normally a HEX file which is loaded into the product by a USB debug programmer. Software is the tuning interface that runs on the computer and it is used to tune the product's parameters.

Serial Number

There is a unique number assigned to each product. It is saved on maps and recognized by the database on its status etc.

Hardware release

Displays which type of device has been connected to the software. In this case and a Mercury2 Engine Control Unit.

Hardware class

Displays the Hardware class of the product that has been connected to the software. The hardware class will determine which firmware can be uploaded onto the product. This feature allows the unit to open certain or all functions of the electronics. The amount of features determines the price of the unit. This feature can be changed over on the internet to allow for remote upgrades of the unit. The hardware classes are as follows:

1. Micro

2. Basic

3. Standard

4. Intermediate

5. Advance

6. Ultimate

Product Release

The product release section displays the function of the device connected. E.g. Engine control unit, Transmission Control unit etc. The Mercury2 hardware can be used with different firmware to control different applications like ECU, ECU, TXW etc. It is used by the software to identify if the correct firmware is connected.

Firmware Class

Displays the class of the firmware that has been downloaded onto the device. Each firmware program supplied will have a certain class according to the features used. You may load any firmware for a specific product into the unit as long as the firmware class does not outrank the hardware class. The firmware classes are as follows:

1. Micro

2. Basic

3. Standard

4. Intermediate

5. Advance

6. Ultimate

Program Number

Displays the current firmware program that has been downloaded onto the device. The program is identified by a program number and description. See the firmware list of programs for the ECU.

Protocol Version

Displays the current protocol version number between the firmware and the PC software. This must be the same for the hardware and software to communicate. The firmware will indicate to the software which version of the program to open.

Firmware Version

Displays the sub version of the current firmware that has been downloaded into the device. It is an alphabetic number and has no effect on the protocol version used. This version is used when corrective firmware is released. Always use the latest version available.

Program Restriction

Displays the Firmware number which the ECU is locked to. If it says No Restriction it means that any ECU program for that ECU can be programmed into the unit, provided it does not outrank the hardware class. If there is a number, it means the ECU is locked to a specific program and only that program may be loaded onto the unit. This is for sponsored or specials which was approved by the manufacturer.

On the top bar you will find the product software version. Note that version 3.5 will be standard with the Firmware version 3.6.

The first 3 is version 3 PC Software.

The second 3 is the protocol version between the PC software and the firmware. When new features are programmed into the unit, this protocol version will change in the PC software and in the Firmware.

The .0 at the end is a sub version and has no effect on the firmware. This version will indicate corrective or improved PC software. Always use the latest version available.


ECU Setup

Help > ECU Software Desciption >

ECU Setup

General Settings

or [image] Engine Settings

Timing Settings

Injection Settings

Sensor Settings

Turbo Settings

This blocks are where all the setup values for the ECU are grouped so that the tuner can setup his engine.

See the sub folders for explanations.


General Settings

Help > ECU Software Desciption > ECU Setup >

General Settings

See the sub folders for explanations.


Map Information

Help > ECU Software Desciption > ECU Setup > General Settings >

MAP Information

The Map information screen, Name Model and Engine, contains info for the ECU application for a specific vehicle. This helps the tuner to recognize previous work and tuning data. It is saved in the ECU and also in PC maps. It does not affect any tuning on the engine.

Map Number

The firmware can save up to 2 maps for different fuel setups or tuning algorithms. This is only an indication and the map cannot be forced on this page. This block is updated when the ECU is switched on. If no selection switch is connected, the ECU will default to Map 1. Note: The maps cannot be changed whilst the engine is running. The power of the ECU has to be cycled for the new Map to be loaded. The reason is the time it takes to load and populate a map in software will let the engine cut out. If you populate in real time settings of one map will be implemented momentarily on another map and then time and fuel values may be out of limits and damage an engine under load.

Save Setup Data

This feature is handy if you want to load a map to change the tuning graphs without altering the setup data. If it is on it will load the setup settings and the graph and matrix data. If it is off it will only load the graph and matrix data. Note: The critical settings and calibrations are not altered in map load. A useful tip is to leave this setting off. Any changes on the setup while the ECU is connected is saved as normal. This feature is permanently saved in the ECU and can only be changed on the screen when the ECU is connected. Note. Never load a map while an engine is running.

Dual Map Selection

The map loaded in the ECU is determined by the Dual Map Selection switch. Note that this block varies depending on the product used. For Mercury2 there are no specific input dedicated to the Map switch. An input that is not used in the ECU control can be selected for this feature. If all the inputs are utilized, then dual maps cannot be used. On Mercury2 you may select between Cam 2, Fuel Pressure input and Altitude input to be used for the Map selection switch. Pluto2 and Saturn has a dedicated input and this whole block will be blanked out. This switch is read at startup and the map cannot be changed during running. The ECU power has to be switched off first to implement the selection and then the switch will determine on which map the ECU will start. If the driver wants to change maps he simply through the switch and switch the ECU off and on again. Then if it started on map 2, the Map No will indicate 2 when the software is restarted. Press the upload button [image] to read the new map information. (See the wiring diagrams for info on the different wiring connections.)

NB!! The fuel sensor input requires a 1K pull-up resistor to 5V and not 12 Volt. This may damage the processor. The cam sensor may need a pull-up resistor due to the isolating nature of the input. Leave it as a last resort.

The Dual map switch only operate at startup. Om Mercury2 the switch then is used as Flat-Shift. This will momentarily cut the spark or fuel to enhance mechanical gear shifting. See the Flat Shift description in the Turbo Settings section.

Tuning Mode

This feature allows the tuner to select variations of tuning according to his skills. The firmware will enable more features as the level of progress is made and hide features on lower levels so that confusion for beginners is kept to a minimum.

Novice

This level is set up as the first generation of Spitronics ECU's. There are however new features which is explained further in the manual. This mode is used for graph tuning and were developed by Spitronics. It is also easier for road tune where a Dyno is not present.

Moderate

This level is more for tuners with Dyno facilities. Here the matrix tuning is present as well as the graph method for fuel and timing. There is also a selection for MAP or TPS tuning versus RPM. Included in this level is a mixture, possibly for racing engines with poor vacuum but with turbo chargers where MAP pressure needs to be compensated for. The tuner can select his preferred option. Note: The graph and matrix data uses its own memory space and both types could be tuned without losing the data on selection changes. This allows the tuner to tune both options and chose the best for his application.

Expert

This level is to assist the tuner to tune racing engines and different fuels where more refined parameters are required. Here parameters like Start Prime Pulse, Start enrichment, and the two Accelerator pump Enrichment values are tuned on a graph versus temperature. This is very useful for methanol cars also in extreme cold conditions when fuel does not ignite easy.

Related Links

Dual Map Switch Wiring


General Purpose Outputs

Help > ECU Software Desciption > ECU Setup > General Settings >

General Purpose Outputs

Output selection

Version 3.5 can handle up to 10 General Purpose (GP) outputs to configure for several different functions. These outputs can be configured to use any of the analogue signals to switch relays on or off when certain limits are reached. Due to the number of GP outputs this block was developed to be generic. That means there is a dropdown menu to choose which one is adjusted by the tuner. Not all firmware has the ability for 10 GP outputs so the number of selections may be limited. This depends on which features are activated in the ECU. Note the operating current and requirements of each product in the electrical drawings, so that damage to the ECU will not occur. See the GP Priority register and the wiring of the specific output for that ECU. Some drivers may be positive output and some negative output.

If an output is available, the software will show the location of the driver that is used with this GP output.

Should an output not be available the driver will be blank and the Output settings will be locked on not used.

Selections

The tuner has a number of selections to use in the GP output. Use the drop down menu to display the others.

Not used - this saves processor time

RPM - RPM/min 100rpm increments

Vacuum - pressure 0.1 Bar increments

TPS - percentage at 1% increments

Water temperature - degrees at 1°C increments

Air temperature - degrees at 1°C increments

POT value - percentage at 1% increments

Battery voltage - voltage 0.1volt increments

Altitude - pressure 0.01 Bar increments

Fuel pressure - pressure 0.1 Bar increments

Lambda - percentage at 1% increments

Timing - degrees at 1° increments

Injector - fuel at 0.1milli second increments

The GP outputs can be used in different ways.

First we do water temperature as it operates in a unique way on all the GP outputs. In this example we will setup the water temperature to operate the electrical cooling fans.

The water output will come on when the temperature goes above the Max setting at 98 degrees C and will stay on until below the Min setting at 92 degrees C. This will give the fan a dead band of 6 degrees before switching off.

All other types.

If tou want to use a GP output to switch on a shift light. The light must come on at 5000 RPM and switch off at 7000 RPM.

Note that the GP limits are only, 'bigger and smaller than'. This is to prevent shuddering due to a small dead band. This means if the light must come on and off on the rising limits, you may need to change the value a slightly. In this example on rising RPM's the output will come on at 5000 RPM and off on 7000 RPM and on falling RPM's it will come on at 6800 RPM and off on 4800 RPM. So the output is set on between the limits and off outside the limits.

If we swop the Min and Max settings around, (see below), it will change the logic to Off between the limits and On outside the limits.

V-Tech

There is one GP output, No2, that has the added V-Tech TPS limit added to the RPM setting.

In this method the output will switch on between the limits only if the TPS value is above 40%.

Note! If you don't use these outputs, select Not Used so that valuable processor time can be saved.

Related Links

GP Output Priority

GP Output Wiring


RPM Output

Help > ECU Software Desciption > ECU Setup > General Settings >

RPM Output

Pulses/RPM

This feature is used for Rev counter calibration. You can adjust the number of pulses per revolution for the RPM output. This is handy for engine conversions. A value of 1 to 60 pulses can be achieved with this function. On some firmware you may enter 61 which will then divert the crank angle signal onto the RPM output. This is also handy if the standard ECU is still live and doing other functions in the car. Note different electrical connections in the drawings to connect the different RPM gauges onto the Spitronics ECU.

This Auxiliary Values is used on certain firmware to achieve certain functions. It is only used in new development where the features were not yet developed in the Tuning Software. See the specific instructions for that engine type.

Related Links

Tachometer Wiring


Engine Settings

Help > ECU Software Desciption > ECU Setup >

Engine Settings

See the sub folders for explanations.


Engine Configuration

Help > ECU Software Desciption > ECU Setup > Engine Settings >

Engine Configuration

Engine Type

The ECU firmware will lock this selection for a Piston or Rotary engine. For Rotary it will enable a Trailing degree graph and also a Maximum trailing degree setting. For most firmware this block will be hidden.

Cylinders

Most ECU firmware will lock this selection for a specific number of cylinders. Other firmware like the standard unit will open this dropdown menu for the tuner to decide for which engine it is required.

Map Teeth (Gear Type Trigger Only)

This setting is used to synchronize the crank angle degrees where the manifold vacuum is sampled. This is very useful for engines with individual throttle bodies that has poor vacuum signal due to a common vacuum rail. This setting can be adjusted up to 180° of engine rotation after TDC. If it is a 36-1 gear as in this example, then 9 teeth will result in 90° after TDC. Start at 90° after TDC and adjust the teeth more or less at idling till the best vacuum signal is achieved. Start with the gear teeth divide by 4. For 60-2 it will be 15.

On multiple throttle bodies you only connect one cylinder to the Map sensor. It must be cylinder 1, or the one that shares the same TDC degrees with it. Do not use a common vacuum rail. Set the setting as below.

Map sensor

Spitronics have a selection of 4 Map Sensors to choose from. 1.1 Bar, 2.5 Bar, 3.0 Bar, 4.0 Bar and a Custom sensor option. Select the one that is supplied with the ECU. The most popular one is 2.5 Bar.

If you use an engine MAP sensor that is not standard with the 4 selection you may choose Custom and calibrate it yourself. Select the following.

Chose custom sensor and chose a map range. The range cannot be larger than the sensor capability.

Go to MAP sensor select and click the calibrate button.

Adjust the Offset value till the software reads the altitude at your level.

Click OK.

Map Range

Spitronics can use any MAP sensor to fuel even a normal aspirated engine. Note however, that it is best to use a sensor that is just higher than your maximum manifold pressure. It is more accurate because the sensor has better resolution over the 0 to 5-volt range. On this field you select the maximum boost pressure that you will use in the application. For example, if the engine is required to run at 0.8 Bar boost, select 1.9 Bar. This means at sea level you can run 0.8 Bar boost without running the tuning pressure off the scale. Making the scale too large will reduce valuable tuning space on the graphs or matrix. For normal aspirated engines always select 1.1 bar.

RPM Range

This setting is used to adjust the ranges of the RPM tuning graphs or matrix. Set it to a value of 500 RPM above the engine max RPM. If you use a higher value, you will reduce valuable tuning space.

Trigger Type

Selective firmware may let the user choose the crank angle sensor type. This program is written to minimise stock on the shelf for retail stores.

Two Stroke

This Setting will select between 2 or 4 stroke to correct the injector duty % indication bar. If it is on 4 stroke the injector time is calculated over 2 RPM's while on 2 stroke the injector time is calculated over 1 RPM. For example, on a split sequential setup, 10 milliseconds on 4 stoke means that the injector will inject 5 milliseconds each RPM to make up 10 milliseconds. While on 2 stroke 10 milliseconds will inject the full 10 milliseconds on each RPM. If you have an engine that does not rev high and the injectors are too small you may put it on 2 stroke to double the injector time. Note however, the injector duty % during tuning must not go over 100% as this will occur at a lower RPM. 85% Max is a recommended maximum duty cycle as the injector may stay open after that.

Engine Shutdown

This setting will select how the engine is shut down. Fuel first means that the ECU will run normally but stop injecting fuel when the key is turned off. This will let the spark burn all the unwanted fuel from the cylinder. That is handy for rotaries where the injectors are far from the intake valve. It may sound as if the engine keeps going for a moment after the key is switched off. Fuel & Spark cuts both immediately when the key is turned off. There may be unburned fuel on the cylinder but the engine dies immediately. Note: This feature is only available with Mercury2.

Related Links

Map Sensor


Timing Settings

Help > ECU Software Desciption > ECU Setup >

Timing Settings

See the sub folders for explanations.


Timing Configuration

Help > ECU Software Desciption > ECU Setup > Timing Settings >

Timing Configuration

Maximum trailing

This is for rotary engines and prevents the trailing degrees from being adjusted to far from the leading plugs. In piston engines this block is hidden.

Maximum Timing

This is the maximum combined timing allowed in degrees by all the timing maps combined. If the graphs are tuned for more degrees, it will be limited by this value. On the Timing Matrix this will also prevent the tuner from selecting higher values there.

Minimum coil time

This is the minimum charge time which the tuner can select. The ECU will vary the charge time automatically according to engine load from the minimum to the maximum value. It can be adjusted in 0.1 millisecond intervals from 1ms to 5ms. Standard coil setting is 2.0 to 2.5 milliseconds for coils of around 0.7 ohms but some new coils are lower resistance and may need shorter times. Normally the driver will heat up and may damage if it runs too hot. Always start with a min value if you are not sure. Always a good idea to put a 5-Amp fuse in the power line of each coil. If you go too high the fuse will blow.

Maximum coil time

This is the maximum charge time which the tuner can select. The ECU will vary the charge time automatically according to vacuum load from the minimum to the maximum value. It can be adjusted in 0.1 millisecond intervals from 1ms to 5ms. Standard coil setting is 2.5 to 3.5 milliseconds for coils of around 0.7 ohms but some new coils are lower resistance and may need shorter times. Normally the driver will heat up and may damage if it runs too hot. Always start with a min value if you are not sure. Always a good idea to put a 5-Amp fuse in the power line of each coil. If you go too high the fuse will blow. During cold starting, this value is used till the engine reaches 60°C. thereafter spark control will commence.

Vacuum Timing Split

This value sets the RPM split between the Low & High Vacuum Timing maps. This value is selected about 500 to 1000 RPM's above idling.

Altitude comp.

This value sets the timing advance ratio for every 1000 meter above sea level. A value of 3 means that the timing will be advanced by 6 degrees at 2000 meter above sea level. If you tune the vehicle at a higher altitude, make sure this value is set. Then when the driver descends to lower altitude the ECU will retard the timing automatically.

Related Links

Tuning


Crank and Cam angle sensors

Help > ECU Software Desciption > ECU Setup > Sensor Settings > Active Sensors >

Crank and Cam angle Sensors

These inputs are required by the ECU to determine exact crank and cams angles so that spark and injection timing can be calculated. VVTI cams can be positioned by the ECU. Their cam signals will be compared to the crank signal to determine the right position for loop control. Version 3.5 can only do open loop cam control. The firmware may blank out or force the signals in a state depending on the specific engine.

Crank (TDC)

The crank angle sensor is used by the ECU to determine exact crank degrees as it rotates. This sensor could be situated on the crank or in a distributor or encoder called a CAS. If it is situated on the cam gear like a distributor, then it will have enough pulses for 2 revolutions to represent the crank signal. For example, Toyota uses what we called a 24+TDC pattern. If the sensor is on the crank there will be 12 teeth. If it is on the cam there will be 24 teeth. If a pulse is generated on a 36-1 gear on a crank for example, then the missing tooth is used as a TDC pulse. A TDC pulse represent a signal that comes once every revolution. It is not necessary at TDC of the engine. In a distributor it may have a TDC pulse or Home pulse. If a pulse come once in two revolutions it is called a a home pulse.

The crank sensor has a test function. Each firmware file is programmed for a specific sensor pattern. The test function will activate a test procedure of the crank sensor pattern during cranking, to ensure that it is read correctly. If it is incorrect or has the wrong firmware, the software will show errors and not attempt to start the engine. In this mode the ECU will do two revolutions of the crank sensor before starting the engine if the trigger pattern is correct. These Errors have numbers indicating a fault code and description. This is a very useful feature for first time startup after the installation is done. See Setting Crank Sensor Timing below. Note. After setup put the test faction off. It may bother at high RPM's due to the calculations to determine correct patterns.

Cam (Home)

The cam angle sensor will always be situated on a cam shaft. It could be a lone sensor in the valve cover or in a distributor. This signal only came with later models when full sequential injection was introduced. Some distributors like Nissan and Toyota had both sensors in the distributor. The cam signal will give a unique pattern over two revolutions, allowing the ECU to detect which revolution is the firing stroke. This signal could be one pulse or a number of pulses. The ECU can compare it with the crank signal pattern and determine firing stroke.

This feature is incorporated in the new version 3.5A firmware to determine a home pulse position from different cam signals. Each manufacture uses a different cam pattern. One of the cam sensors must be connected to the ECU and selected. During setup, start with teeth 1 and crank the engine. It should show missing home pulses on the error codes. Increase the value and press C for clear after each adjustment. If the error stops appearing, at for example 4, then continue increasing till you see the error again. If the value is 10, for example, then set the teeth setting in the average of 7 teeth. Now the ECU knows the difference in stroke 1 and stroke 3 of the engine. One will have a pulse within 7 teeth after the slot and 3 will have no pulses.

Cam 1&2 (VVTI)

These cam angle sensors shift in relation to crank signal when the cam is advanced or retarded. The ECU uses it to determine if the cams are in the right advanced position. Ver 3.5 does not use them as it controls in open loop.

Crank angle signals also have a rising or falling edge selection. This will indicate to the ECU on which edge of the pulse to start calculations. On magnetic type sensors there is a positive and a negative wire. If it is wired incorrectly, the tuner may select the rising or falling edge in software without the need to change the wires around. The best is always to measure the sensor and determine the positive and negative sides of its wires and then wire correctly according to the drawing. This is useful, if you require so, to swop ECU's with similar engines to test them. Always wire for falling edge transition.

On a Hall sensor it must be wired correctly. Certain encoders my use the rising or falling edge of the signal. The reason is that the signal varies in length but a certain edge is used which is equally divided into crank angle degrees. Note, however, that the Hall sensors do require a pull-up resistor to work correctly. This is selected by jumpers.

The Mercury2 ECU angle signals goes through isolating capacitors giving it the ability to tap into existing magnetic angle signals. See the wiring diagrams and make sure you use the correct wire. The reason is there is always a reference wire that is ground from the Mercury and also a 12V signal that is required for the Hall or optic type sensors. When tapping into a sensor do not connect the Mercury2 reference wire or power wire to the existing sensor, only the signal wire. Connecting two reference wires together which are at different voltage levels will damage the ECU's. Pluto2 and Saturn will require these isolating capacitors.

Setting Crank Sensor Timing

This block is used to indicate to the ECU where the exact TDC point is on the crank. It works differently for the different style of crank angle sensors. These settings will allow the ECU to synchronize software timing with the actual spark timing on the engine.

On gear type trigger wheels, the Gear Teeth will indicate to the ECU the amount of teeth between the slot and TDC. The Timing Sensor will do finer adjustments to precisely set the timing in-between the teeth.

The example below explains, if you put the engine of a 36-1 trigger wheel on TDC, count the number of teeth from the slot anti clockwise to the pickup sensor plus the one just past the sensor. Put this value in [image] . Then you may adjust the Timing Sensor [image] from 0 to 9 degrees to precisely align the timing light to the tuning software. The example below should work out as Gear teeth 7 Timing Sensor 6 as the last edge of the teeth is in the center of the sensor.

With the engine running match the timing as close as possible by using the Gear teeth setting. For example; the ECU software indicates 10° advance on the real-time bar, but you see 12° advance on the engine. The Timing sensor °BTDC will now be adjusted to accommodate the difference which is 2. With the Timing sensor adjusted the Timing light and the ECU should now be matched.

Important!
When using an Advance / Retard timing light on a wasted spark system the timing light will read double the timing of the engine. So if the timing light reads 20° advance, the actual ignition timing is 10° advance. If you are not sure rather put the timing light on zero degrees and use the pulley marks. Remember that the COP systems are still fired in wasted spark sequence.

On single event triggers you will find that gear teeth are not adjustable only the degrees between the triggers. On a 4Cyl Nissan for example the timing sensor may be adjusted to 180 degrees.

Related Links

Crank and Cam angle Sensors

Error Codes


Timing Calculation

Help > ECU Software Desciption > ECU Setup > Timing Settings >

Timing Calculation

This block will allow the tuner to choose different options to set up timing for this engine. Each of these methods will be discussed in detail under the tuning chapter further in the manual. Note that this block is changed by setting the fuel calculation block. Both time and fuel calculating algorithms must be the same. The fuel setting is the master. You can see the Tuning section for detailed description on the tuning side.

Graph MAP

This method is for standard engines with a good vacuum signal and it allows for easy tuning in the street. It has a Dynamic timing map on top which is tuned at WOT. It has 2 vacuum tuning maps for pull-off and cruise timing adjustments.

Graph MAP+TPS

This method is used for engines with a poor vacuum signal at low RPM's and it still allows for easy tuning in the street. The ECU will use the TPS signal to calculate a MAP signal at low RPM's when there is no or little vacuum. It is used for engines where the vacuum signal is correct and above 1500RPM's. The graphs are the same as above with the addition of the following settings:

When the RPM's is below the RPM fuel cut off, then TPS idle is activated. The Vacuum Fuel Cut off setting then becomes the minimum manifold pressure value to start off from.

The TPS gain value will use the TPS signal to calculate a projected vacuum signal on the graph. When the actual vacuum is below the calculated vacuum then the ECU will use the lowest vacuum signal of the 2. Once RPM's are above the RPM fuel cut off, then TPS idle is de-activated.

Matrix MAP

This is for standard engines with a good vacuum signal and allows for easy dyno tuning. Here the MAP sensor versus RPM is used and the blocks are set in 1-degree resolution.

Matrix TPS

This is for normal aspirated engines with poor vacuum signal or throttle bodies and allows for easy dyno tuning. Note: It is recommended to add the altitude sensor to compensate for altitude pressure changes. TPS versus RPM does not compensate for pressure changes. Here the TPS sensor versus RPM is used and the blocks are set in 1-degree resolution.

Graph MAP + Matrix TPS

The Matrix is the same as TPS Matrix above. This is for turbo racing engines with a good or poor vacuum signal and allows for easy dyno tuning. Note: It is recommended to add the altitude sensor to compensate for altitude pressure changes in the TPS matrix. Here the normal aspirated tuning is done on the matrix and the boost timing tuning is done on the two Cruise timing graphs. They will become visible in this mode. Here the TPS sensor versus RPM is used on the matrix and the blocks are set in 1-degree resolution. Then Map sensor is used to modify timing in the cruise graphs.

Related Links

Tuning


Coil Combination

Help > ECU Software Desciption > ECU Setup > Timing Settings >

Coil Combination

This block indicates the type of coil combinations that can be used with this firmware. Some firmware programs will allow the user to select between the different coil combinations on his engine. Note: If you have an intermediate or lower hardware class ECU, you may only use single coil with distributor. Most COP coil per cylinder engines are fired in wasted spark configuration and each coil will have its own driver. The Pluto2 and Saturn with internal drivers can fire single coils for 4 Cylinder engines. Mercury2 does not have built in coil drivers so for COP systems the driver output is split to 2 coil drivers. (See the wiring diagrams for connections.)

The combo files can be loaded into intermediate or advance ECU's. In an intermediate ECU only the single Distributer option will be available. In an advance ECU the tuner my select between single and wasted spark.

Note! On the Rotary programs the tuner may select between coil per cylinder or wasted spark. If the engine has the three coil setup where the leading spark plugs are on a wasted spark coil and the trailing are on coil per cylinder, this value is set on wasted spark. The two leading coil trigger wires must be tied together on the wasted spark coil negative. (See the connection diagrams). The charge time for the leadings will combine without overlapping and destroying the coil. Note that on high RPM's the leading spark will become weaker due to less time available to charge the coil. It has to charge twice per revolution.

Dual distributor
Two ignition coil outputs will be activated and phased to run a dual distributor system as found on the Lexus 1uz-fe and BMW V12,

Single distributor
Only one ignition coil output will be activated and phased to run a single distributor. Old school engines use these types.

Wasted spark coil pack
Coil outputs equal to half the number of cylinders will be activated to run a wasted spark ignition coil. This is a very popular choice on smaller engines. Mercury2 will use this setup mostly and combine drivers on the outside to cater for COP systems.

Wasted spark coil per cylinder
Coil outputs equal to the amount of cylinders, will be activated to COP coil per cylinder. They are fired in wasted spark sequence. Pluto2 and Saturn can do COP coils up to 4 cylinders.

Full Sequential coil per cylinder
Coil outputs equal to the amount of cylinders will be activated to coil per cylinder. They are fired in full sequential mode. This requires a home pulse from a cam signal. This is the preferred method for NOZ systems that has fuel in the intake manifold.

Note that the last COP systems has no performance difference as both types will have a full load on the coil so spark is the same energy.

Related Links

Ignition Coil Wiring


Coil Driver Selection

Help > ECU Software Desciption > ECU Setup > Timing Settings >

Coil Driver Selection

This block selects the type of coil driver used by the ECU. If it has internal coil drivers like Pluto2 and Saturn, the installer may choose to select Internal or External drivers. The Mercury2 unit does not have internal drivers so it will default to External configuration and this block will be hidden. Note: You will need a pull-up resistor on each driver with the external selection. (See the wiring diagrams).

Note that the coils must get their power from the ECU power relay. At startup this relay is kept off till the ECU can read the map to see what type is selected. Having this wrong will destroy the drivers or the coils.

Internal

This is for coils with no electronic drivers. We call them basic or dumb coils. They have a resistance of around 0.8 Ohm and must be protected by the ECU from overcharging. Charging occurs between 1 and 5 milliseconds and maximum currents of around 6 Amp are fully charged. These coils normally have two wires and occasionally a screen ground for the iron core or one point of the high voltage side. Mercury2 cannot drive these coils directly and require an external coil driver or ignitor.

External

This is for coils that have built in electronics or intelligent coils and requires only a trigger pulse to charge and discharge the coil. In this case there must be a 220 Ohm 10 Watt pull-up resistors installed on each driver. This is due to the internal driver of Pluto2 or Saturn that can only output a ground signal. The older F10 firing modules from Spitronics has these pull-up resistors built in and they are used with the Internal setting. The Mercury coil drivers that are sold with the Pluto2 and Saturn nowadays does not have them and require the External setting. These coils normally have 3 or more wires. Ground, 12-volt power and trigger pulse. Most of them also have a misfire detection wire for the OEM ECU.

It is very important to do this selection before the coils are connected and powered up. This is due to an inverted trigger pulse between the 2 options. If you have it wrong it may destroy the driver and / or ECU. As an added security this setting requires confirmation to change in the ECU.

Note that this setting will not change with loading maps. It has to be done on the ECU. If you clone a device always check these settings before you connect the coils to the system. Read the instruction carefully before selecting Yes or No.

Related Links

Ignition Coil Wiring


Injector Settings

Help > ECU Software Desciption > ECU Setup >

Injector Settings

See the sub folders for explanations.


Fuel Configuration

Help > ECU Software Desciption > ECU Setup > Injector Settings >

Fuel Configuration

Start enrichment

This value will help an engine to stabilize after starting. This amount will be added to the injector time after the engine is started and reaches 500 RPM. It will then be phased out in a couple of revolutions. This value is also compensated with the water temperature %, and is not active in Expert mode. Then the Water Temperature graph is used. The value is set in milliseconds. In Expert mode this value for Start Enrichment will be blanked out and the graph value for that temperature interval will be used. See the graph sample below.

Maximum fueling

This setting is to protect against over fueling from all the graphs with accelerator pumps etc. It will limit the final injection time to this value if it is higher. This value can be calculated as the time it takes 1 revolution for 2-stroke engines, or 2 revolutions for 4-stroke engines. The calculation for 4 stroke engines at 7000RPM is seconds=60 * 2 / Max RPM=120/7000 = 0.017 = 17 milliseconds. For a 2 stroke it at 7000RPM is seconds=60 / Max RPM = 60/7000 = 0.085 = 8.5 milliseconds. The recommended injector time is 85% of that value which results in 14 and 7 milliseconds respectably. If your duty cycle of the injectors at full load max RPM reaches over 85% you may have to go for larger injectors or increase the fuel pressure to maximum safe pressures. On the Fuel Matrix this will also prevents the tuner from selecting higher values there. This value is set in milliseconds.

Start prime pulse

This setting is to assist in the starting of the engine. When the engine starts to crank and reaches 100 RPM a set amount of fuel is injected on all the injectors to get the first one with spark to ignite and turn the engine. A colder engine requires more initial fuel to start. This value is also compensated with the water temperature and is not active in Expert mode. Then the Water Temperature graph takes over this value. In Expert mode this value for Start Prime pulse will be blanked out and the graph value for that temperature interval will be used. Note that this value is x10 so 6.4 is 64 milliseconds. See the graph sample below.

The Spitronics ECU's have a manual prime function where you can press the accelerator pedal before starting to inject fuel in the system. This fuel is measured at 50% of the start prime pulse setting. It is injected each time the throttle is pressed more than 25 % opening.

Should the engine be flooded, you may keep the pedal fully pressed to the floor during cranking. This will indicate the ECU to cut injectors and only provide spark. Press the throttle in all the way before putting the ignition on. It will prevent the prime pulse from injecting more fuel when the pedal is pressed. Once the engine starts release the pedal and then injection will commence as normal.

Vacuum fuel cut off & RPM fuel cut off

This feature is useful in town and downhill driving and will save fuel. It will let the engine run against compression as you are decelerating. It will also prevent flaming in the exhaust during accelerator blip. Injectors will be cut when the MAP sensor value is below the vacuum setting and the engine RPM is above the RPM setting. There is a dead band feature built into these settings to prevent jerking when cruising close to the parameters. If you feel a jerk when the feature is activated or deactivated, adjust these settings till it changes over smoothly. This is normally where the change from positive to negative drive on the prop shaft is.

Injection teeth

This feature adjusts the start injection degrees. It is only available on gear type triggers as low as 12 teeth per revolution. Normal injection timing starts just after the intake valve closes. The warm valve helps atomizing the fuel and makes the engine use less fuel. Put the engine on the degrees where you want to start injection. Count the number of teeth from the slot or missing teeth in the gear, in an anti-clockwise direction, to the sensor. If the pickup is in the slot imagine the tooth there and count it as well. Even if it is 60. The firmware will move injection in the slot to the closest teeth as this is not as critical as spark timing. You may change this value during tuning to see if you get better atomization and performance increase. Usually this is best seen at idle. Find the spot where it runs rich and make idling leaner. Start with low teeth and move to larger numbers to see when the valve closes. It will go rich at that point.

TPS Gain

This setting will adjust the rate at which the TPS sensor will move the MAP bar to the right of the graph during Graph Map + TPS calculation mode. This will simulate a MAP signal and the gain adjustment will produce the right amount of fuel during pull-off. (For further details see the tuning section).

Related Links

Tuning


Throttle Selection

Help > ECU Software Desciption > ECU Setup > Injector Settings >

Throttle Selection

This setting is developed to use a MAP signal on multiple throttle body engines. The problem with them is there is no intake plenum where the vacuum could be measured. The vacuum signal only makes a spike when the valve opens. This spike is also there only once in two RPM's. This makes it important to read the signal on crank degrees when the vacuum signal is present. This setting is only available for gear type triggers as low as 12 teeth.

Single

Most engines have one throttle and an intake plenum where a map sensor is used. The map signal is read 2 or 3 times per revolution. It makes for a fast vacuum signal response. The map teeth can still be adjusted here as there is a small amount of pulsation in the intake plenum.

Multiple

To use this method a crank gear of min 12 teeth is required. The MAP sensor is only connected to cylinder 1 or the cylinder that shares the crank degrees on movement. With this feature the MAP sensor is read once per two RPM's when the vacuum signal is present. This makes for a slow response that may cause flat spots during blip. This however can be cured with the accelerator settings. One requirement is that the throttles are properly balanced as only one's vacuum is measured. The map teeth setting here is very important. When the engine idles it is adjusted to read the best vacuum. The more teeth on the crank gear the finer adjustment could be made to find the sweet spot. This sweet spot on the vacuum signal is around 90° after TDC. For a 36-1 gear 90° would be 9 teeth.

Related Links

Tuning


Accelerator pump tuning

Help > Tunning >

Accelerator pump tuning

Accelerator pump selection

The accelerator pump setting is used to richen the fuel mixture when accelerating to avoid flat spots or bog. Here you can select not to use it, use either the TPS or MAP or both signals. Below is the selections to setup each pump for TPS and MAP.

Enrichment %

This is the amount of fuel that will be added momentarily when the accelerator pump is activated. This value is divided by the number of strokes and each stroke the value is reduced by the division value. It will start with 10 and reduce to zero so that fuel is gradually reduced. This value is also compensated with the water temperature graph value. In Expert mode this value for MAP and TPS will be blanked out and the graph value for that temperature interval will be used. See the graph sample below.

Sensitivity

The activation sensitivity can be adjusted from 1 to 10. The lower the value, the more sensitive the accelerator pump will be. If the accelerator pump is set too sensitive it will activate randomly and cause the vehicle to over fuel. Rather keep the activation sensitivity as high as possible to avoid this from happening. For the TPS signal this value can be lower as it is more stable than MAP value and it reacts faster.

Max RPM

This is the maximum RPM that the pump settings will be active. At high RPM you do not need an accelerator pump. A standard is 1500 to 3000 RPM for TPS and 1500 to 2200 RPM for MAP. If a value was initiated before this limit was reached it will finish the decay cycle.

Strokes

This is the number of engine strokes that the fuel must be applied to and then decayed over the amount of cycles. If it is a 4 cylinder engine, a value 0f 8 will inject 4 full revolutions of fuel. There are two firing strokes per revolution. If it was a 6 cylinder engine, a value 0f 12 will inject 4 full revolutions of fuel. Always tune for the lowest value to eliminate flat spots. If a value of example 10 is selected it means that the enrichment amount will be decayed by a tenth every cycle till the tenth stroke.

Related Links

Error Codes


Injection Type

Help > ECU Software Desciption > ECU Setup > Injector Settings >

Injection Type

This setting will allow different methods of fuel injection. The firmware in the ECU will blank out the methods that are not adjustable. In some firmware a refresh will be forced to reshuffle GP outputs or cancel an illegal setting.

Batch Injection

This method all the injectors are pulse at the same time. It is not good practice as the cylinders does not get the fuel under the same conditions or injection angle, and is poor on power and economy. Spitronics programs does not use the feature unless for specific tasks.

Split Batch Injection

This method will pulse two sets of injectors 180° apart from each other. It is used where the trigger has even pulses and no cam signal is present. It is used on the standard systems where budget is of importance. For a 4 cylinder, the injectors are paired so that each cylinder gets fuel under the same condition or injection angle.

Split Sequential Injection

This method will pulse two injectors per driver together for the two cylinders that move at the same crank degrees. It will follow the sequence of the firing order. There may be 2 to 6 drivers in the sequence. The injector will pulse once per revolution and the injection time on the software will be divided in two. With other words for each revolution only half the calculated fuel is injected. This method does not require a home pulse and is the popular choice. There is very little difference in power and economy to a full sequential system.

Full Sequential Injection

This method will pulse one injector per driver in the same sequence as the firing order. The injector will pulse once every two revolutions and it will inject all the fuel in one squirt. Here a cam pulse or home signal is required to sink the injectors with a certain stroke one the engine. If there is no home pulse it will still do full sequential injection, but stroke phasing may vary from start to start. Note that an engine is normally started in split sequential mode and then goes over to full sequential after 500 rpm is reached. This helps for faster starting. This feature is mostly for Mercury2 which has enough drivers for engines up to 8 cylinder. Here specific firmware needs to be developed for each engine due to the cam signals type and position.

Related Links

Injector Wiring


Fuel Calculation

Help > ECU Software Desciption > ECU Setup > Injector Settings >

Fuel Calculation

This block will allow the tuner to choose different options to set up timing for this engine. Each of these methods will be discussed in detail under the tuning chapter further in the manual. Note: Setting this block will also set the Timing Calculation to be the same. Both spark and fuel must be tuned the same method. You can see the Tuning section for detailed description on the tuning side.

Graph MAP

This is for standard engines with a good vacuum signal and allow for easy tuning in the street.

Graph MAP+TPS

This method is used for engines with a poor vacuum signal at low RPM's and it still allows for easy tuning in the street. The ECU will use the TPS signal to calculate a MAP signal at low RPM's when there is no or little vacuum. It is used for engines where the vacuum signal is correct and above 1500RPM's. The graphs are the same as above with the addition of the following settings:

When the RPM's are below the RPM fuel cut off, then TPS idle is activated. The Vacuum Fuel Cut off setting then becomes the minimum manifold pressure value to start off from.

The TPS gain value will use the TPS signal to calculate a projected vacuum signal on the graph. When the actual vacuum is below the calculated vacuum then the ECU will use the lowest vacuum signal of the 2. Once RPM's is above the RPM fuel cut off, then TPS idle is de-activated.

Matrix MAP

This is for standard engines with a good vacuum signal and allows for easy dyno tuning. Here the MAP sensor versus RPM is used and the blocks are set in 0.1 milliseconds resolution.

Matrix TPS

This is for normal aspirated engines with poor vacuum signal or throttle bodies and allows for easy dyno tuning. Note: It is recommended to add the altitude sensor to compensate for altitude pressure changes. TPS versus RPM does not compensate for pressure changes. Here the TPS sensor versus RPM is used and the blocks are set in 0.1 milliseconds resolution.

Graph MAP + Matrix TPS

The Matrix is the same as TPS Matrix above. This is for turbo racing engines with a good or poor vacuum signal and allows for easy dyno tuning. Note: It is recommended to add the altitude sensor to compensate for altitude pressure changes in the TPS matrix. Here the normal aspirated tuning is done on the matrix and the boost tuning is done on one Fuel Load graph. It will become visible in this mode. Here the TPS sensor versus RPM is used on the matrix and the blocks are set in 0.1 milliseconds resolution. Then Map sensor is used to modify fuel under boost. Notice how there is no fuel if there is no boost. This fuel is calculated as % boost compensation.

Related Links

Tuning

Injector Wiring


Injector Trim

Help > ECU Software Desciption > ECU Setup > Injector Settings >

Injector Trim

This feature allows the tuner to trim each injector individually for the ultimate performance. This is done by individual Lambda or EGT sensor on the exhaust runner to measure individual air fuel ratios. It is only selected Mercury2 firmware that has this feature.

Trim Count

This is the number of drivers selected by the tuner. The Mercury2 has 8 injector drivers and can work full sequential for 8 cylinders. At can also run duel injectors full sequential for 4 cylinder engines. A setting of zero will disable this feature.

These tuning blocks allow the tuner to adjust the register from 90.0 to 110.0 % for each cylinder. Adjustments can be made in 0.5 % resolutions.

This block is to clear all the registers to 100.0 % to start with. First tune the engine is as good as possible, then do minor changes here to calibrate the injectors. A tip is to use the middle average of the injectors ant tune to that. Example if the injectors differ by 10 % between high and low. Then use the middle vale and some will be 5% high and some 5% low.

Related Links

Tuning

Injector Wiring


Sensor Settings

Help > ECU Software Desciption > ECU Setup >

Sensor Settings

See the sub folders for explanations.


Active Sensors

Help > ECU Software Desciption > ECU Setup > Sensor Settings >

Active Sensors

This block lets the tuner select the different sensors that he requires for his application. Not all the sensors are used but each one has different features that makes the engine perform at its best. If a sensor is not used, leave the block unchecked. This will free up valuable processor time. Also make sure the wiring to that sensor is properly isolated as there is power on the leads that could short circuit and damage the ECU as a result. Some of the sensors cannot be altered or will be forced on by the firmware.

Calibration

Some of the inputs can be calibrated by clicking on this calibrate button next to it. This allows for a wider range of sensors to be used and calibrated in the software.

See the sub folders for explanations.


TPS

Help > ECU Software Desciption > ECU Setup > Sensor Settings > Active Sensors >

TPS Sensor

This sensor indicates to the ECU what the driver wants to do. It is also used for many features in the ECU, such as fueling, accelerator pump, idling control, fuel cutoff, cam control, automatic transmission control, etc. It is possible to control the engine without this sensor but with limited drivability. If there is a TPS sensor on the engine, rather connect it. If not, un-select the check box and isolate the wiring.

For the ECU to operate correctly this sensor needs to be calibrated. Note: When pressing the throttle while calibrating, the Fuel Prime function may squirt some petrol on the cylinders. You may disconnect the P2 and P3 connectors so that these functions will have no effect.

Click on the Calibrate [image] button left of the TPS check box and do the following procedure:

The TPS value must increase with throttle depression. If it is decreasing, click on Polarity to select Negative. This feature is normally used where the original ECU is still connected and wiring cannot be altered. In this case you connect only the ECU TPS signal wire to the OEM signal wire. Do not connect the ground or 5-volt signal wires but isolate them to prevent shorts. Now click the Calibrate button. The current TPS value will be written into the two blocks Min and Max.

Press the fuel pedal in completely and release the pedal completely. The Min and Max values will be indicating the range of the TPS. Click the Save button. You may now test the TPS signal by pressing the pedal in and releasing it. The TPS real time value should operate from 0 to 100%. Then click on the 'Save to ECU' [image] button to make the changes permanent.

Show Graph

This checkbox will enable the TPS compensation graph [image] . With this graph it is possible to add fuel % with the TPS position. It is handy to enrich the fuel mixture at full throttle conditions. There is no timing compensation for this graph.

Related Links

TPS Sensor Wiring

Error Codes


MAP

Help > ECU Software Desciption > ECU Setup > Sensor Settings > Active Sensors >

MAP Sensor

This sensor measures the MAP (Mean Absolute Pressure) in the intake plenum. This is the main sensor for the ECU to calculate the fuel amount which is injected into the engine at different conditions and load requirements. This sensor, however, does have its shortcomings when it comes to engines with overlap cams where the intake vacuum falls away at low RPM's. Then the ECU need to rely on other type sensors like TPS or Mass volume in conjunction to air temperature, altitude and RPM's. For multiple throttles this sensor also is inadequate but there is a feature that the ECU can use to remedy this. (See multiple throttle bodies.)

This 'calibrate' button will only appear when the custom sensor is selected.

Only custom sensors can be calibrated. Click on it to adjust calibration.

If you click calibration this block will appear. The offset value will change the MAP reading. Adjust it to read the same as the barometric pressure of your altitude above sea level. Note: Remember to take temperature into account.

The Filtered checkbox can be used to smooth an erratic map sensor signal. It will average the current sample with the previous sample. The down fall is that it may create a minor flat spot under blip conditions. This needs to be corrected with the accelerator pump feature.

The sensor must to be set up correctly by selecting the Type and range under Engine Configurations.

Calibration is done in the firmware.

If the sensor is not used, uncheck it to free up valuable processor time.

Related Links

MAP Sensor Wiring

Error Codes


Altitude

Help > ECU Software Desciption > ECU Setup > Sensor Settings > Active Sensors >

Altitude Compensation

The ECU can compensate for altitude differences in pressure. It will adjust the fuel mixture and the timing in relation to altitude. Pluto2 and Saturn has an optional On-board 3 Bar MAP sensor which can be used for altitude. This is optional and has to be ordered separately. The Mercury2 can do Altitude compensation by wiring an external 1.1 Bar Map sensor onto it.

Select Altitude and click on Compensate. The Altitude sensor is pre-calibrated. You do however need a 1.1 Bar MAP sensor for external sensors unless the 3 bar sensor on board is used. The real time bar below will indicate the actual altitude pressure of your surroundings.

Fuel Compensation

This feature works differently for the different tuning methods. Below are descriptions of operation in each method.

Graph Map tuning - Normal Aspirated

This scaling feature is only for normal aspirated engines where the map range is set at 1.1 Bar. The ECU will calculate altitude in the background and rescale the MAP sensor value so that the map bar always reaches full scale at all altitudes. This is important because the normal MAP sensor will not reach the maximum scale on the tuning graph at high altitude. Put another way, full scale on the graph will always be compared to available altitude pressure outside.

In a typical Fuel Load graph for example, an engine that was tuned at sea level where the MAP sensor reached 1 Bar, will only reach 0.83 Bar at around 2000 meters above sea level. The full load fuel compensation that was set to be richer above 0.9 bar will not be reached. The ECU will then not have the advantage of the full curve that was mapped out during tuning.

Engine tuned at sea level up to 1 bar only reach 0.83 bar at 2000 meter. Note: The bar will not pass the red bar and take advantage of the WOT rom compensation graph or the extra hump in the full load graph above 0.9 bar.

In the above example the injector time was 11.9 milliseconds.

When compensation is checked by the ECU will it compare the available air pressure in the air cleaner with the actual pressure in the intake manifold. It will then scale the MAP sensor to read 1 bar when the value reaches the same value as the altitude sensor. (See the example below.)

The dark blue bar is the altitude value and the olive bar is the map value. Note how the MAP sensor is now reading 1 bar at 2000 meter.

Notice the difference in fuel due to the hump on the right hand side. Now the ECU still has the advantage of the graph profile even at high altitude.

Matrix Map - Normal Aspirated

The same system applies for the Matrix Map tuning as Matrix Graph tuning. They both operate the same way except that it is a matrix. Read the above section for explaining purposes.

Graph Map tuning - Boosted Engines

In this tuning method altitude compensation is disabled. The reason is that you are already using a MAP sensor and measuring the manifold pressure. Fuel and time is set accordingly and does not require additional altitude compensation.

TPS Matrix tuning

This is for normal aspirated racing engines where TPS versus RPM fueling is used. The altitude sensor becomes very important as RPM versus TPS cannot compensate for altitude pressure differences. The ECU will adjust calculated fuel in ratio with altitude pressure differences to ensure a more accurate fuel mixture. For example, 10% less altitude pressure will result in 10% less fuel. The TPS versus RPM tuning is normally for engines with throttles or poor vacuum signal due to overlap camshafts. You need to activate the compensation values before tuning an engine. Even if you are inland at high altitude. The ECU will tune with the reduced fuel so that when you descent to sea level, the fuel will be added.

Graph MAP with TPS Matrix tuning

This is for boosted racing engines where TPS versus RPM fueling is used with a boost pressure graph. The altitude sensor becomes very important as RPM versus TPS cannot compensate for altitude pressure differences. The ECU will adjust calculated fuel in ratio with altitude pressure differences to ensure a more accurate fuel mixture. For example, 10% less altitude pressure will result in 10% less fuel. This altitude compensation is done on the TPS matrix and then is compensated with the boost graph. The TPS matrix and boost graph tuning is normally for turbo engines with poor vacuum signal due to overlap camshafts. You need to activate the compensation values before tuning an engine. Even if you are inland at high altitude. The ECU will tune with the reduced fuel so that when you descent to sea level, the fuel will be added. For detailed explanation see the Graph MAP and Matrix TPS Tuning section.

Timing Compensation

This feature is available and operates the same in all the tuning modes. If you don't want it to affect your timing, make the value 0.

Under Timing Settings set the Altitude Comp to 3 degrees per 1000 meter.

With timing compensation, the ECU will gradually add timing with increased altitude. The tuner can select the number of degrees' advance per 1000-meter increase in altitude. In this example we used 3 degrees which results in 1 degree for every 333 meters. Note: This will advance the calculated timing in total. There are no extra graphs to tune.

You need to activate the compensation values before tuning an engine. Even if you are inland at high altitude. The ECU will tune with the added degrees so that when you descent to sea level, the timing will be retarded.

Related Links

Altitude Sensor Wiring

Error Codes


MAP/Alt Swop

Help > ECU Software Desciption > ECU Setup > Sensor Settings > Active Sensors >

MAP_Alt Swop

This function is for Pluto2 and Saturn to swop the external MAP sensor with the onboard Altitude sensor. This will enable the tuner use the On-board 3 bar sensor for a MAP sensor instead of an altitude sensor. It will also allow the altitude sensor to move to the external input.

On Mercury2 both sensors are external and the altitude sensor must be a 1.1 bar sensor. This feature is blanked out.


Water Temperature tuning

Help > Tunning >

Water Temperature tuning

The water temperature sensor is used mainly for cold start compensation with fuel and spark timing graphs. There is however a couple of functions that requires compensation with temperature like idle control, accelerator pump, prime pulse etc. Neglecting to wire the sensor in may result in the engine not being drivable when it is cold. All fuel injected engines have water temperature sensors mounted in the thermostat housing area. Not all are compatible with the Spitronics ECU but there are aftermarket sensors that can be fitted. Spitronics ECU's use a 2K NTC (Negative Temperature Co efficient) resistor. It is the standard under water sensors for most engine manufacturers. It has a fixed calibration curve which is programmed in the firmware and it cannot be altered. It can however be slightly calibrated by giving it an offset percentage. The normal setting is 100%. Click on the calibrate [image] button left of the Water sensor check box.

Reduce or increase the value to slightly shift the reading value. Do this at the critical temperature for instance where the fan must come on or off. If the error is too large you may need to replace it or get the correct sensor. These sensors are measured at 25°C with an ohm meter to see which type it is. If you have the wrong type you may need to change the sensor to a 2K sensor. Save to ECU [image] button will make the changes permanent.

You may be required to do adjustment tuning in the winter and then in the summer. Remember to enable it on the active sensors page. When the engine is used in the winter, you may advance the timing slightly as the fuel burns at a slower rate. The fuel must be increased till the engine runs properly. Especially for racing fuel It may even require a richer mixture for these conditions. In the hot engine condition, you may retard the timing and increase the fuel. A richer mixture helps to cool the engine down. The thermostat controls maximum temperature so it may be difficult to tune. Nevertheless, put some extra fuel and less timing in the graph.

Water temperature correction can only be done in the morning when the engine is at its coldest. To set this graph, start with the example below. Now start the engine and let it idle. Adjust the AFR to be on the rich side. You may later have to tweak prime pulse, start enrichment and accelerator pumps to get a smooth pull off and start when cold.

Water Temperature Graph

Related Links

Water Temperature Sensor Wiring

Error Codes


Air Temperature tuning

Help > Tunning >

Air Temperature tuning

The Air temperature sensor is used to compensate with fuel and spark timing for density changes in warm or cold air. Neglecting to wire it in may result in the engine detonating when it is Hot. Not all engines have air temperature sensors mounted on them. Most sensors were incorporated in the MAS meter. This sensor deviates plenty between manufacturers so it is difficult to cater for all manufacturers. However, it can be installed and utilized effectively. Spitronics use a 10K NTC (Negative Temperature Co efficient) resistor. It has a fixed calibration curve which is programmed in the firmware and it cannot be altered. It can however be slightly calibrated by giving it an offset percentage. The normal setting is 100%. Click on the calibrate [image] button left of the Air sensor check box.

Reduce or increase the value to slightly shift the reading value. Do this at the critical temperature for instance where the engine is at running temperature. If the error is large you may need to replace it or get the correct sensor.

These sensors are measured at 25°C with an ohm meter to see which type it is. If you have the wrong type you may need to change the sensor to a 10K sensor. Save to ECU [image] button will make the changes permanent.

The Air Sensor is difficult to tune as you need controlled environment to do so effectively. Cold air is denser and requires more fuel and timing. You may be required to do adjustment tuning in the winter and then in the summer. The air temperature sensor is situated just before the throttle body (if installed). Remember to enable it on the active sensors page. When the engine is used in the winter, you may advance the timing slightly as the fuel burns at a slower rate. It may even require a richer mixture for these conditions. In the hot summer the engine may tend to detonate as a hot mixture burns more rapidly and the air is thinner. Then you may require to retard the timing slightly and lean out the air-fuel ratio. Remember if you tuned in the winter or summer your graph may tend to slope just on one side.

Air Temperature Graph

Related Links

Air Temperature Sensor Wiring

Error Codes


Fuel Sensor

Help > ECU Software Desciption > ECU Setup > Sensor Settings >

Fuel Pressure

The Mercury2 ECU has the ability to control fuel pressure by speed controlling the fuel pump with Pulse Width Modulation (PWM). This is achieved by pulsing the driver at 300 Hz with a required duty cycle and then measuring the actual fuel pressure with an electronic pressure sensor. The duty cycle is then adjusted to reach the required fuel pressure in loop control. At startup for the first time, disconnect the P2 and P3 connecters till you have set the control up properly. Reason is that the ECU may start the pump at full pressure and damage the lines.

The advantage of this feature is that the ECU can compensate for pressure fluctuations as this will vary the fuel amount going through the injector. It also eliminates the need for a fuel pressure regulator and return line to the tank. It can also compensate for turbo engines to increase fuel pressure above manifold pressures.

There are a few requirements to ensure stability of the fuel pressure. The fuel pressure sensor must be mounted higher than the fuel line where it is connected. The pipe must go downwards from the sensor to the fuel line. This will ensure a pocket of air between the sensor and fuel which will have a damper effect and isolate the sensor from the fuel to enhance reliability. Use high quality fuel hoses and clamp them properly to the sensor and fuel line. Note: The ECU has a built-in shutdown protection should the pipe come off and pressure signal falls below a certain level. There will however be petrol spillage as the pump has momentum and the one-way valve will prevent the fuel in the rail to return to the tank. This fuel is under pressure so it will spill at the severed line. Do not mount the fuel pump close to the exhaust as it will heat up and the fuel in the pump will percolate. The air pockets will cause the cavitation in the pump resulting in erratic pressure. The air bubbles can only be pushed through the injectors which also result in incorrect mixtures.

To use this feature, proceed with the following steps. Start by switching the sensor on. Click on show graph.

Click the calibrate [image] button and type in 100. Click OK.

If you have an accurate fuel pressure gauge or a different fuel pressure sensor you may calibrate it with this value. It is a percentage correction which allows for range calibration only. That means calibration is accurate at the working pressure. The sensors supplied are calibrated according to the manufacturer signal specs.

Now set up the following parameters.

Fuel sensor value

Type in the Fuel sensor value that you are using. They come in 4 Bar MAP, 5.5 Bar Differential pressure, and 7 Bar MAP. The most popular sensor is the 5.5Bar DP. Note: The low pressure side of the DP sensor must be tied to the intake manifold pressure just as a normal fuel pressure regulator. This sensor will automatically compensate for the intake manifold pressure.

The fuel pressure real-time gage will also be scaled to this Fuel Sensor value setting.

Fuel Control sensitivity

This setting will adjust how the ECU will react to pressure changes. Fast or slow reaction will control the pressure range. '1' is for the fastest reaction. If it is set too fast the fuel pressure will become erratic. Select the fastest value which will stabilize the pressure against hunting.

Fuel Safety Pressure

This setting is the protection feature that will cut the fuel pump in case of fuel line breakage. Especially to the sensor as this is a thin line. Use a 1 Bar setting.

Fuel Pump Low

This setting is to control the minimum duty cycle of the pump. If it is too low the pump will stop start and make the fuel erratic. Some fuel pumps need to do a minimum RPM or their veins will not deploy to pump fuel. If this is the case the pump will start to make funny noises and the fuel pressure becomes erratic. Sometimes it helps to turn the pump position so that the veins protrude downwards. Set the minimum duty cycle so that the pump runs smooth at lowest pressure. If it is too high the pump will not be able to control at the lowest pressure. A value out of 254 will make up 100% of duty cycle, it means that 127 will be 50% duty cycle.

Fuel Pump High

This setting is to control the maximum duty cycle of the pump. The high setting will limit the pump at a certain pressure. This is handy to prevent the pump from over pressure on the thinner fuel lines to the sensor. Make sure that the pump can supply the right pressure at full load high RPM. Always go for the lowest setting and keep a note on the fuel pressure at high load.

Driver Output

This setting will indicate to the installer which output is dedicated to the pump. This output must be positive and is used with the Spitronics Electronic relay. Make sure on the wiring connections.

Settings the graphs

Click the page button [image] tab.

Fuel Setpoint Graph - Manifold Pressure (Bar)

There are different ways to set-up this control system. With the 4 & 7 Bar MAP, (Mean Absolute Pressure) sensors, you need to compensate on the graph for manifold pressure fluctuations. The reason is that the Map sensor does not compensate for manifold pressure like a fuel pressure regulator. The fuel pressure needs to be adjusted with manifold pressure to keep a constant fuel pressure over the injectors. These settings in the graph below will keep a constant pressure of 2.5 Bar over the injector through the manifold pressure range.

For the 5.5 Differential pressure sensor the compensation is automatic as the open line is connected to the intake manifold. These settings in the graph below will keep a constant pressure of 2.5 Bar over the injector through the manifold pressure range. If you leave the line open to atmospheric pressure it will result in fuel pressure variations with altitude and will influence tuning of the engine.

For Turbo engines with the 7 bar Map sensor the graph below will keep a constant pressure of 2.5 Bar over the injector through the manifold pressure range. Note: The graph below how the pressure increases to 5.5 Bar at 2 Bar boost pressure.

For the 5.5 DP sensor the compensation graph will be flat as the DP graph above. Even if the total pressure is above 5.5 bar the DP sensor will only see 2.5 bar over it. (Fuel pressure minus boost pressure).

Fuel Pressure Graph - Fuel Compensation %

The Fuel pressure graph will allow the ECU to compensate for fuel pressure variations during blip conditions when the injectors suddenly require more fuel. The fuel pressure signal will react faster than the pump can be sped up or slow down at due to mechanical delays. Here the injector opening times will be manipulated in order to add or reduce fuel for pressure variation. To set this graph, start with a flat line.

Load the engine at light cruise settings like 2000 RPM and say 20% throttle. This may be varied as the type of engine may be smother at different RPM's. Now adjust the fuel mix to be in stoic area. Now increase the fuel pressure by half a bar increment. Do not go too high as the fuel lines may burst. Every time adjust the graph lower to maintain the same AFR mixtures. Now reduce the pressure and increase the graph again to stay in the right mixtures. Put the pressure settings back to normal.

Now if fuel pressures vary, the injector times will be compensated for and the AFR will remain constant. These graphs are interpolated.

Related Links

Fuel Supply

Error Codes


Charge volts tuning

Help > Tunning >

Charge volts tuning

Battery and alternator voltage have a great influence on ECU systems. When an engine cranks, battery voltage can fall as far as 9 volts on cold days and when the engine is running, voltage can go up to 14.3 volts. This difference has a big influence in coil energy and injector opening speeds. So to compensate for that the Spitronics ECU's has 2 graphs. One graph is a fuel compensation graph which adds more fuel during cranking. The other is a charge time compensation graph that will act on the charge time of the coils. This will improve spark energy to help the engine start. It is not a clear cut tune as you need to put a variable power supply in place of the battery.

What you can do is look at spark quality when the engine is hot and compare it to spark when it is cold. You don't want to overcharge a coil as it may get damaged. Always a good idea on a cold morning to look at the ECU voltage during cranking. A healthy battery should crank no less than 11 volts. Below is an example of a typical graph.

Charge Voltage Graph

The blue graph adds a certain percentage to the injector time and the red graph adds a certain percentage to the charge time. This is not an easy one to tune but it is recommended to lower the values and see if the result is worse or does not make a difference in starting. Always go for the lowest values. You may also decrease the values with higher battery charge. This may help protecting the coil drivers. These graphs are interpolated.

Related Links

Relay Wiring

Power Connection

Error Codes


Lambda loop control tuning

Help > Tunning >

Lambda loop control tuning

All Spitronics ECU's have the capability to do loop control with a lambda sensor connected. The tuner may set up parameters for lambda control and then the ECU will compensate the main air fuel ratio according to the lambda sensor in real time. This will result in the optimum mixture even if all the maps are not setup accurately or/and due to variations in environment which are difficult to tune in, such as moisture, air density etc. You need to tune the engine properly first and then activate this control afterwards.

To setup this feature, click on the Lambda and Show graph check box. If you only check Lambda, then it will display the values but not control AFR. This is handy while you do the base tuning.

Target Volts

This is the desired Stoic area where the sensor determines the best mixture of 14.7 air to fuel ratio. These narrow band lambda sensors have a voltage output of 0.1 to 0.9 volt. A voltage of 0.45 volt = 14.7 A/F ratio = 45%. Spitronics work in % as this is easier to simplify between the 1 volt and 5 volt signal. This unit can receive a wide band signal of 0 to 5 volts but the electronics for driving the sensor is not built in the ECU. It will require a separate electronic board. The ECU does not convert this volt signal in A/F ratio or lambda values as it is not required for control. There is a difference in volts for different type wide band sensors. The tuner uses an accurate test instrument to tune the engine and set his AFR correctly in real time.

Startup Delay

This will give the sensors' element time to heat up so that it can measure accurately. A normal setting here is 30 to 45 seconds. If the temperature of the engine is below 30°C, then lambda control will be disabled. When you start the engine time the sensor with a stopwatch till you can see that it measures correctly.

Control Percentage

This is the value of injector compensation. It can be adjusted from 0 to 20%. This means that if on 10%, the ECU will lengthen or shorten the injector signal by 10% to achieve stoic. Always try and tune the engine accurate in open loop and give the lambda just a little control to smooth it out. If you give it a large % and the sensor fails your engine may be out of AFR.

No. Samples

This Setting is the number of samples that is used as an average to prevent the control from becoming erratic. Because the sensor has a 0.6 seconds reaction time the ECU tends to over react. Increasing the number of samples will bring more stability to the control program.

The 3 limits

This will set the control range to where the narrowband sensor is accurate. A narrow band sensor cannot always control where a slightly richer or leaner mixture is required. The control will be active between the RPM limits and below the vacuum limit. Do not use this control at high RPM and high boost. It may be too slow to react when a mixture is lean. These settings are displayed on the graphs as short bars.

Sensor input

This input is used to select between a narrow band 1 volt signal and a wideband 5 volt signal. A wideband signal is linear and can cover a wider range of A/F measurements. It can be used for idling and high load readings. Notice that the rich and lean % change between the 2 sensors. Narrowband is inverted and wideband is linear.

Now click on the Lambda Graph [image] button.

Lambda Target Volts Graph - Manifold Pressure Compensation

You can manipulate these two graphs to alter the target voltage of the lambda sensor for control of the ECU. This means if you have a 10% increase on the graph and the target volts is on 45%, then the ECU will use 49.5% as the new target volts. Now, remember on a narrow band sensor this makes a larger difference in fuel as on a wide band sensor. Normally a car idling or under load requires a richer mixture. The top graph compensates according to load and the bottom graph according to RPM. These graphs are interpolated. Note for a wideband sensor the richer mixtures will be below the line.

When TPS Matrix is selected the ECU will use the TPS as load signal since there may be no MAP sensor.

Lambda Target Volts Graph - TPS Compensation

Lambda Target Volts Graph - RPM Compensation

This graph will adjust compensation in the RPM range. Outside the 2 limits will be no control.

When you drive the car you can set different target controls to obtain different AFR ratios to cater for load. For racing vehicles wideband AFR gauges are recommended with the signal connected to the ECU.

Related Links

Lambda Sensor Wiring

Error Codes


POT Input

Help > ECU Software Desciption > ECU Setup > Sensor Settings >

Tuning POT

This POT is a Potentiometer or variable resistor that lets the tuner or driver change settings in real time while the ECU is operating. It is a device that connects to the communication port plug for Pluto2 or Saturn or can be wired in permanently on Mercury2. The following functions can be activated for it.

See the sub folders for explanations.

Related Links

Tuning POT Wiring

Error Codes


Injector

Help > ECU Software Desciption > ECU Setup > Sensor Settings > POT Input >

Tuning POT Injector

Injector setting will change the injector time with 10% richer or leaner in this example. The POT needs to be in the middle to have no effect on current fueling. This is handy in a race car if the driver has an A/F Ratio gauge installed. Then he can manipulate fueling and remember under which conditions he has to lean or richen the mix. Then he can make adjustments on the graph at a later stage.


Timing

Help > ECU Software Desciption > ECU Setup > Sensor Settings > POT Input >

Tuning POT Timing

Timing will advance or retard the ignition timing by 5 degrees in this example. The POT needs to be in the middle to have no effect on current timing. It is useful in racing for tuning time while driving. Ensure that the driver has a knock sensor and light fitted to the engine.


Launch

Help > ECU Software Desciption > ECU Setup > Turbo Settings > Launch Control >

Launch Control

This feature will adjust the RPM limiter, enrich the fuel mixture and retard the ignition timing. These parameters are implemented in different ways to suit the driver. Launch control will spin the turbo to higher RPM's while the vehicle is stationary. This will create boost pressure so that when the driver launches, there will be no turbo lag. These Launch settings will only be implemented the moment engine revs reaches Launch revs minus 500RPM. Example: If the limiter is set as 5500RPM then the timing and fuel compensation will only start above 5000RPM. This will help the engine to rev up to launch effortlessly. Should the engine revs go above 5500RPM the fuel will be cut to limit the engine from over revving. Spark will continue to ignite unburnt fuel. (See the Product Hardware description for different wiring options.) Note: Timing can only be retarded to TDC. Going after TDC may require some clever tuning.

There are 2 methods to implement the Launch feature. One is with hardwire switches and the other, semi-automatic. (See the Product hardware description on the different connection methods.) For both methods set the Tuning POT selection on Launch.

Method 1 (Switch or Clutch and switch)

Select Clutch under Launch Deactivation. Set the desired RPM limit normally lower than engine limit. 4500 to 5500 RPM. This is mostly preferable depending on the grip at the racing track. Timing is set from 0 to 10 degrees depending of the engine characteristics. Fuel enrichment is set from 10 to 20% to create more burning fuel in the exhaust which is the power to spin the turbo.

Now to activate this feature. If you have only wired the dashboard switch you only need to press the switch and press the accelerator pedal. The moment you need to launch just release the switch with the clutch.

If you have wired the dashboard switch and the clutch pedal switch with resistor combination, then press the clutch in to make the clutch pedal switch, press the dashboard switch once and launch is activated. No need to keep the dashboard switch pressed. Press the accelerator. The launch parameters will be activated. The moment the clutch is released the launch switch will break and launch is deactivated. To activate this feature again you need to repeat the procedure. This feature lets the driver concentrate on his pull-off and free his hands for other tasks.

Method 2 (TPS 90% - Semi-Automatic)

With this method there is no need for a clutch pedal switch. You do however need to install the dashboard on/off switch or the Tuning POT. This method requires the driver not to press the pedal over 90% during launch activation. Pressing it deeper will deactivate launch to normal settings. The driver may need to practice this. He may also use a GP output to switch a light on at 80% TPS to ensure that he does not press it too deep. Both methods require the engine to rev lower than 3000RPM before activating the launch feature for the next launch. This will prevent the feature from activating during gear shift.

With the Dash Board switch do the following settings:

Select TPS 90% under Launch Deactivation. Set the desired RPM limit normally lower than engine limit. 4500 to 5500 RPM is mostly preferable depending on the racing track grip. Timing is set from 0 to 10 depending of the engine characteristics. Fuel enrichment is set from 10 to 20% to create more burning fuel in the exhaust which is the power to spin the turbo.

Now to activate this feature, put the switch to 'On' position. Now press the accelerator no more than 90%. The launch parameters will spin the turbo. When the driver releases the clutch he also presses the accelerator 100%. This will deactivate the launch feature. To activate this feature again you need to repeat the procedure except for the switch that is already on position. Note: The revs must be lower than 3000RPM. To deactivate this feature put switch off

With the tuning POT do the following settings:

Set the desired RPM limit to 0. This will indicate to the ECU that it must use the POT value to calculate a limit value. Timing is set from 0 to 10 depending of the engine characteristics. Fuel enrichment is set from 10 to 20% to create more burning fuel in the exhaust which is the power to spin the turbo.

Now set the POT register to the maximum allowable launch RPM. Example: 55 means 5500RPM. This will set the POT maximum clockwise value as 5500 RPM.

This feature is useful as different race tracks give better traction and allows for higher launch PRM's. To activate this feature, the driver simply presses the clutch and applies the accelerator till just below 90%. Now he adjusts the tuning POT till he sees the desired RPM on his rev-counter. When he releases the clutch he presses the accelerator 100%. Launch will then deactivate. This feature will activate automatically once the revs falls below 3000RPM because it does not have the Dash Board switch. If you want to cancel this feature set the launch revs 500RPM above the normal engine limiter. Then turn the POT fully clockwise. You can make increments on his tuning POT to calibrate it to his engines' revs.

Related Links

Launch Options Wiring

Error Codes


Transmission Retard

Help > ECU Software Desciption > ECU Setup > Turbo Settings > Launch Control >

Transmission retard

This feature is for automatic transmissions to retard the engine timing during gear shift. This will make the shift smoother and protect the transmission. The launch control circuit will be used and this system will disable launch control.

Set the tuning POT on.

Set the POT on Retard.

Set the RPM limit on zero. Set the launch control timing on 5 to 15 degrees depending on the feel of the shift in the transmission. Launch deactivation must be on Clutch. Fuel enrichment is not used here.

Now connect the relevant wires from the TCU to the ECU. When the TCU makes a shift it will put a negative driver on. It will connect to the POT input of the ECU. The POT real-time bar will be high and the moment of shift it will go low, activating the retard feature.

Related Links

Error Codes


Idle Control

Help > ECU Software Desciption > ECU Setup > Sensor Settings >

Idle Control

The ECU has the feature to control different types of idle motors found on an engine. Before adjusting the idle control settings, you need to select which type of valve or stepper is on the engine. Note: The stepper types idle motor (4 to 6 wire), require the external electronic driver. Also note that the electronic unit differs between the 4 Wire bipolar type motor and the 6 Wire common supply type motor.

Type Selection

The Type Selection can select between the two-wire spring-loaded Idle Valve, the three-wire spring or non-spring loaded Dual idle valve, the Bipolar Stepper motor or common supply Stepper motor. Stepper motors do not use the Low Limit and High Limit settings as they keep their position when there is no signal present. If there is no idle control select 'Not' used to free up valuable processor time and general purpose outputs.

Idle Valve

Two wire spring loaded idle valve only use one output from the ECU.

Dual Idle Valve

Three spring or non-spring loaded idle valve two outputs from the ECU.

Stepper Motor

Four or Six wire idle valves operate with a Spitronics Type 1 or Type 2 stepper motor controller, use one output from the ECU.

Settings

Drivers

This indication will show the installer which wires to connect on which outputs of the ECU. Driver 2 is only used for the dual valve to close. Note that positive and negative drivers may be used for idle control. If a valve is used, then make sure the Diode across it is wired correctly. (See the wiring diagrams and general purpose priority spreadsheet for correct installation.)

RPM

This setting is the target RPM's when the engine is on running temperature. When it is cold the ECU will automatically increase engine RPM's with up to 300 RPM's. This is calculated according to fuel enrichment on the water compensation map. Every 15% will increase 100 RPM on the Idle control.

Start %

This setting is used to increase the air intake when the engine is started hot or cold. The ECU will open the idle valve with this %. Note that on stepper controls it will activate 25% every time the key is switched on. If you don't start it, it may idle high at first then come back to idle target.

Response Time Up

This setting will determine the rate at which the valve opens when the actual RPM's fall below the set point in Idle RPM. The further the RPM fall below the set point, the faster the ECU will open the valve to let in more air. Low values will create a faster response time and high values will create a slower response time. This setting must prevent the engine from stalling when you switch the air conditioner on, or put it in drive.

Response Time Down

This setting will determine the rate at which the valve closes when the actual RPM's go above the set point in Idle RPM. The further the RPM goes above the set point, the faster the ECU will close the valve to decrease airflow into the engine. This value is set higher than the Response Up value, to eliminate hunting. Low values will create a faster response time and high values will create a slower response time. This setting must bring fast idling down as fast as possible without hunting the engine.

Low Limit duty cycle

This setting will preload the solenoid against the spring in the idle valve so that the valve starts to open immediately when the ECU starts increasing the value. It can also be used to set minimum idling RPM for throttle valves that closes completely. To set the value start with a larger % and decrease until the desired idling RPM is reached.

High Limit duty cycle

This setting is used to limit the maximum idle RPM's. No need to open the valve more than necessary. It also allows for the use of large valves in smaller engines. Make sure that when the engine is cold, it can still lift the RPM up to approx. 1500 RPM. This can be tested by entering a large Idle RPM value and limit the ECU from increasing it too high.

TPS Idle Cutoff %

This value is used to disable the idle control when the driver touches the throttle. The reason is that the ECU must know when not to control idle as the driver may need just a minimal amount of revs with slight throttle.

Related Links

Idle Control Wiring

Idle Control Tuning

Error Codes


Anti-Lag

Help > ECU Software Desciption > ECU Setup > Turbo Settings > Launch Control >

Anti Lag

The Anti-lag function will help to keep the boost pressure up when decelerating in corners on the race track. This function will use the launch control settings which will add fuel and retard the timing. The correct installation requires an EGR valve to bypass boost pressured air from the turbo before the throttle body, into the exhaust between the engine and turbo. The extra fuel with this air will ignite and the pressure will cause the turbo to spin creating boost. If the valve is not installed, then the min throttle setting must be opened slightly as to let air pass through the engine to burn the excess fuel. This may cause the engine brake to be eliminated and the driver will need to rely more on his pedal brakes.

Settings

Enable the feature and set the minimum RPM setting. This RPM setting is the limit which will disable the function. If the engine revs fall below this value normal fuel economy cut will resume. During racing the driver will gear down keeping the engine revs high.

These two setting will activate the Anti-lag. When the boost pressure inside the intake manifold falls below the Vacuum fuel cut off value and the throttle position is below the TPS idle cut off value. When the boost pressure goes above the Vacuum fuel cut off the feature will be deactivated and normal functions will resume.

To disable the normal Econo Fuel Cut off function make this value higher than max RPM.

The launch settings Timing and Fuel Enrichment are also used for the Anti-lag feature. If it is activated, the timing will be retarded to the launch timing and the fuel will be enriched to improve burn pressure in the exhaust to spin the turbo.

For valve wiring and output connection on the ECU consult the specific firmware instructions and drawings.

Related Links

Error Codes


Turbo Settings

Help > ECU Software Desciption > ECU Setup >

Turbo Settings

See the sub folders for explanations.


Launch Control

Help > ECU Software Desciption > ECU Setup > Turbo Settings >

Launch

The Launch control feature can be used for Launch control and Anti-lag. It could also be used to retard the timing during transmission shifts. But not for both. The driver will have to set it up for one of them. These features came later than the hardware so plans were made to accommodate them in this hardware. It is also mainly a Mercury2 feature. Pluto2 and Saturn can only do Launch control.

See the sub folders for explanations.


Engine Limiter

Help > ECU Software Desciption > ECU Setup > Turbo Settings >

Engine Limiter

This block has a few protection features. Setting them may prevent the driver from damaging the engine in normal and racing conditions.

Boost limiter

This feature will cut the injectors clean if the MAP sensor detects a manifold pressure that is higher than the set value. It is not a boost controller but it is to protect against boost controller or waste-gate failure. It can be adjusted in tenths of a bar resolution. The spark will not be cut.

Over temperature limit

This feature and the next one will protect the engine against over temperature. The injectors will be cut until the revs fall below the next setting.

Temperature RPM limit

This is the maximum limp mode RPM's when the engine is over temperature. If it is due to a burst hose it is better to switch off before the engine is damaged. If it is due to low water the lower revs will help to cool it down instead of disabling the engine.

RPM limit (>=60°)

This feature will prevent the engine from over-revving under normal temperature conditions. It can be adjusted in 100 RPM intervals. RPM limit can be achieved by three methods.

Soft

This mode will retard the timing in three stages and then cut the fuel completely. The result will be a smooth soft loss of power. Each 100 RPM over the limit, timing will be retarded further. First retard is 15 °BTDC, then 10 and then 5 °BTDC. Then during the third stage, fuel will be cut but not the spark. This will prevent fuel from entering the exhaust and backfire there. This is the preferred method for engine over-rev limiting. Note: The engine may reach 300RPM above the set value.

Hard

This mode will cut the fuel and spark completely. It has a jerk type feel and may result in small detonations in the exhaust.

Spark Only

This mode will cut only the spark. This will give the backfire sensation when unburned fuel is ignited in the exhaust. Note: Damage to the exhaust system might occur in this method.

RPM limit (<60°)

This feature will prevent the engine from over-revving under cold temperature conditions. It can be adjusted in 100 RPM intervals. This method will only cut the fuel and is just a protection.

Related Links

Error Codes


Micro Fueling Injector

Help > ECU Software Desciption > ECU Setup > Turbo Settings >

Micro Fueling

The Mercury2 ECU has a few features where it can use two injectors per cylinder. The way these injectors are implemented vary for different applications. If you use one fuel and the primary and secondary injectors does not differ too much in size, then the Ratio method is preferred. If you want to use different fuels together and the secondary injectors is a lot bigger than the primary injector, then the Graph method is preferred. On the hardware side, there is also different wiring configurations for different firmware. If there are enough drivers for all the injectors, then they can be used. If there are not enough drivers, then an extra electronic relay and isolating diodes are used to power the secondary injector's separately. So please see on the wiring diagram. The hardware connections do not affect the software settings if it is the same method.

If you are not using micro fueling, set it to 'OFF' to free up some microprocessor time.

Ratio Micro Fueling

This feature uses the primary injector at low manifold vacuum and when the manifold pressure goes high, it will add a secondary injector to increase the fuel amount to the engine. This will allow the engine to be tuned more optimally on low and high loads. This is necessary for high boost applications where the range of the injector's usage become limited. There are two limit values and the ratio value. If any of the two limits are reached, then micro fueling will be activated.

The ECU will calculate the difference in injector time between one and both injectors, so that the same amount of fuel enters the engine under the same conditions. This method should make the transition as smooth as possible. This is done by decreasing the total injector time by a fixed % which is calculated in the explanation below.

The Injector ratio adjust % field is calculated by the primary injector cc divided by the total injector cc multiply by 100.

Example: Primary = 100cc, Secondary = 200cc.

Compensation = Primary Injector x 100 = 100cc x 100 = 33%

Primary + Secondary Injectors 100cc + 200cc

If you are not sure on the injector sizes set the 2 limit values high so that the secondary injectors stay off. Tune the engine at 3000RPM's with the primary injectors up to a load where the injector duty % is around 70% [image] . Set the A/F Ratio with the Fuel Ratio setting [image] to be at stoic or 45%. Now start with 50% Injector ratio adjust value. Decrease the two limit values so that the secondary injectors start to operate. Reduce or increase the Injector ratio adjust % so that the same air fuel ratio at the same load is reached. You may need to reduce the throttle to disable the secondary injectors, while changing the Injector ratio adjust %. Now adjust the % setting till the Fuel Ratio setting [image] to 45% like with single injectors.

The Injection duty limit is one of the limit values where the secondary injectors will be implemented. If you set it at 70% then the moment the primary injector reaches this value, the secondary injectors are implemented. This will result in a combined lower injector duty cycle.

The Injection duty time is the other limit value where the secondary injectors will be implemented. If you set it at 12 milliseconds then the moment the primary injector reaches this value, the secondary injectors are implemented. This will result in a combined lower injector time.

Note: There is a dead band implemented on both limits so that the injectors do not become erratic when you cruise at this changeover load.

Graph micro fueling

This feature is ideal for Methanol Injectors. It will not influence the primary injector time like the ratio method. It will just bring a secondary set of injectors in at a certain boost pressure and progressively adjust the injector time for the secondary injectors on a graph in milliseconds. If you select Graph, a second graph on the Fuel graph will become visible. Click on the fuel graph menu [image] button and set the graph as follows.

The brown graph will be for the primary injectors and the blue graph for the secondary injectors. There is no real time display for the secondary injector value but the milliseconds are exactly as on the graph where the orange boost bar cross. Note that when these injectors do come in working zone, you need to keep the primaries constant or reduce them under the same pressure. The reason is that they may be close to the maximum duty cycle of 100%. This graph is interpolated.

Check the relevant drawings of which drivers will be used for this micro fueling.

Related Links

Injector Wiring

Error Codes


Cam Selection

Help > ECU Software Desciption > ECU Setup > Turbo Settings >

Cam selection

See the sub folders for explanations.


VVTI

Help > ECU Software Desciption > ECU Setup > Turbo Settings > Cam Selection >

VVTI Settings

This block is used to set up open loop cam control with TPS limits. It is also used to open variable intake runners found on some engines like the Lexus 1UZ VVTI. In some cases, part of this block may be hidden or disabled.

Cam1

In this block the output will be on between 2100 and 3900 RPM if the TPS value is above 30%, This is how most V-Tec cams are applied. The driver output will indicate where the solenoid must be connected on the ECU. Cam 1 is always used for the Intake cam or Cyl1 bank cam.

Cam2

In this block the output will be on between 2500 and 4000 RPM if the TPS value is above 30% as above. It operates the same as Cam1 but for the exhaust cam or bank 2 of a V type engine.

If this block is made visible like above, then it is only to indicate which driver is used. This may be in the V type engine where both cams settings are the same.

The intake flap

This block is firmware dependent on control according to requirements. For Toyota V8 the flap will be powered or activated whenever the RPM's are between 2500 and 4900 in this sample regardless of throttle position. It will also be powered if the throttle is less than 60% depressed regardless of RPM. Said in another way, the flap will not be powered at over 60% throttle and at lower than 2500 RPM or higher than 4900 RPM.

Related Links

Cam Solenoid Wiring

Error Codes


Flat Shift

Help > ECU Software Desciption > ECU Setup > Turbo Settings >

Flat Shift

This feature will momentarily cut the fuel or spark or both for a pre-set time during shifting. This will slow the engine RPM momentarily to ease shifting process in the gearbox. It is initiated by a negative going transition pulse of a switch, or electronics or load cell that will give an earth contact. The switch is combined with movement of the gear lever.

Settings

The following settings is done to activate this feature. On the Mercury the input is shared with the dual map input. This input is only used at start-up of the ECU for dual map. After that it is used as the flat shift input during run conditions. Normally an open switch will mean Map 1 when the ECU starts. Then if this contact is earthed the flat shift delay will be activated. If you want to start in Map 2 hold the switch in and put the ignition on. Then Map 2 is implemented, from there on the flat shift work as normal.

Choose a signal for the Dual Map and Flat shift. The correct wiring for the dual map switch must be followed. See the wiring section. Note: Fuel Pressure input requires a 1K pull-up resistor to 5 volts.

A delay can be adjusted from 0 to 350 milliseconds. Zero will deactivate the feature.

You may select the type of engine cut which is the same as the normal rev limiter settings. Soft will cut only fuel, Hard will cut fuel and spark and Spark only speaks for itself.

Related Links

Dual Map Switch Wiring

Error Codes


Rotary Engines

Help > ECU Software Desciption > Specific Instructions >

Rotary Special instructions.

General Information

The two stroke setting means that the firmware will inject the calculated amount of injector time in every stroke. Putting it off means that the injector time will be divided by 2. This will cause the tuning graphs to be twice as high. The advantage is that the graphs tune more easily and adjustments is 50% finer resolution. A drawback is that 25 milliseconds maximum fueling is easily reached during accelerator pump function and might cause problems at tuning flat spots during blip conditions.

Another feature is the duel injector system. It can be tuned with a ratio adjustment or separate graph system which is discussed in this article. Not that the secondary injectors is compensated, on all the graphs except the lambda control. Also during cranking the secondary's is not pulsed. During acceleration they will be pulsed even if the main graph is set at zero.

Determining if coils are on the correct plugs.

Due to the duel spark plug system it is sometimes confusing to understand why some leads can be faulty. The rotary engine allow the leading plugs to be fired in wasted spark configuration. The reason is that the non-combustion rotor is still covering the leading plug with the previous chamber. The trailing plug however is now situated in the upcoming chamber and will ignite the fuel in the intake should it be fired with the other rotor. Spitronics uses a different setup for the 3 coil wasted spark Leading coil pack. You connect both leading drivers on to the same wasted spark coil. Then it is Important to set the software to wasted spark as the firmware will then reduce charge time at high RPM to ensure that charge time does not overlap and that there is enough discharge time between charges. See the setting below.

NOTE: Always use a colder spark plug on the trailing and one size warmer on the leading for instance NGK B10EG on trailing and NGK B9EG on the leading. This will help with detonation that can be caused by a warmer plug on the trailing do to heat glow on the intake cycle

Note: Should the "Wasted spark coil per cylinder" be selected then the software will change it to Full Sequential.

To make sure that coils are setup in the right position, disconnect the drivers from the trailing coils. It is not good practice to pull off HT leads and let them spark in dry air. Reason is high voltage feedback may damage coil drivers. Now start the engine. There may be a 5% power loss but it should start easy and rev up smoothly. Get the timing light out and make sure timing is according to specs. Now disconnect the leading coils and reconnect the trailing coils. In the software set the maximum trailing degrees to zero as below. This will ensure that the trailing degrees fire the same time as the leading plugs. Now insert the trailing plugs onto their plugs. Again start the engine. If they are correct then the engine should start and rev up smoothly. There should be a power difference but no misfires. If they are incorrect there should be misfires in the intake manifold. Swop them around and try again.

Timing light degrees.

Due to 1 spark per revolution the normal timing light that does not have a 2 stroke setting will have an error in its reading. The degrees on the timing light will be double that of the actual degrees. If the timing light is on 20 it is 10 actual. If you use the wasted spark option there are 2 pulses per revolution and the degrees will be quadrupled on the timing light. If the timing light is on 40 it is 10 actual. Best way in these conditions is to set the timing light to zero degrees and work on the degrees on the engine pulley.

Determine Maximum injector time.

This is important because at high revs there is only a certain amount of time to inject fuel. This time may not be exceeded as the engine will leaned out. You may argue, that at lower RPM's you can go higher duty cycle with the primaries, but the problem is that this is not matrix and the switch over point is hard to determine. This time is calculated as follows.

Injection Time = 85% * 60 / Max RPM

= 51 / 8000

= 0.006375

Or 6.375 milliseconds

85% is recommended max duty cycle of an injector.

Max in this example is 8000 RPM

First set all the RPM graphs to 0.

To tune this unit set the Micro fuel setting on graph. There are 2 graphs available for the dual injectors. Red is for primaries and blue is for secondary's. First adjust the secondaries' to 0 right through the scale. Then at 3000 RPM adjust the primaries' from light load to full load until the max time is reached. In this case 6.3 milliseconds. Make a note of the load where max injector time is reached. About 0.84 bar. Then make the rest of the graph flat at the same value.

Now take a load just smaller than max like 0.75 bar. and look at the air fuel ratio. Lift the secondary's graph in totals till you see that the A/F ratio becomes richer. Decrease just enough till it is back to what it was. This offset will eliminate the dead band of the secondary injectors which will help to make the transition as smooth as possible.

Now you may increase the load and tune the secondary injectors to maintain the correct A/F ratio. Note that the secondaries' may also not increase the max injection time.

Lastly taper the injection time to the left off to eliminate pulse on the secondary injectors. Note the taper off is on the left where the primaries stopped working.


4+2Home 4Cyl Engines

Help > ECU Software Desciption > Specific Instructions >

4 Pulse + 2 Home Programs

Spitronics has a generic program for 3 different variations of these angle sensors. They are mostly distributor hall type sensors. This firmware is called Combo 48 4+2Home due to the number of different cars using this configuration. This firmware is used for different manufacturers like Mitsubishi, Mazda and Hyundai etc. It is up to the tuner to set it up so that coil and injection timing is correct. Or, a map from a previous install will ease this process. Note that distributors can be adjusted, but it is not advisable as it will create incorrect rotor fazing. Always leave the distributor in the manufacture position.

Crank TDC Pulse

This is the yellow pulse in the pictures below. It is used to calculate the engine degrees for spark and injection timing. There is an even 4 window signal in the distributor that gives 2 pulses per RPM which is 180° spaced apart. If the sensor is on the crank it will only have 2 teeth. The different versions may differ in length of the pulses but they are consistent in degree spacing on the rising and falling edge.

Cam Home Pulse

This is the blue pulse in the pictures below. It is used to calculate a Home signal to synchronize engine stroke. TDC will indicate to the ECU when Cylinder 1 is on TDC. This is adequate for Spilt-sequential injection and wasted spark. The Home signal will indicate when Cylinder 1 is on firing stroke. This is important to synchronize injection timing on a specific stroke for full sequential injection. Always crank the engine with no outputs connected. P1 only. Then play with the edges till no errors occur. Press C to clear the errors before cranking. If it accumulates as missing TDC or Home pulses, try another setting and clear errors again. Ignore the Error 6 Emergency shutdown when you release the key. It is normal.

Program 39 on Simulator 2 & 3

This combination below has 2 trigger setup options. The cam signal may be rising or falling. Both will produce no errors during cranking. The problem is that the actual stroke sink between the 2 settings will shift timing 180° degrees. You may have to go further in the startup procedure and look and see where is No 1 Cylinders' spark. If you don't see it then try the other setting.

or

Program 38 on Simulator 2 & 3

Program 42 on Simulator 2 & 3

Setting up Instructions

Make sure the distributor is in the factory position. Otherwise do rotor phasing as discussed in the manual. Disconnect all the output connectors and leave only P1 connected. This is important as wrong settings will fire coil times at random degrees causing starter failure. Make sure the jumper settings are set up for Hall sensors.

Crank the engine and look at the errors on the software. If it shows error 4 [image] then change the Crank(TDC) edge on the software [image] to the other selection.

It shows error 5 [image] then change the TDC edge on the software [image] to the other side.

You can press ''C'' to clear the error. There should be no error during cranking this indicates that the ECU is happy with the setup.

The ECU can now read your trigger pattern correctly but it still needs to know where TDC and Home pulse are.

TDC is important for the coils, so we begin timing from there. Connect P2 now. Disconnect the injectors and fuel pump so that there is no fuel while we work with the timing light and spark degrees.

If you use 1 coil on the engine put the settings as below.

Gear teeth is adjustable 1 or 2, which will shift the timing 180°. This is irrelevant with a distributor. Leave it on 1 then.

Set the Maximum timing to 10 degrees so that it is easy to find the timing mark.

Now put a timing light on cylinder 1 and set the timing on it to be 0°. This will eliminate timing light errors for the setup procedure.

Now crank the engine and look at the timing mark on the pulley. If it is not around 10° BTDC adjust the Timing Sensor block it in 10 degree steps to find it. Now adjust it as close to 10 as possible. You can click the arrow to increase while someone is watching with the timing light.

If you cannot find the mark with multi coil packs then it means timing is 180° out of phase. Set the [image] to 2 and start with the timing sensor at 0 again. Repeat the above process. Once you find it then you can connect the other coils as per drawing.

After this adjustment put the Maximum timing back to the original value.

Timing for fuel can be adjusted in 360 steps. This is to change the phase of injection between the 2 revolutions. Unfortunately, only gear programs can adjust different degrees on one revolution. There is no easy way to tell if you are on the right resolution but a dyno will indicate which one gives the better performance. This is usually found at low rpm loads. The setting to jump between the revolutions is [image]. It may be adjusted between 1 and 2.


Memory Handling

Help > ECU Software Desciption >

Memory Handling in Ver 3.5

The Memory handling in Ver 3.5 is changed to provide more GP outputs from the unused Coil and Injector drivers. The danger before was that when different Map files is downloaded into the Device, it may override critical setup values which could damage the device or components on the engine. Now the critical values cannot be changed by loading a map. It is saved in a separate space in the flash memory. These values can only be changes by adjusting them on a connected device or by Cloning the device.

Below is a block diagram of the map memory and how map data is handled.

The memory is divided into 3 categories. Map setup data, Map Graph and Matrix data and Critical setup data. Below follows a description of the different memory spaces.:

Map Setup Data

In this block all the normal settings are saved. If you load a map file, this setup data can be overwritten or it can be retained by selecting or de-selecting the Save Setup Data.

Note. This setting must be selected before opening the map. Once you open a map file then this setting is ignored as it is now part of the setup. There are values like TPS calibration that must be recalibrated if you load a new map.

Map Graph and matrix data

This memory house all the graphs and matrix data. This influences the actual tuning of individual engines.

Critical I/O setup data

The memory holds settings that will alter the inputs and outputs connections of the device. They are part of the normal setup data but are critical not to change during a map load function. This memory can never be overwritten by loading a map. One way to change these settings is online with the device connected, and then save it to the device. The other is by cloning function.

The Critical settings are:

Tuning Mode

This setting does not change connections to the device but selects different tuning parameters which may not be adjusted by the tuner.

Save Setup Data

This setting determines if the setup block will be overwritten or not. Checked on means it will be overwritten.

Dual Map Selection

This setting will effect which map data is loaded at startup. It effects also which wiring is used on some devices. This setting was already saved permanently in previous versions.

RPM Output pulses

This setting is used by other devices like a tachometer or TCU and should not change by loading a new map.

Coil Combination

This setting is critical because it could free up drivers that may be used for GP outputs. It will effect wiring connections.

Coil Driver Trigger Combination

This setting is only used in Pluto2 and Saturn and is critical setting because it will damage coil or driver if it is set incorrectly.

Injection Type

This setting is critical because it could free up drivers that may be used for GP outputs. It will effect wiring connections

Idle Control

This setting effect wiring connections and is combined with GP outputs,

Fuel Pressure Control

This setting effect wiring connections and is combined with GP outputs,

Duel Injector Control

This setting effect wiring connections and is combined with GP outputs,

Map Lock Password is also saved in this block. Note that if you upgrade a unit with new firmware it will be locked because this memory space was not cleared. Save both your maps before upgrade and load it in afterwards. See the Clone function.

Cloning

Cloning means copying a device map exactly onto another device. This process will save all the settings including the critical setup data exactly as the device map that was saved. This is handy for builders that use the same engines and drivetrains in different builds. It is also handy to load a startup map of a similar engine in the device to assist new customers. Simply lock a device by entering a map lock password. Then load the map into the device without unlocking it. This will initiate an exact data replacement into the locked device. It will also load the map in all the relevant maps for systems with Dual or quad maps. See locking a device below.

Related Links

Locking a Device


Tunning

Help >

Tuning Basics

Tuning is all about getting fuel and fuel amount, spark and spark timing timing correct under all conditions. Understanding how the ECU works with these values is important to adjust them correctly. The Spitronics ECU's are designed to be easy and user friendly and will do many calculations in the back ground to simplify tuning.

A Dyno is always the best way to tune with and then do fine tune other settings on the road. In some cases, a Dyno Map from a similar engine could be used and tweaked on the road to near perfection. No two engines are exactly the same and will always need some refining. Main differences come in to play with fuel pressure from a mechanical regulator and then Injector sizes etc. The help of a Lambda in loop control usually sorts this out while driving.

For racing engines with different fuels and boost pressures it is always recommended to tune with a professional tuner on a Dyno. A good rule is, always if you hear detonation or see lean mixtures, back off the throttle and adjust the maps. The GP output could be set on lambda with a bright light to warn when mixtures are lean. For a Turbo or racing engine it is recommended to make use of one of our agents who has a Dyno and can tune your engine properly.

Instruments used for tuning is a timing light and wide band lambda instrument with display. If you have set knock ears this will also be very helpful. If you are just tweaking an existing map on the road you may use the lambda wired into the ECU. If you do not have a lambda sensor on the engine you need to put a temporary lambda tuning instrument in the exhaust.

Adjustable timing lights can be confusing due to the wasted spark firing of the ECU. It usually shows double the actual timing. On wasted spark rotary coils it shows 4 times the actual value. Rather mark the degrees on the engine pulley and put the timing light on zero. They are not always accurate especially the cheaper timing lights.

See the sub folders for detailed explanation of the different tuning sections. Before tuning make sure you set the ECU in the modes explained in Settings before Tuning.


Tuning Tips and Hotkeys

Help > Tunning >

Tuning Tips and Hotkeys

Info


Settings before Tuning

When you get to this point your engine should start and idle easily and the basic settings in the startup procedure should be set. Start with a warm engine at working temperature. Remembering you have a start-up map loaded from a running vehicle.

All the sensors such as TPS, MAP sensor, water temperature etc. should be calibrated.

If you are on dyno tuning, then certain graphs must be set to zero.

Disable or set the following features so that it does not influence your basic tuning.

General Settings

Make sure you are in the right tune mode.

Your outputs should be set to ensure that cooling fans etc. operate correctly.

Engine Settings

Set this value 500 RPM higher than your max tuning RPM.

Timing Settings

Set the Maximum timing and trailing degrees to a safe level. It will protect against too much timing on the graphs while tuning.

Set these values to a min. if you are not sure use 2 and 2.5 rather. Later when the engine miss you can increase them to see if it improves the miss. Too higher values may heat the Coil drivers to a critical level.

If you installed an altitude sensor these values must be set before tuning.

Select the right tuning method. Usually the same as fuel.

Fuel Settings

This setting will prevent over fueling while tuning the graphs.

These settings will prevent the engine from cutting unexpectedly. For a rotary use 2000 RPM.

The accelerator pump sometimes influences your fueling. Especially the MAP sensor compensation if the vacuum is erratic. Always start with minimum values. If you see erratic injecting time put it on TPS only.

Select the right tuning method. Usually the same as timing.

Sensor Settings

If you plan to use the Lambda sensor and one is installed, then these settings must be on and the sensor must show your altitude pressure.

If you are doing fuel pressure control you should have set this up already. See the fuel pressure control adjustment section. If not, put the Show Graph or the sensor off if it is not connected.

Disable the battery, Lambda and POT till the tuning is done. The sensor will indicate though. If the lambda is not connected, then put the sensor off as well.

If you can tune without idle control on it will be good. Then select Not Used. You will need to ensure enough idle air to maintain engine RPM. Or you could do this tuning beforehand. But if you adjust Fuel Offset and timing, you may need to adjust the idle control again. See the idle control adjustment section.

Turbo Settings

Set a maximum value 0.1 bar above your planned maximum boost to protect the engine during tuning.

If you plan micro fuel injection with duel injectors, you will need to do some basic adjustments. See the section on dual injectors.

Related Links

ECU Setup

Error Codes


Starting and engine for the first time

The ECU has a few sequences how to start the engine. An engine requires an initial prime pulse of fuel to start the moment the engine is cranked, then a richer mixture during cranking. Once it started, it also requires a certain amount of richer mixture than idling to get it going till normal idle settings can take over. For cold starting all these settings must be increased at a certain %. This is done automatically by the ECU by using the water temperature compensation Map. Adjust the following settings before starting and again when the engine is at normal operating temperature.

Start Prime Pulse

This setting will open the injectors for 20 milliseconds when the engine reaches 100RPM during cranking. This will ensure that the fuel is not cranked through the engine before ignition spark is started. When the engine starts look at the exhaust. If there is black smoke it is too rich. Try decreasing this value till the engine struggles to start. Then increase it slightly. If this pulse is too large, it may flood the engine.

Throttle Priming is a function to manually inject fuel into the engine on very cold days. The TPS must be connected for this feature. If you press the throttle more than 25%, the ECU will prime the injectors by half the value set in the Start Prime Pulse block. It will start the fuel pump for 1 second to get the fuel pressure up again. This function may be repeated if more starting fuel is required. It is handy to see if a stubborn engine requires more fuel or not.

Flood Control is a function that clears a flooded engine. It is activated when the accelerator is pressed more than 80% during cranking. The ECU will cut the injectors and no fuel will be injected into the engine. The spark and clean air will eventually dry and ignite the remaining fuel and clear the plugs. When the throttle is released the ECU resumes normal fueling.

Cranking Fuel is calculated from the graph or matrix where the MAP or TPS value and RPM is at the time. In TPS matrix the block on the matrix at low RPM is used for cranking fuel. The Rotary firmware will use the prime pulse graph in expert mode as a crank fuel setting. The reason is the amount of fuel and low vacuum signal during cranking.

Start %

If you have idle control, do not press the throttle as the idle control will ensure enough air at starting. This value determines how much air the ECU must add to the starting enrichment. If you don't have idle control it helps to open the throttle slightly for starting. Do not rev the cold engine as oil pressure is still low. Rather let it heat up gradually. For cold starting you may need to keep the engine running with the throttle as it requires more air.

Start Enrichment

This setting will enrich the idle fuel after the engine has started and reached 500 RPM. It will add 0.5 milliseconds to the injector time. This value will decrease with RPM counts, and should fade in about 8 seconds at idling to zero milliseconds. If you rev the engine after starting, it would be zero in 2 seconds. Try starting with a zero value. Do not press the throttle. If the engine dies after starting, increase this value till it keeps running.

The engine is designed for a certain torque and power curve. Inadequate mixtures and timing will only reduce performance. Timing is the easiest parameter to get in the right region, as you can use timing marks on the pulley and quality timing light. Also follow the guidelines for the specific type of pickup to get it more or less in the firing zone. If you are not sure try to go for a retarded time position. This will make the least damage and not break the starter.

Related Links

ECU Setup

Error Codes


Calibrate timing

Help > Tunning >

Calibrate timing

This section discusses how to set the ECU timing to be accurate with Engine timing. This is important to see realistic timing values on the software and also settings that use the timing real-time bar to protect the engine.

First get the engine to start and idle smoothly as discussed in the Start-up Procedure. Make sure that you have the timing marks on the pulley checked for accuracy. If this is wrong it means timing will not be accurate on the software. Make a 10-degree mark or select a mark on the pulley that is close to that degree.

Now set the Maximum engine timing at 10 degrees or at the preferred mark on your pulley.

Make sure that the real time bar is on 10 degrees or you will need to lift it on the Dynamic timing graph.

Now take your timing light to the engine. Put it on the HT lead of cylinder 1. If it does not trigger on the light loosen the HT lead so that it creates a little gap on the spark plug tip. Not too much! You may also clip the sensor over the coil negative wire if it has COP coils. If that doesn't work, then wind the trigger wire 3 times in the same direction as the arrow around the sensor and close the clip. This will amplify the trigger signal. Sometimes you may need to use an extension wire piece to do this.

Put the timing light on zero and see where the timing flashes. It should be on the mark you set. If it is not there, then you need to make adjustments in the software. Do not adjust the distributor (if it has one.) It will adjust Rotor fazing which will then have a problem later.

You may ask someone to assist by looking at the light while you adjust the software. Start with the Timing Sensor setting.

Make small adjustment and see what happens at the front if you are going in the right direction. If not adjust to the other side. If you get to the end of the adjustment range, then you need to adjust the Gear teeth setting to make a course change. These settings react different for different firmware. On the gear teeth programs more teeth mean slower timing by the pitch of the teeth. For a 36-1 gear the timing will jump 10 degrees slower if you add a tooth. The Timing sensor wall advances with higher values. It can adjust from 0 to 9 degrees.

Once you get the timing light spot-on with software timing, you can check if your adjustable timing light works correctly. Put it on 10 degrees for a distributor then the flash should fall on TDC. If you have wasted spark or COP coils, then 20 degrees on the timing light will fall on TDC. If you have a Rotary with wasted spark leading coil the 40 degrees on the timing light should fall on TDC.

Now put your maximum timing back to where it was and save the data to the device. It is good practice that after setup of the software before tuning, save a base map. Should something go wrong then you save a lot of time.

Related Links

Software

Rotor Fazing


Fuel economy cut-off tuning

Help > Tunning >

Fuel economy cut-off tuning

This feature will cut fuel to the engine under low load conditions. This will save fuel in town and downhill driving. The engine will run against compression as you are decelerating. It will also prevent flaming in the exhaust during accelerator blip.

The injectors will be cut when the MAP sensor value is below the Vacuum fuel cut off setting and the engine RPM is above the RPM fuel cut off setting.

The Vacuum fuel cut off setting is chosen as a value lower than idle vacuum. A good value is usually 0.08 bar for a standard street car. The RPM fuel cut off setting is about 500 RPM higher than idle RPM. Rotary and racing engines may need some extra RPM's.

There is a dead band feature built into these settings to prevent jerking when you are cruising close to the settings. When tuning these parameters use third gear at around 2000 rpm and release the throttle. Look at the real-time injection bar and you will see that it goes to zero value which means the injectors are switched off.

You will also notice in information code at the right-hand bottom of the screen indication that this feature is activated.

Now, let the car reduce speed by itself till injection is restored and the engine is running by itself again. This change over point must occur when the engine reaches idle RPM's. If it jerks in the car, reduce or increase one of the settings till it comes-in unnoticed.

Related Links

Error Codes

Software


Graph MAP tuning

Make sure all safety precautions are met as specified by the Dyno Safety rules from the manufacturer. Also remember to keep an eye on the water temperature of the engine. If at any time you hear detonation, back off the throttle immediately and lower the timing in that RPM range about 3 degrees. If at any time the RPM bar becomes erratic, back off the throttle and do faultfinding for interference or a faulty trigger signal. If the AFR shows lean, back off and make it richer in that load site. Especially turbo and racing fuel engines. They can become damaged in a very short time.

Ensure that the engine is at working temperature and all the sensors are calibrated. Disable Lambda Control until after the tuning is done. By now your engine should start and rev up and timing must be calibrated. See the Calibrate timing section. This section will discuss the final fuel and timing tuning. After this you still need to tune drivable features and cold starting. Ensure all the settings in the Settings before Tuning section is done. Now proceed to the map reset section.

Reset Maps

Zero both graphs on the Cruise Timing Graph.

Zero all 5 graphs on the Fuel Graph - RPM Compensation.

Zero both graphs on the Water Temperature Graph.

Zero both graphs on the Air Temperature Graph.

Zero the TPS Graph.

Set Maps

Now set a basic profile on the following maps.

This is a basic dynamic timing that should work for the average engine. Set a basic RPM timing map to start at 10°BTDC degrees and idle at 15 °BTDC degrees. Increase the timing from 1000RPM to 3200RPM up to 32°BTDC. Keep it flat till maximum timing. If you have a special engine with high compression, then lower the maximum timing to 28 degrees.

Your main fuel map should look something like this. This means engine idles at around 0.2 bar vacuum and requires 4 milliseconds of fuel to idle when hot. The slope will provide enough fuel to rev and ride the engine. If your injectors are larger than standard, then idle fuel would be lower and the slope less aggressive. Note: Fuel Ratio is set at 100% and Fuel Offset is as 0%.

Set the 5 tune markers in even space over the load of the engine. The green marker could be at idling and the red high bar at about 90% load. Space the other ones evenly.

If you have a Rotary engine also set the trailing degrees at a base timing of 7 degrees.

Make sure that fuel compensation is zero at operating voltage in the Charge Voltage Graph.

Start Tuning

Tune1. Fuel Load Graph - Manifold Pressure

Now start the engine and set the Dyno RPM at the middle of the engine max RPM, around 3200 RPM for a 6500RPM engine. First tune is to set the throttle flow profile on the Fuel Load Graph.

Set the easy tune feature to Tune All Right. Put the real time tracing function on. Now use the arrow keys to tune the graph.

Look at the AFR gauge closely all the time. Start with light throttle and increase it by pressing the pedal just a little at a time. First RPM will increase till it reaches 3200 on the Dyno. Then the Dyno will keep the engine RPM constant and you can proceed right through the load range.

Listen for detonation. If you detect any, back off and go to the timing graph and lower the graph in that RPM bracket. Also, remember the AFR should show slightly lean at light load, Stoic at cruise load and slightly rich at high load. Different engines will require different ratios so you need to tune accordingly. This manual is not written with specific AFR in mind, but merely for explaining. After tuning you should have a similar profile. See below.

Tune2. Dynamic Timing graph (WOT) - RPM

Now that you have the AFR set to a safe level you can proceed with the Dynamic Timing graph. For this tune you need knock ears or a Dyno with very fine torque measurements. Start with light throttle again. This tune is to determine wide open throttle timing. Keep the dyno control handy and start with the lowest RPM. at very low RPM's WOT may not fuel correctly so use a lither load tile as it is clean. Here, you now increase the timing till you see slight detonation or that power does not increase anymore. If you see knocking you can lower the timing by about 3 degrees. This should also be the limit where power break offs' occur if you decrease any further. Keep an eye out for the AFR gauge. Timing will influence the amount of fuel required at that RPM. If AFR goes to lean repeat the first tune again and come back to timing. Also, ask someone to look at the water temperature on the engine to be safe. A very hot engine requires less timing so try and tune at working temperature. Below is a sample of a Lexus V8 engine. Notice the timing dip at 4000 RPM. That is where VE is at its best and requires less timing.

After Tune 2 it is good practice to look at tune 2 quickly and see if it requires fine tuning.

Tune3. Cruise Timing Graph (High RPM) - RPM Compensation

Now, you need to set a cruise timing curve to proceed to cruise fuel tuning. Keep the dyno on 3200 RPM and again tune for timing up to detonation or power turn point like in test 2. Start from full load to light load using easy tune all left function. At light load you can keep the same value to the left. You will end up with a graph similar. See below.

Tune4. Fuel graph - RPM Compensation

Now that dynamic cruise timing is set it is time to proceed to the Fuel graph - RPM Compensation. Here there are 5 graphs. Start again with the green at lightest throttle and work to the high load. You can press the Hide function to isolate each graph. Keep the dyno control handy and start with the green bar. As you increase the RPM on the dyno from idling to high rpm, you need to load the throttle to keep the Map sensor value on the green bar on the Fuel Load Graph - Manifold Pressure. Tune all right will adjust the graph evenly. Remember that AFR is different for light load and full throttle. It should look like below. Again this graph may vary between engines. Notice how all the graphs come together at 3200 RPM. This was due to Tune1 step where all the graphs was set to 0.

Tune5. Cruise Timing Graph (Low RPM) - RPM Compensation

Now you need to set a low RPM timing. This is handy to get a slow engine up to speed quickly. See the graph below. This engine idles at 0.2 bar when hot and there is zero timing. The moment you press the accelerator, and the engine is below 1500 RPM, the bar will move to the right-hand side. This will add quick timing and get more power from the engine. If you blip the throttle it will still add 5 degrees till the engine reaches 1500 RPM.


Graph MAP with TPS tuning

Help > Tunning >

Graph MAP with TPS tuning

This tuning is the same as MAP graph tuning with the added adjustment to get the engine to idle on TPS calculations. It is still easy to tune without going to TPS matrix. So first tune according to this method. The same principles will apply to the timing graph but it is not as critical as fuel. Now do these adjustments.

Idle Tuning for an engine with a hot or long duration Cam

When a cam has valve overlap, the manifold vacuum at idling is very erratic or none existing due to exhaust gasses that backflow into the cylinder and sometimes also into the intake manifold. As a result, the ECU cannot use the MAP signal effectively because it is no longer a representation of how much air is going into the cylinders. To correct this there are two ways to tune the ECU to compensate for these out of balance situations.

Option 1, RPM Compensation

In the example below the engine loses vacuum at 1500 RPM and lower. Then the vacuum bar on the top graph moves to the right. This means that the Low cruise and cruise Map below is active. Now, lower the graph below 1500 RPM to compensate for the over fuel condition. This option works well with mild cams. It is used for fuel calculation Maps only.

Option 2, TPS Blending

In this option we use the TPS signal for the fueling signal at low RPM's and the MAP signal for high RPM's. First determine at which RPM's the engine looses the vacuum signal. Put the engine in neutral and increase the RPM's till it has a good vacuum signal. Now reduce the RPM's while looking at the green bar on the Fuel Load Graph. The bar should move to the left until vacuum becomes a problem. It will then move to the right again. If it happens, let's say at 1600 RPM adjust the following settings on the Setup Fuel setting.

Put the Fuel Calculation on Map + TPS.

Put the critical RPM value in the RPM Fuel Cut-off block. Put the Vacuum Fuel Cut-off on 0.1 Bar. Start with the TPS Gain at 100. Now if the RPM signal falls below 1600 RPM, the TPS signal will be calculated as a MAP signal for the vacuum graph. When the TPS is at 0%. the MAP signal will stand on the 0.1 Bar position and move from there. If the RPM goes higher than 1600 RPM, the map signal will be used for fueling again. Should the actual MAP signal be lower than the calculated MAP signal at RPM's lower than 1600, then the actual MAP signal would be used. This will prevent the TPS signal from over fueling the engine.

Now adjust the fuel to increase as the TPS is increased so that the flat spot is corrected. If you don't find a sweet spot between the TPS fuel and MAP crossover, then you may need to move the Vacuum Fuel Cut-off higher to 0.2 Bar. This will have a higher value on the Fuel economy cut and result in harsh control on that feature.

Now press the throttle at different opening speeds with your foot. The vacuum bar will move from the 0.1Bar position to the right side of the graph. The speed of movement is adjusted by the TPS Gain value. If the bar moves to slow you will have a flat spot under acceleration. Increase the Gain value till a smooth acceleration is achieved. Start with a lower value to ensure that the mixture is not too rich.

Another tip to tune flat spots: Set the MAP accelerator pump to only work in the calculated range, and then make it sensitive and enough fuel. Note the 1600 RPM setting.

This is not a black and white setup but merely a guideline so you understand what you can do in the firmware. Trial and error will find a sweet spot.


Matrix Map Tuning

Help > Tunning >

Matrix MAP Tuning

This tuning mode is the most popular Dyno tune method. It is easy because the Dyno locks the RPM's to a specific load site and the tuner can move the load through the other axis. Then he tunes specific intervals. The ECU will then interpolate points in-between his tuning points and get fuel and time accurate and smooth. Note that this mode is not available in Novice mode. See the Tips and Hotkeys section to understand how to manipulate all the data values.

Matrix tuning Pallet

This pallet is tuned in a 16x16 matrix. The MAP load range is on the vertical Y-axis and the RPM value is on the horizontal X-axis. The range will scale according to MAP sensor setting and the RPM Increment setting.

A Popular value is 500 RPM per column then it will end at 7500 RPM. Should the RPM's go higher than the right column, the ECU will keep that column value The load however will still increase on that last line.

Always start to tune with Ratio 100% and offset 0. If you add an offset remember it will be added to all your fuel values.

Easy tune and Real-time tracking

Easy tune and real time tracking are very useful tuning tools in this tuning pallet. It assists the tuner to tune where the load and RPM is without moving the tuning block with the arrows.

Focus window

The focus window guides the tuner to the centre of the block so that his tuning is accurate. Otherwise he will tune the wrong values in the active block. He will need to fine adjust the Dyno RPM's and adjust the load with his foot till the window turns yellow.

3D Display

The 3D window is a representation of the actual map. This is handy to see if there are irregularities in a block.

Tuning Preparation

See Settings Before Tuning, before you begin. If you have a start-up map it would make starting and idling easier to begin with. If not, set easy tune to Initialise and make the whole pallet 4ms. Then on the load rows increase the fuel gradually to 14ms max. It is a base map and will get you started. For a turbo engine with larger injectors start with smaller values and end with higher values. A turbo engine's injectors has to work over a wider range to cater for the higher fuel demand. See the pallet below.

Set a base timing map of min 10 degrees and max 32 degrees. If it is a turbo engine you may need to decrease the load timing. See the pallet below:

Tuning

To tune an engine from scratch you need to adjust fuel then timing then fuel again and then timing again. Fuel has a big influence on AFR and power while timing has a smaller influence on AFR and power. But they do have an effect on each other. When you tune fuel listen for detonation. If you have knock ears or some indication, it will be helpful. If at any time you hear detonation, back off and reduce the timing with 3 degrees in that field. Also look at Water Temperature not to damage the engine. Start with an engine on working temperature. Remember air and water temperature can alter your AFR settings, so keep a constant flow of cool air on the air filter.

Start as close to idle as possible. In this case 1000RPM's. Start with idle AFR at no load. Now set auto tune to [image] . That is the direction of tuning. Put Real-Time tuning on [image] . Your engine should idle at around 0.2 bar to 0.3 bar vacuum so adjust from there.

Tune low loads for lean AFR and then go richer as load increases. This manual will only explain basics of tuning. Now increase the load with the throttle to 0.3 until the focus window is yellow. Some dyno's may "Creep" as load increases so you may need to do adjustments. Increase the value till the right AFR is reached. Then go to 0.3 and so on. Remember at 1000 RPM the engine may not get top maximum boost range. Tune as far as is possible. Later you can predict sensible values for that part of the Matrix.

Remember at high boost detonation or timing this may start to play a big role. Some tuners will stay at 1000 RPM and do timing first. The reason is the tune up and right will also set timing more realistic for the next fuel load. It will save on repetitive tuning later. So for this section we will do timing next.

Adjust the timing and look at the power reading on the Dyno. Usually maximum power is 2 to 3 degrees before detonation. The power tends to level out in that region. So the trick is to find the avalanche where power breaks off, then you should be safe. If you hear detonation back off, reduce the timing 3 degrees. Now increase the load with the throttle to 0.3 until the focus window is yellow. Do the same as the previous block. You should see that the timing increase to 1 bar and then reduces again with high boost pressures. Again at high load on this low RPM the turbo may not reach high boost pressure.

Now release the throttle and set the Dyno on 1500 RPM. start with 0.2 bar load again on the fuel Matrix and repeat the previous exercise. Then go to Timing Matrix and do the same. Then next RPM column and so forth.

All that remain now is the space outside where the Dyno cannot reach. This is the load rows below idle vacuum and RPM columns lower than idle.

The load rows below idle vacuum can only be reached when the RPM's are high and you back off the throttle like on a downhill or decelerating stage. On the Dyno you can accelerate and release the throttle and look closely where the vacuum and RPM crossing point is at. Then decide on how you want it to give it fuel and timing. You won't be able to hold the focus window on yellow so make adjustments and try and see if your measurements improve. Here are some guidelines.

On timing give the lower Load rows on the high RPM side more timing than usual. Fuel will be lean due to low compression and it could be ignited earlier.

On the RPM columns make the whole row 10 degrees which is your cranking timing. This will ensure the engine starts easy without kick back on the starter.

On the fuelling rows side try and tune it close to correct value when you release the throttle. The reason is the interpolation will still calculate fuel. Don't use this as the Fuel Economy Cut-off feature.

On the fuelling column side use this as your cranking fuel. When the engine cranks it will use the block where the load is at. It will be compensated with the water temperature graph for cold starting.


Matrix TPS Tuning

Help > Tunning >

Matrix TPS Tuning

This tuning mode is the most popular Dyno tune method for normal aspirated racing engines that have poor vacuum signal or throttle bodies. It is easier because the Dyno locks the RPM's to a specific load site and the tuner can move the load through the other axis. Then he tunes at specific intervals. The ECU will then interpolate points in-between his tuning points and get the fuel and time accurate and smooth. Note that this mode is not available in Novice mode. Requirements here is a good and accurate TPS signal and also the altitude sensor. This tuning method cannot cater for altitude and pressure differences due to temperature. See the Tips and Hotkeys section to understand how to manipulate all the data values.

Matrix TPS tuning Pallet

The only differences in this tuning method is that the vertical load Y-axis is TPS instead of MAP signal. The tuning is the same as described in Matrix Map Tuning. Note: When the throttle closes, the block will stand a 0% and not at atmospheric pressure. Also when the throttle is released it will stand on 0% right at the bottom.

All that remains now is the space outside where the Dyno cannot reach. This is the RPM columns lower than idle.

On the RPM columns make the whole row 10 degrees which is your cranking timing. This will ensure the engine starts easy without kick back on the starter.

On the fuelling column side use this as your cranking fuel. When the engine cranks it will use the block where the load is at. It will be compensated with the water temperature graph for cold starting.


Graph MAP and Matrix TPS Tuning

Help > Tunning >

Graph MAP and Matrix TPS Tuning

This method is for Dyno tuning and used for racing engines with poor vacuum signal. Before reading this section please read Matrix MAP Tuning to understand how to tune from scratch. This section will only discuss the differences and types of Tuning options.

For this method you tune the normal aspirated part on the TPS matrix and then the turbo boost part on a graph. This feature is best to use with Altitude compensation sensor wired in. The Altitude sensor will modify the TPS matrix value before it is compensated by the Graph setting. This will give a more accurate calculation of the fuel per air. The trick is to tune normal aspirated fuel on the TPS matrix then add the boost compensation fuel on the graphs. TPS has no reference against pressure of the Turbo. Timing will also activate the two Cruise Timing Graphs for boost timing tuning.

There are two methods of tuning.

Method 1 is to disconnect the turbo and do the TPS matrix as previously discussed. Then connect the turbo and do the Fuel Boost Compensation graph. This method is good for low boost engines.

Method 2 is to add a predicted boost graph line and then tune the TPS Matrix with low boost to get a pattern on the Matrix. Then put the boost up and tune the Fuel Boost Compensation graph part complete.

Method 2 Fuel with Altitude sensor wired in.

Make sure the altitude sensor is switched on Compensate. Especially if you are not at sea level. Tuning will include the pressure difference and change the maps when you go to sea level. This graph will start at 0 pressure which is the current atmospheric pressure where you are. If you change altitude this zero point will move with the altitude pressure. This means that the moment boost pressure goes above altitude pressure the graph will indicate the difference. That will eliminate the need for the ECU from being retuned all different altitude levels.

Fuel Boost Graph with Altitude sensor.

Set a base graph as above. Note that at 1 bar boost it will be around 100% enrichment. With this method you can boost up to 2.5 bar above sea level. If you need higher boost you may have to add fuel on the matrix or add the dual injectors with Ratio or Graph method. The reason is this graph can only go to 250% enrichment. This graph is linear and it should curve up to make mixtures progressively richer at higher boost. So go for the lowest boost setting that you can. Maybe 0.5 bar boost. Now turn your attention to the Fuel matrix.

TPS Fuel Matrix

Note: Due to the turbo engine, the injectors will be bigger and the injection times will be shorter. The maximum set here is 8.7 and with 1 bar boost it will become 17.4 milliseconds. Which should be maximum at high RPM's. After you tuned at low boost then proceed to the graph again.

Now lock the dyno on a high RPM load site at full throttle. As you increase the boost adjust the graph to run at the right AFR mixtures. Once this line is set to maximum boost then change the RPM and check other load sites as well. They should be the same AFR. If you see a lean mixture you may correct it on the matrix map. Notice the graph below now has a slight curve to the top. This one runs out of tuning space because the injectors are too small.

Fuel Boost Graph with Altitude sensor.

Method 2 Timing with Altitude sensor wired in.

TPS Timing Matrix

Timing matrix is set like a normal aspired engine. See sample above. As for the boost part you need to tune the Cruise Timing Graphs.

Fuel Boost Graph with Altitude sensor.

Here only the red graph is of importance as normal liming comes from the TPS matrix. Set the blue one on 0% compensation so that it does not affect low RPM timing.

Fuel Boost Graph with Altitude sensor and Dual injectors.

If you need more fuel for a high boost engine, then you may activate a second set of injectors. There is the standard Ratio method, or the graph method. The graph method is only available if there are enough drivers for that application.

Ratio Method works standard as it is discussed under Micro Fuelling Injector section. A certain duty cycle or injector time will trigger the second injectors to come in and share the load. Fuel will be divided between them.

The Graph Method is also discussed there and below is an example on the set-up of a graph. Note that when the system passes 1 bar boost a second set of injectors are phased in. In some cases the top ones may be flatten out if their duty cycle becomes too large.

Fuel Boost Graph with Altitude sensor and Dual injectors.

Method 2 Fuel with no Altitude sensor.

This method can be used if you don't use the vehicle on different altitudes. Remember air temperature has an effect on atmospheric pressure so there may be slight changes in your AFR from day to day. If possible, use it with the Lambda control. The main difference is the Lambda sensor don't effect the timing and you may get detonation at sea level.

Fuel Boost Graph with no Altitude sensor.

Notice that this method uses the actual MAP signal on the real scale. This example as tuned at sea level on 1.03 bar altitude pressure. At higher altitudes the graph will start to increase from that altitude.

Cruise Timing Graph with no Altitude sensor.

Same as above this starts to change from 1 bar.


Tuning for Automatic Transmission

Help > Tunning >

Tuning for Automatic Transmission

Automatic transmissions, air conditioners and power steering uses a lot of energy and may cause engine RPM's to drop and may stall the engine. Usually idle control will cater for this but you will also need to set fuel and timing accordingly.

To adjust this start with a hot engine and put the transmission in park. The engine is now on free idling. When you put it in drive, the load will cause the engine to lose RPM and also vacuum. The Map sensor bar will move slightly to the right, now add a little timing and fuel to make the engine idle stronger. These settings will act very fast on the engine and capture the power loss.

Dynamic Timing graph (WOT) - RPM

Fuel Load Graph - Manifold Pressure


Idle Control Tuning

Help > Tunning >

Idle control Tuning

Idle control is done with different methods. It could be external idle valve or stepper motor or it could be done with partial throttle motor or full drive by wire throttle. Due to the delay in mechanical control to stabilise idle, you need to tune the ECU and idle valve together. The reason is that the ECU can react faster than a mechanical air restrictor valve. And most of the times hunting is a result of incorrect engine tuning. If idle drops then the valve opens to correct. That adds more air resulting in a worst effect and it comes with a delay. Then the ECU will add fuel due to more air resulting in high rpm which in turn close the idle valve and this repeats out of control. Also after blip the idle valve must capture the engine rpm before it stalls. Again here the ECU can react faster by adding timing and fuel to assist in this process. This section describe what needs to be done on the ECU side to help smooth idle control. See the different types of idle control and how to adjust their settings in the idle control setup section.

Setting the Idle Jet for Time & Fuel

When an engine idles in neutral and is at working temperature, the idle timing should be around 15 to 18 degrees depending on altitude. This may vary from engines but this is a basic guideline. Increasing idling degrees usually result in higher RPM's. Do not confuse this thinking it is what the engine needs. All you will do is lowering the air volume to bring idle down. This will result in very poor power and engine will easily die off when you put a bit of load on it. The lower the engine timing the slower the engine idles and the more idle air it requires. It will also require a slightly richer mixture. Now if you put a little load on the engine you immediately add timing which will make more power due to the rich mixture with more air. Adjusting timing is immediate and there is no mechanical delay. Now when an engine wants to hunt you can effectively control power to it without the idle control valve or throttle movement. Below is some basic ECU settings.

First adjust the timing so that at idle there is 15 degree dynamic timing and no vacuum timing.

Adjust the Idle fuel so that the engine has just enough fuel to idle constant. Do not make it too rich. It should be close to avalanche point where if you go leaner the engine will lose power. The best way to see this point is where the vacuum signal will be at its lowest point for normal engines. Any more or less fuel will results in higher vacuum. Racing cams and matrix tuning will be saver to look at A/F ratio. Idling RPM's should be on your Target RPM value. In this example 800 RPM. Notice that the green and brown graph below on RPM compensation is at zero compensation. Only the main graph determine idle fuel. Also make sure water and air compensation is zer0.

Now when the engine hunts we will use timing to control it before the idle valve needs to act. First you must understand what happens in hunting. The engine will lose power resulting in an increase in manifold vacuum. The vacuum bar will move to the right and the RPM bar will move to the left. Due to our slower timing we can increase timing to add power which will increase RPM. Adjust the Low rpm timing graph as below.

Lower rpm also brings more air in the manifold which requires a bit more fuel to make the mixture a power mix. Adjust the green and brown graph on the RPM graph ay the lower rpm range to add a certain % fuel. Note on the fuel load graph we already should have a slight increase in fuel.

Now the above adjustments will capture falling RPM's and it may now cause the idle control valve to react as well adding air. This will increase RPM above target. There is an up and down response on the idle valve control settings. As a rule we make up response faster to ensure that the engine does not stall. Then we make down response slower to prevent hunting. Will result in more vacuum which makes the vacuum bar move left and the RPM bar moving right. First we use timing again to make it slower reducing engine power.

Then less air also needs less fuel. This time we adjust the fuel load graph as the engine don't use this part for normal riding. Note however, that deceleration will cause the vacuum to move in this region. If the mixture is too lean then the engine to being jerking due to too lean mixture.

Automatic Transmissions

For automatic transmissions tuning principles are the same as above. But there are two load steps that differs for neutral and drive. After you do the neutral tuning, then put the engine in drive. The load on the engine from the transmission will cause the vacuum bar to move to the right quite a bit. RPM is controlled and will stay the same. So you need to make sure that the idle fuel will increase for the added load.

Related Links

Idle Control Wiring

Idle Control Setup

Error Codes


Startup Procedure

Help >

Startup Procedure

This procedure is very important as this is a universal ECU that can cater for many combinations of engines. Setting incorrect values here may damage the ECU or some of the engine components permanently. The Maps supplied by the agents are a guideline and not guaranteed to be set up correctly for your application. It is your responsibility to make sure it is setup correctly. Common failures are short circuited wires in the installation. Coil drivers are set incorrectly for internal or external coils, resulting in damaged coils or ECU drivers. Injectors stuck in open condition causing fuel to flood a cylinder and resulting in bent connecting rods. Too larger fuses resulting in damaged electrical components.

See the sub folders for explanations.


Preperation

Help > Startup Procedure >

Engine and system preparation.

Before connecting the ECU check the following:

1. Install new spark plugs on engines that was standing for a long time.

2. Service and test the injectors to ensure they all have the same fuel delivery and that the filters on them are clean.

3. First ensure that the installation is correct according to the Hardware Installation manual.

4. Test the electrical wiring with a multi meter according to the Installation Testing Procedure.

5. Power up the fuel pump by loosening the fuel pump positive from the relay circuit and connecting it to 12V battery positive. Check the fuel pressure is around 3.5 Bar and check for fuel leaks. Reconnect to the relay.


Connecting the ECU for the first time

Now you can proceed with the following steps. If any steps do not correlate with the ECU operation, stop and look for the faults. Ensure that the ECU is earthed!!! Notice that there may be steps not applicable to certain ECU's. Then you may skip them.

1. Remove all the fuses. If it is an easy install harness with a common fuse on the main lead then disconnect the coils, injectors, fuel pump etc. from the power relay.

2. Ensure that the Jumper Settings are correct for that ECU.

3. Connect only the input connector P1 connector leaving the output connectors open. On Mercury2 you may also connect the P4 6way connector. Switch the Ignition on. Do not start the engine. The yellow LED on the ECU must come on. Also the blue LED on the idle stepper control unit must come on, if it is installed. If the yellow LED does not come on switch the ECU off immediately as there may be a short on the 5 Volt output that will damage the ECU in time. Then on Pluto2 and Saturn, the green LED will also come on and switch off. This will indicate that the ECU has a legal program loaded and the processor is running. Note: On Mercury2 the other 4 LED's are connected to drivers and do not come on with trigger signals.

4. Now switch the Ignition off and connect the Laptop with the USB cable to the unit. Switch the ignition on. Start the PC software and connect to the ECU. The engine data like the water and air temperature sensors should be displayed. It should read more or less correctly for the cold engine.

5. Go through the setup pages one by one and ensure that all the settings are correct for this engine. Especially the Trigger Level Output on Pluto2 and Saturn. This setting may damage the ECU or coils if set incorrectly!!! (Not applicable to Mercury2)

6. Ensure that the crank and cam angle sensors from the distributor or crank are set up correctly. Also their angle level selection must be rising or falling edge.

7. Check the Rotor Fazing if you have a distributor system. This will make electrical interference on the ECU and Laptop if it is set incorrectly.

8. Calibrate the TPS and Map sensors and save the calibration as described under active sensors.

9. Set the maximum RPM range and Map sensor type and range.

10. The Map sensor value should be reading the atmospheric pressure of your region. Check the Altitude chart for the correct pressure in your area.

11. Make sure the Test function next to the crank sensor is on.

12 You may now crank the engine without the other connectors. Check that the Green LED flashes on Pluto2 and Saturn. Also look at the RPM signal on the timing map. It should show 200 to 300 RPM constantly. If it shows erratic and runs wild, do not proceed. First find the fault. It must be constant with no errors. The vacuum bar should move slightly to the left of the graph while cranking at closed throttle.

13. Look if any error code is displayed at the bottom. If there are errors remedy the fault condition.

14. Save the data to the ECU if it has been changed.

15. Switch the ignition off and connect the other connectors.

16. Remove all the fuses. If it is an easy install harness disconnect the power on the injectors, coils fuel pump etc. Switch the ignition on. The relays will come on for three seconds then switch off again. If not, check the relay wire according to the drawing. If you have electronic relays, check that the LED on them must come on. Note on Mercury2 there are 3 relays with a free-wheel diode on pin 85 and 86.

17. Switch the ignition off and insert the fuel pump fuse. Start with 5A. If it blows check the wiring and try 7.5A as some pumps draw more power than others. Do not go to larger amp fuses as there may be a short somewhere.

18. Switch the ignition on, the fuel pump must start for three seconds and switch off.

19. Switch the ignition off and insert the coil fuses of 5A. If it blows check the wiring.

20. Now crank the engine with a timing light and check if the spark timing is in the 10°BTDC region. If not see the Calibrate Timing chapter for the correct setup. Do not attempt to start if the timing is not right or erratic. You may need to loosen the plug wire and make a small gap so that the timing light picks up the pulse of the spark plug. For coils that are bolted onto the plug, try using the trigger wire from the ECU. If this does not work, take a separate wire and wound it three times around the inductive pickup of the timing light and then insert this wire between the trigger wire and the coil input. This will amplify the signal three times so that it will trigger the timing light. Set the timing light to zero timing as wasted spark systems read double the degrees. This means if the timing light is adjusted to 20 degrees it is actually 10 degrees timing on the engine.

21. Switch the ignition off and insert the injector fuses of 5A. If it blows check the wiring.

22. Crank the engine. It should start. If the engine backfires or misses stop and do some checks. See the Trouble Shooting chapter to guide as to what the symptoms may be.

23. If your setup is correct the engine should start and idle smoothly.

24. Make sure the RPM is constant before revving the engine. If it jumps more than 300 rpm intervals, recheck the angle sensor's polarity. It must be steady. If it was error free during cranking without coils, it means the interference is now generated by the coils. See the precautions section on wiring tips.

25. Look at the exhaust. If there is black smoke, it is very rich. Try leaning it out on the water temp graph by lowering the dot closest to the yellow bar. The bar is interpolated.

26. Once the engine idles, calibrate the timing so that the Timing value on the software and the timing light on the engine is on the same degrees.

27. During the heating up faze, blip the accelerator from time to time. If the engine has a flat spot it may be lean and need some more fuel. Adjust the Fuel Graph till the flat spot reduces.

28. The blue LED in the idle control should go off once the target RPM is reached. If it keeps on flashing, then the ECU is trying to control the idling but nothing happens. It means the fault is on the idle side or motor. It may be a wiring fault or sticky stepper motor. It may also be a blocked airway or the throttle opening is too large. Remember for every 15% of enrichment on the water correction graph, the ECU will raise the set RPM's by 100.

29. As the engine heats up, the water sensor value must increase. Adjust the mixture on the water graph or by lowering the Fuel Graph till the engine is at normal temperature.

30. The water graph should now be around 85°C with no fuel enrichment. If it is not, you can calibrate the water sensor slightly on the setup page. The engine should rev up smoothly. If it has a flat spot it requires more fuel. Increase the Fuel Graph slightly till the flat spot is nearly gone. Also check that the timing is not the result of the flat spot. Check with the timing light that the timing increases as the software indicates.

31. Let the engine idle and adjust the Fuel Graph till it idles smoothly. Always try to make the mixture as lean as possible because it is difficult to see when it is too rich.

32. Save the data to the ECU. Also save a copy to the Laptop at this stage. The car may stutter and die. Restart again and proceed with tuning.


Frequently asked questions

Help >

FAQ Frequently Asked Questions

This chapter will shed light on certain areas where common mistakes are made or remedies on problems can be found. It is a general knowledge chapter and will have all the questions answered around the topic. It is systematically put forward and will guide you to the problem or to a point where the dealer can help you faster and not need to ask un necessary questions. If your answer is not there, please contact the dealer for help and let us know to answer that question for future use as well.


Spark Problems

Help > Frequently asked questions >

Spark Problems

Work through each point below to find your problem.

1. First ensure that the setup in galaxy is done according to the startup procedure . You came to a point where you want to start and everything is according to the startup procedure but there is no spark or weak spark. The timing bar should read around 10 degrees and there should be no errors.

2. Ensure that the coils are correctly powered from the ECU relay. Do not connect them from the original vehicle power. This may damage the coils during startup of the ECU.

3. Coils require a constant battery supply on their positive or supply terminal. This power is switched via a relay so that it is disconnected during an accident or power off condition. To check that this power is present put you multi-meter on DC volts at a scale of 20 or higher. Measure on battery negative pole and the coil positive terminal. Now switch the ignition on. The power relay will come on for 3 seconds then switch of. During this time you must read 12 volt on these points. If there is no volts or less than battery voltage check the wiring for bad connections. This is no load power testing.

4. If you have dumb coils (coils without drivers) do the same test as above but this time measure on coil negative. You should see 12 volt on this point too. If not it means the coil is dead or open circuit. Replace. Intelligent coils (coils with built in drivers) cannot be tested like this.

5. Sometimes bad connections will indicate that the power is present but during load conditions the power will drop due to high resistance that is formed by bad connections. So for load testing switch the meter to AC volts and measure at the same points as point 3 above. Crank the engine. During cranking there should be close to zero volts. If there are any volts above 2 it means that the power to the coils is fluctuating which could not happen because it is connected to the battery. This will indicate a bad connection in the power supply line during load conditions. Sometimes a bad fuse connection makes this voltage drop. With the same test procedure it could be tested backwards to the problem source. It could also be due to too thin supply wires that cannot hold the current that flows through them.

6. The next problem could be in the earth line of the coil current. Normally the driver supply earth to the coil momentarily to charge the coil and then break the earth connection to fire the coil. For dumb coils the earth is switched in the ECU or external coil driver. To test this put the meter on AC volts like above and measure between the ECU earth wire on the chassis or the external coil diver's earth. Again crank the engine and see if you measure any volts. It should be close to zero volts. Above 2 volts means a bad connection in the negative earth line during load conditions.

7. Now you have established that power and earth is present at the coil or driver but there is still no spark. This means that the trigger pulse is not coming from the ECU or driver. For dumb coils put the meter on the highest AC volts scale and measure on coil negative and battery negative. Crank the engine. You should read a voltage above 100 volts. This means the driver and primary coil works. If you put a sparkplug on the HT lead and let the plug earth against the engine you should be able to see the spark. If not then the coil secondary is dead or open circuit. If you did not see any volts during cranking it means the ECU driver is dead or it is not pulsed by the ECU for some reason in the setup maybe.

8. For intelligent coils measure the trigger signal to the driver side. Here you should measure 12 volts meaning that the ECU driver is pulsing the coil. If no spark then the coil driver is dead. If you did not see any volts during cranking it means the ECU driver is dead or it is not pulsed by the ECU for some reason in the setup maybe.

9. If you use an external driver and dumb coil then measure the trigger signal on the ECU side. Again it should be 12 volt during cranking. If not it means the ECU driver is dead or it is not pulsed by the ECU for some reason in the setup maybe. If there is a pulse measure the coil negative side for the hi-voltage pulse around 100 volt. Remember to put the meter on the higher voltage scale. If there is no pulse it means the driver is dead. Replace.

10. There may be 2 faults present. So finding one may only then present the other. Test from the beginning again.


Password required after upgrade

Help > Frequently asked questions >

Password required after upgrade

After you upgrade a product to Ver 3.5A it will ask for a Lock Password. The reason is that we moved critical settings to another part in the memory of the product, to facilitate the Clone Feature. Make sure never to upgrade a device with the outputs connected. The firmware may be set incorrectly on the outputs and it could damage the electronics or components connected to it. We strongly advice to read Memory handling and Cloning a Device in the manual.

To remedy this situation is save all the maps of the device beforehand and then clone the device with map 1 and load the extra maps in after that. This will ensure all your calibrations are reinstalled.

Related Links

Memory Handling

Cloning


Manual Problems with HTML

Help > Frequently asked questions >

Manual Problems with HTML

The manuals are written in HTML files. This cause anti-virus programs to suspect the data and sometimes block the content. Here are the problems that arise and how to get past them.

When downloading you may encounter this message. Select Keep.

When you open a manual you may find the list but no data.

Go to the manual file and right click on the icon. Select properties. Select Unblock and Apply.

Open the manual file again and now the content will show.


USB Cable History

Help > Frequently asked questions >

USB Communication Cable History

Communication between devices and the Tuning Software is done via a USB Cable manufactured by Spitronics. The electronic components for communication was put in a separate cable to reduce production cost and board space on the devices. The cable can work on all the current devices and are only required for tuning. The electronics in the cable consist of the USB converter as well as isolation devices. This cable will protect the laptop during high voltage interference. This cable requires drivers to be installed to operate on a laptop. They can be downloaded from the Spitronics website under Downloads - USB Drivers. The baud rate to all products are 19200.

As development progressed over the years these products were upgraded as well. Spitronics started out when USB was only in the beginning stage and very expensive to use on micro design level. They started out using a standard USB to RS232 converter for laptops that did not have serial ports. Nowadays these serial com ports are discontinued so the RS232 were abandoned and changed over to UART directly. This saved the 2 RS232 chips. One in the cable and one on the device. Later we found that during tuning the 9pin D-Sub connectors were coming loose during tuning and were also prone to static discharge doe to the metal housing. So they changed to the clip-in Molex connector which is the current cable and will stay like that for a while. So keep in mind that cables between the products do differ. In some cases, you may require an adapter to use the USB cable on older products. See below for explanation on the different types over the years. The current cable (left) clips into the device and won't fall out during tuning. It will also not be vulnerable to statics as the metal counterpart. This will be the style for the future.

History

1. TCU, EMU and Titan units were the fore runners. They used a RS232 to USB converter with a 9 Pin Male D-Sub connecter. With these units you had the option of a third party converter and breaking out pins. Note that this connecter is the same as the Mercury and Neptune one but the cable electronics is different. The electronics is not compatible with Venus, Mercury, Mercury2, Neptune, Neptune2, Pluto or Pluto2. Mark them properly so that you do not get confused. It may damage the other devices as higher voltage levels were used. Below is a picture of the cable and connecter.

The Prolific RS232 to USB converters were popular in the old days and could be used only for TCU, EMU and Titan units. Note however that you had to break-out pins 1, 4, 6, 7, 8 & 9. This is due to other connections from the ECU to the 9 pin D-sub connector. Use a small screwdriver and bend them outwards and then inwards till they break out. Do not damage the other pins. There are small numbers inside. Below is an illustration of the layout.

If you have the skills and equipment like a hot air de-solder machine, you may modify your TCU or Venus to work with the new style USB/UART cables. You need to install two connection links as well. Then you will require also the converter cable and maybe adapter to make the connection to the 9 pin D-Sub. Do mark the box that it is now using the new cable so that other dealers can see if they work on it. Below are photos that illustrate this modification. Blue is TCU and green is Venus.

2. Venus used a USB to UART converter with a 9 Pin Female D-Sub connecter. This was to stop confusion and the different connectors was easy to identify the product it was used for. But the male pins on the ECU were susceptible for static spikes. During the era of the Venus the cable changed to the isolation cable due to laptops that "hang" with interference wiring. Some of the cables had the electronics in the wire covered with heat shrink and most have it in the D-Sub holder. Below is a picture of the cable and connecter.

3. Mercury, Neptune and Venus2 were using the same electronics as the Venus cable except with the 9 Pin Male D-Sub connecter. We changed this unit back to the standard connector due to static electricity on the male pins that were exposed. Spitronics do solder the 9 Pin D-Sub connecters back to back to make USB converters between Venus, Mercury and Neptune compatible. See further in this section for details. Do not use a gender changer as the pins are mirrored and will not work. Below is a picture of the cable and connecter.

4. Pluto, Pluto2, Mercury2 and Neptune2 use the new generation cable. It will be standard to all the new products released. Here Spitronics have done away with the D-Sub connecter and go for a 6 Pin Molex connecter which is the same type as the harness connectors. The reason is it is plastic which eliminates the static connection with the human body and it clips in place preventing it from falling out during tuning. It is also more durable. With this cable the electronics is also in the wire covered with a plastic enclosure. Again these USB cable's electronics is compatible with Venus, Mercury and Neptune. You only require a converter cable harness to make it work. Below is a picture of the cable and connecter.

Converter Cables

Spitronics made converter cables to interchange cables between similar products.

The cable below could convert your Mercury, Neptune and Venus2 USB cable to fit the new Pluto, Pluto2, Mercury2 and Neptune2 products.

The cable below could convert your Pluto, Pluto2, Mercury2 and Neptune2 USB cable to fit the older Mercury, Neptune and Venus2 products.

These bare connectors could be soldered back to back in male/male or female/female pairs to cater for Venus2 or Venus Racing cable converters. The heat shrink only covers the pins. Solder all the pins in 9 pairs.

Note that only the Spitronics USB cables are compatible with their products. They are not expensive cables.


Dual Drive by Wire Throttles

Help > Frequently asked questions >

Dual Drive by Wire Throttles

Due to the number of questions I decided to discuss this setup in details.

Dual throttles was designed to split mostly V engines to run it as two separate engines. The V12 and some V8 engines used this setup. The advantage is in cruise mode one throttle operate independently from the other and can reduce fuel consumption by taking the load of half of the cylinders. It may also help in low power use to control a single throttle more effectively than one large throttle. There may be more reasons unknown to me.

These engines have two intake plenums and they are not shared with vacuum. This means that the two throttles is not balanced and does not produce the exact same manifold pressure. This will then require two MAP or MAS sensors and separate fuel calculations. Which means two ECU's which are difficult to setup and tune.

To run this engine with a dual throttle and one ECU will be impossible. You will have to modify the intake to add a runner between the 2 manifolds. This may influence the air flow dynamics of the manifold. The other option is to add one larger throttle and split it to the two intake pipes. I've seen this plenty of times and were done professionally. It is in my opinion the better modification.

Due to this information we have not developed dual TxW as you can see it will require mechanical modifications. I stand to be corrected.


Trouble Shooting

Faults and Remedies

The ECU yellow LED does not come on

  1. The ignition wire does not have 12Volt
  2. There is a short on the 5 Volt output from the ECU. The magnetic crank or distributor sensor, TPS and MAP sensor all use this 5 volt. Check the wiring.

The Software does not connect to the ECU with the USB Converter

  1. Ensure that the yellow led on the ECU is on. Check the cables are fully inserted.
  2. No Driver for this Device installed - The USB converter must have a driver CD which has to be installed first.
  3. Faulty device settings in the Hyperspace software.
  4. Faulty USB converter.
  5. Faulty ECU.

The engine does not start for the first time

  1. Check for error codes . This is always the first place to look and a good indication of the problem.
  2. Go through the Startup Procedure to ensure ECU operation is correct.
  3. If you crank the engine and it does not want to start, disconnect the high tension leads at the spark plugs one by one and check for spark on the plugs. Use another sparkplug in the lead and hold the earth onto the engine. If no spark:

a. Check on the laptop and see if there are no errors. Make sure there is 200 rpm while cranking. If not, check the crank or distributor signals. Air gaps of the magnetic sensors to gear may be too large.

b. Check if sensor polarity is correct.

c. Check if the fuel and coil relays pull in at ignition on. If not check that the numbers on the relays are correctly wired. Electronic relays have a LED that will come on at Ignition on.

d. Test if the coils have positive supply +12 Volt when cranking the engine.

e. Test the coil resistance from the relevant connector to see if there is an open circuit.

f. Test the coil to see if it is faulty.

g. If it is distributor type, check the spark at the coil HT pole.

  4. If there is spark, take out one of the spark plugs. If it is dry it means there is no fuel. Check for:

a. Check on the laptop and see if there are no errors.

b. Look at the injector milliseconds bar. It should indicate that the ECU is injecting fuel at around 10 milliseconds during cranking.

c. Ensure the fuel pump is running during cranking. If you switch ignition on it should pump for 3 seconds.

d. If it shows zero milliseconds, check the map calibration, TPS calibration, fuel cut off function settings. There should be an error code helping you to identify which control program prevent the injectors from pulsing.

e. Test the fuel pressure by loosening a bolt on the fuel rail somewhere. Hold a rag over the joint to prevent spillage. Keep a fire extinguisher close by.

f. Ensure that the injectors were checked and serviced if the engine stood for a long time.

g. Put your fingers on the injectors and feel if they pulse during cranking.

  5. If the plugs are wet, it means there is fuel. Check the following:

a. It may be that the start fueling was too much and the plugs were flooded. Dry them and try again. You may also push the throttle in completely and crank the engine till it starts or the plugs becomes dry.

b. It may be that ignition timing is setup incorrectly. Then firing occurs at the wrong time and failing to ignite the fuel mixture. Check the timing setup again for the specific engine.

c. The plugs may be old or dead. Replace.

  6. If the engine tends to stop cranking suddenly, check the following:

a. It may be that the timing is too fast. Reduce timing by 10 degrees. Add more teeth if a crank gear is used.

b. If there is a magnetic crank or distributor sensor, check that positive and negative wires are not switched around.

c. If more than one coil is used, check for incorrect wiring or firing order.

Engine Backfires during Cranking

  1. Check for error codes. This is always the first place to look and a good indication of the problem.
  2. The engine backfires through the intake.

a. Faulty ignition timing or firing order. Check again the timing setup for the specific engine.

b. If there is a magnetic crank or distributor sensor, check that positive and negative wires are not switched around.

c. If more than one coil is used, check for incorrect wiring or firing order.

d. Check if the RPM bar jumps erratic in the PC software. If it does, the gap of the magnetic sensors may be too large or the signal is too weak or interference from the ignition coils.

e. If it is a distributor check rotor phasing and that it is on the correct cylinder at TDC.

  3. The engine backfires through the exhaust.

a. Too lean fuel mixture. Increase by 10 at a time on the fuel ratio adjuster.

b. Water temperature sensor or compensation map incorrect.

c. Some of the plugs may be old or dead. Replace.

Engine start but it stalls directly afterwards

  1. Check for error codes. This is always the first place to look and a good indication of the problem.
  2. Check the map sensor in the fuel map field is operating. The olive color bar should be on your altitude pressure value. If not, it may be a calibrating error or faulty wiring.
  3. The fuel mixture may be too lean. Try to enrich using the fuel ratio adjuster.
  4. The temperature sensor may be faulty causing the cold engine to give a warm signal to the ECU. Thus leaning the mixture out.
  5. Incorrect Fuel Cutoff settings. A symptom will be that the milliseconds bar on the real time block will jump to 0.
  6. Incorrect Engine Limiter settings

Engine start but is very rich

  1. Check the map sensor in the fuel map field is operating. The olive color bar should be on your altitude pressure value. If not, it may be a calibrating error or faulty wiring.
  2. The fuel ratio adjuster is set too high. Start with 100%.
  3. Check if the water temp sensor is working. If not, it will keep on enriching the mix as if for a cold engine.
  4. Some of the plugs may be dead, and then the engine loses manifold vacuum resulting in enriching the other cylinders.
  5. Fuel maps tuned too high. Lower the values.
  6. Fuel pressure regulator regulates too high. Measure the pressure. It should be between 2.5 and 3.5 bar.

RPM signal very erratic.

  1. Check for error codes. This is always the first place to look and a good indication of the problem.
  2. Incorrect magnetic trigger polarity.
  3. Interference on pickup. See also Precautions.

Engine start but do not rev up

  1. Check for error codes. This is always the first place to look and a good indication of the problem.
  2. Check the map sensor in the fuel map field is operating and calibrated. The olive color bar should move to the right if the throttle is pressed.
  3. Too lean mixture. Try increasing the main jet value.
  4. Rev limiter is set too low
  5. Check the micro fueling and boost limiter blocks and see if the settings there are correct. A symptom will be that the milliseconds bar on the real time block will jump to 0.
  6. The Fuel Cut-Off settings are wrong.
  7. Incorrect rotor fazing or timing. Check with a timing light.
  8. The magnetic crank or distributor sensor's negative and positive wires are changed around. The gap may be too large.
  9. Fuel pressure or flow rate to low. Dirty fuel filter.
  10. Faulty fuel pump.

Idle Control does not work

  1. Check if the wiring is correct as indicated on the drawing. If it is an idle valve, make sure the diode is intact. If it is a stepper controller, make sure the sequence is wired correctly. It may try to close instead of open.
  2. Faulty TPS setting. Make sure the TPS is calibrated correctly. It must go from 0 to 100% over the full range.
  3. Check the idle control settings according to the idle control explanation.
  4. Make sure that the throttle position is set correctly at idling. The idle valve can only close as much as this setting.
  5. Check if the idle valve or stepper motor is not stuck. The idle valve can be pulsed with 12Volt to see if it opens and the stepper normally vibrates when the ignition is switched on. It may still be stuck even if it vibrates. So take the stepper off and see if it opens.
  6. If the blue LED on the stepper idle controller is constantly on during idle, it means that the idle computer does not receive the RPM pulse from the ECU. Recheck the wiring.
  7. If the blue LED on the idle controller flash it means that the idle computer tries to adjust the RPM but nothing happens. The idle motor itself is sticky or wired incorrectly. Open it up and clean and lubricate. With the long shipment on ships it corrodes on the inside. The wiring to the idle motor may be incorrect. The airway of the idle motor is blocked.

The Automatic transmission does not shift

  1. Connect to the TCU and see if the TPS and RPM signals are present. If not, ensure the correct wiring connections between the TCU and ECU are correct.
  2. See the relevant TCU manual for information.

Spark plugs does not last

  1. Fuel mixture too rich.
  2. Wrong temperature plugs.
  3. Charge time too long. Reduce the time.

Flat Spot when accelerating

  1. Another vacuum line tied into the Map sensor line.
  2. Restricted vacuum line.
  3. Vacuum line too long.
  4. Too small port for Map sensor on intake manifold.
  5. Incorrect fuel setting of maps or accelerator pump.

Engine lack power, idle erratic, or runs lean

  1. The fuel pressure is erratic. This may be due to the pump sucking air on the in feed which causes cavitation and loss of pressure. This happens more frequent when the engine is hot.
  2. Injector positive is wired incorrectly. It does not have its own supply direct from the battery via relay 1.
  3. Incorrect setting of fuel maps.
  4. Fuel pressure or flow rate to low. Dirty fuel filter.
  5. Faulty fuel pump.

ECU cuts and start erratic or randomly during driving - See Electrical Interference

Copyright © 2013. All rights reserved.


Quick Links

Help >

Quick Links

Air Temp | Software | Hardware |
Altitude | Software | Hardware |
Anti-Lag | Software | Hardware |
Cloning | Software |  |
Coils | Software | Hardware |
Crank & Cam | Software | Hardware |
Flat Shift | Software | Hardware |
Fuel Pump | Software | Hardware |
GP Outputs | Software | Hardware | Priority
Idle | Software | Hardware | Tuning
Injectors | Software | Hardware |
Lambda | Software | Hardware |
Launch | Software | Hardware |
MAP | Software | Hardware |
POT | Software | Hardware |
TPS | Software | Hardware |
Tuning | Software |  |
Water Temp | Software | Hardware |


Introduction

Safety Precautions

The following guidelines in this manual will ensure proper product operation the first time. Failure to install the product correctly may damage it or other equipment permanently. These failures will solely be the responsibility of the installer and no guarantees will be given by us. Make sure you have read the Terms and Conditions in this manual or on the website www.spitronics.co.za before you install this product. By installing the product you automatically agree to these conditions. All equipment is tested before it leaves the factory. We accept no liability for malfunctioning of the equipment, or to injury that may result from installation or the use of the equipment. We also accept no liability for costs of traveling of transportation of the equipment or parts or vehicle recovery due to failures of any equipment. Please read the instructions and drawing and make sure you understand before you begin.

2.1 Operator Safety

  • Use only proper tools and products suited for auto installations. Substandard products and installation procedures may cause failure to the equipment having your customer break down in dangerous areas.
  • Use correct thickness of wire to carry the entire current requirement for that circuit. Too thin wires will heat up and may start a fire causing injury.
  • Use fuses to protect each circuit separately. Joint circuits require large fuses which may heat and melt lesser circuits causing fires.
  • Solder joints, and cover it with shrink sleeve to prevent loose connections which may cause fires. Space solder-joints so that they do not sit next to each other in the harness thus minimizing the chance of a short circuit.

See the individual Safety Precautions for each product.